mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik ext.Netzteil - USB Stromversorung


Autor: Lars L. (ursomat)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
Zusammenfassung des Problems:
Ich hätte gerne USB-Geräte mit einem Schaltnetzteil versorgt, müsste 
also vielleicht zwei Spannungquellen koppeln, die Hauptfrage ist, wie 
ich das machen kann.


Projekt:
 Ich habe mir ein PC-Gehäuse umgebaut, weil ich einige punkte an den 
klassischen Towers unpraktisch finde (z.B. dass alle Anschlüsse ganz 
hinten ganz unten sind). Ein weiterer Punkt der mich gestört hat ist, 
dass die Wechsemedien (DVD, Zip, Diskette, ggf. Wechselrahmen, 
Cardreader, USB-Hubs) im Gehäuse sind, so muss man den PC immer leicht 
zugänglich haben. Zudem hab ich ein LCD-Display für einen 5,25" Schacht, 
das will ich zusammen mit den Wechselmedien auf dem Schreibtisch in 
einem mittelgroßen Festplattengehäuse stehen haben. Dazu habe ich mir 
Gehäuse gekauft mit 5x5.25" schächten (ursprünglich ein externes 
SCSI-Gehäuse), das Gehäuse hat ein Schaltnetzteil, wie ein normales 
AT-Netzteil nur ohne die Mainboard-Anschlüsse.
In diesem Gehäuse habe ich nun
TEIL (Anbindung):
DVD-LW (eSATA), HD-Wechselrahmen (eSATA), Cardreader (USB), 
LS-120-Floppy (USB), Zip-LW (USB), LCD-Display (USB). zusätzlich habe 
ich noch vorne und hinten je ein USB-Hub. Die eSATA-LWs machen keine 
Probleme, die laufen gut mit dem Netzteil des externem Gehäuses.

Für die USB-Geräte habe ich 2 USB-Kabel vom Rechner zu diesem externen 
Gehäuse gelegt, die gehen auf 2 Hubs im inneren des Gehäuses, diese 
wiederum versorgen die Hubs, die nach außen gerichtet sind und die 
Laufwerke. Der genaue Aufbau tut nicht viel zur Sache denke ich.

Problem:
 Das Problem ist der Strom für die ganze USB-Geschichte, bzw die 
Spannung. Beim LCD-Display reagiert der Kontrast sehr empfindlich auf 
Spannungsverlust, also wenn ich statt 5V nur 4,8V habe kann man die 
Schrift kaum noch lesen.
Wenn ich also das Display und die 4Hubs+Cardreader an den 2 USB-Kabeln 
hängen habe bekomme ich am Ende eine Spannung von 4,3V, (jeder 
Verbraucher senkt die Spannung um etwa 200mV) damit ist es auch zu wenig 
für die USB-Specs. Es war auch zu erwarten, dass 2 USB-Ports nicht genug 
Strom liefern können, die Frage ist, wie man da Abhilfe schaffen kann.

Meine gescheiterten Versuche:
1. Die USB-Hubs im externen Gehäuse mit dessen Netzteil befeuern. Die 
Hubs haben einen Anschluss (Hohlbuchse) für eine externe 
Stromquelle(Steckernetzteil), daran hab ich das Netzteil des externen 
Gehäuses geschlossen. Die Hoffnung war, dass das Nezteil die 
Stromversorung übernimmt, wenn die Spannung unter 5V fällt. Das problem 
ist, dass dieses Netzteil nicht angeht wenn schon von außen Spannung 
anliegt sondern es fiept nur (könnte mir vorstellen, dass das normal bei 
PC-Schaltnetzteilen ist).
2. Wie 1. nur mit einer Diode dazwischen, nur an der Diode fallen 0.7V 
ab, also komme ich auch damit nicht über 4,3V.
3. Stromversorgung über USB abklemmen und nur über das Netzteil im 
externen Gehäuse befeuern. Klingt nach einer sauberen Lösung, nur 
erkennt er dann die USB-Geräte nicht, nichmal die Hubs, könnte daran 
liegen, dass bei USB die unterscheidung zwischen USB1 und USB2 Geräten 
über widerstände läuft, die zwischen Datenleitung und Spannung oder Erde 
liegen. Das könnte man versuchen nachzubauen... das hab ich noch nicht 
probiert.

4. Extra Stromkabel aus dem Rechner in das externe Gehäuse legen. 
Funktioniert fast, also der Spannungsabfall ist deutlich geringer, nur 
über 4,8V am Ende bin ich auch nicht gekommen, und für das Display hätte 
ich schon gerne fast 5V. Außerdem ist das keine allzu schöne Variante.

Ich habe noch ein paar Ideen für Mischlösungen, bespielsweise einen 
Stepdown-wandler, den ich auch 5.7V stelle, dann eine Diode (5V), dann 
habe ich die 5V für das Display, nur alles kann ich nicht an einem 
Step-down-wandler betreiben, weil ich keinen über 2A gefunden habe, 
daher wollte ich euch erstmal fragen, meine Kenntnisse in E-Technik sind 
doch sehr bescheiden.

Danke schonmal für eure Ideen

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
USB Stromverbrauch ist limitiert lt. Spezifikation.
http://de.wikipedia.org/wiki/Universal_Serial_Bus#...

Autor: Lars L. (ursomat)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Genau das führt zu meinem Problem... Ich muss ja auch jedem USB-Gerät 
die 500mA zur Verfügung stellen, die müssen also irgendwo herkommen, 
daher brauche ich eine zusätliche Stromquelle (siehe oben).

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.