mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Feuchtigkeitssensor an langer Leitung


Autor: Bastelnder Manne (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,
ich habe mir eine kleine Wetterstation gebaut. Leider macht der 
Luftfeuchtigkeitssensor Probleme. Er geht bei etwa 80% rH in die 
Begrenzung (siehe Anhang). Das Sensorsignal geht über eine ca. 10m lange 
Leitung (8-adrige Steuerleitung mit Schirm) auf einen A/D Wandler 
(fertig gekaufter 4-Fach Analogeingang für EIB-Bus, 0-5V). Der Sensor 
wird mit 5V versorgt (7805). Von den Spannungen sollte es also passen.
Ich vermute, daß der Sensor ein Treiberproblem hat mit der langen 
Leitung. Mein Plan ist es, eine OP als Spannungsfolger dahinter zu 
machen, der dann die Leitung treibt, was jedoch mit relativ hohem 
Aufwand verbunden wäre (aufs Dach steigen, Platine ausbauen,...). Daher 
hätte ich gerne einige andere Meinungen zu dem Problem gehört, 
vielleicht bin ich ja auf dem falschen Dampfer. Das Datenblatt des 
Sensorsist hier als pdf abrufbar:

http://sensing.honeywell.com/index.cfm/ci_id/14057...

Es wäre klasse, wenn jemand eine Idee hätte (falls Spannungsfolger, was 
für ein OP für diesen Fall geeignet)

Gruß Manfred

Autor: Bernd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Das Sensorsignal geht über eine ca. 10m lange
>Leitung (8-adrige Steuerleitung mit Schirm) auf einen A/D Wandler
>(fertig gekaufter 4-Fach Analogeingang für EIB-Bus, 0-5V).

Was hat der für Specs'? Erfüllt er die Minimum Load Anforderung vom 
Sensor?

Autor: Bastelnder Manne (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Was hat der für Specs'? Erfüllt er die Minimum Load Anforderung vom
>Sensor?

Guter Tip! Muss ich checken. Aber würde der Effekt dann nicht auch schon 
im unteren Bereich auftreten?

Autor: Bernd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Guter Tip! Muss ich checken. Aber würde der Effekt dann nicht auch schon
>im unteren Bereich auftreten?

Sag das nicht. Da sind oft stromsparende Fantasieschaltungen drin, die 
sich völlig idiotisch verhalten können...

Autor: Bastelnder Manne (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da fällt mir gerade noch ein, daß vielleicht die Versorgungsspannung 
"absäuft". Die geht über diesselbe 10m Leitung nach draussen. Vielleicht 
läuft der Sensor einfach gegen die Versorgungsspannung, weil draussen 
keine 5V mehr ankommen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.