mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Störung durch Transistor?


Autor: Werner Maier (wmaier)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe die Schaltung im Anhang aufgebaut. Leider verhält Sie sich 
nicht wie erwartet. Eigentlich dachte ich, dass ich aus der 
Rechteckspannung mit 0 und 22V eine Rechteckspannung mit 0 und 5V 
erhalte. Dies funktioniert auch im Groben. Doch leider nicht im Feinen. 
Ich bekomme starke Schwinger kurz nach dem "Umschalten" des 
Rechtecksignals; und zwar an beiden Messpunkten (A UND B).
Das seltsame für mich ist hier vor allem, dass ich sogar an dem 
Messpunkt A diese Über- und Unterschwinger habe. Diese verschwinden an 
diesem Messpunkt, wenn ich an diesem Messpunkt die Basis des Transistors 
auftrenne. Dann ist ja links nur noch ein Spannungsteiler. Folglich muss 
sich der Transistor irgendwie auf die Spannung am Spannungsteiler 
auswirken; aber wie? Und wie kann ich die Schaltung abändern, dass dies 
funktioniert.

Danke

PS.:
Ich weiss, dass ich den rechten Teil der Schaltung weglassen könnte und 
über eine etwas andere Dimensionierung des Spannungsteilers eine 
Konvertierung des Rechtecksignals erreichen könnte. Doch ich möchte 
diese Schaltung und die seltsame Rückwirkung verstehen.

PPS.:
Die Simulation in PSpice hat diese Phänomen übrigens nicht ergeben. Dort 
klappt es wie vermutet ohne Überschwinger auf der Eingangsseite.

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wird sicherlich durrch die sogenannte Miller-Kapazität (zw. C und B) 
verursacht. Überschwinger kann ich mir aber trotzdem nur bei ungünstigem 
Aufbau vorstellen (lange Strippen am T, und vielleicht sogar in parallel 
verlegt.
Auch mal die BEtriebsspannung direkt an der Schaltung mit einem C 
abblocken (100n und/oder 10µF).
Ansonsten Basisspannungsteiler niederohmiger machen.

Autor: Werner Maier (wmaier)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
mit Abblocken der Betriebsspannung mit einem Kondensator meinst du doch 
einfach einen Kondensator von der Betriebsspannung zu Ground zu 
schalten!?
Eine etwas längere Leitung ist wirklich am Messpunkt B angeschlossen. 
Leider aber keine Kabel. Ich kann es also nicht einfach so entfernen. 
Der Spannungsteiler war inital schonmal höherohmiger. Doch leider hat 
die jetzt schon runterdimensionierte Schaltungsänderung nichts gebracht. 
Ich werde dann wohl noch weiter runtergehen.
Danke

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>mit Abblocken der Betriebsspannung mit einem Kondensator meinst du doch
>einfach einen Kondensator von der Betriebsspannung zu Ground zu
>schalten!?

Ja.
Und immer schön die Oszimasse kurz halten. Also die Masse vom Tastkopf 
direkt mit der Schaltung verbinden, und nicht mit einer langen Leitung 
vom Oszi zur Schaltung verbinden. Das ergäbe nämlich bei relativ steilen 
Impulsen dann auch schöne Schwinger.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.