mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit Motoransteuerung


Autor: Retro (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Abend.

Ich habe folgendes Problem:
Ich steuere mit meinem Mega32 und 2 L6203 zwei DC-Motoren an.
Einen kleinen und einen größeren. Beide mit Getriebe und 12V Versorgung.

Nun habe ich das Problem, wenn ich den größeren anspreche, dass mir die 
ganze Spannung für den µC zusammenbricht. Die Versorgung für den µC wird 
über einen 7805 von die 12V heruntergeregelt.

Hab es auch schon mit einem 3A-Netzteil versucht, da ich vermutete, dass 
das alte Netzteil daran Schuld war, welches nur 500mA lieferte.
Denn der große Motor kann lt. Datenblatt 3A ziehen.

Man hört ganz kurz ein Klacken des Motors, dann is es aus da der µC 
neustartet, wegen dem Spannungszusammenbruch.

Was kan hier falsch sein? Passt es dem 7805 nicht dass seine 
Eingangsspannung auch die Versorgung für die L6203 sind und somit die 
Motoren speisen?

Layoutmäßig kann nichts falsch sein, denn probiere ich den kleinen Motor 
an der Klemme für den größeren, funzt es.

Jedoch, als ich ein Batterieladegerät verwendete, dass unter Last 14V 
lieferte, funzte auch der kleine Motor manchmal nicht. Der kleine zieht 
etwa 50mA.

Hat jemand eine Ahnung was hier falsch sein könnte?

Danke schon im Voraus!

Autor: G a s t (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Motor wird sich zum Anlaufen einen kräftigen Schluck genehmigen 
(mehr als 3A). Wenn du an den Eingang vom 7805 einen größeren 
Kondensator hängst und eine Diode zwischen 12V und Eingang, so dass der 
uC eine Weile aus dem Kondensator leben kann, sollte der Spuk vorbei 
sein.

Autor: Retro (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Diode habe ich vor dem 7805.
Kondensator derweil 100µF + 2* 100nF.

Kann ich den hohen Anklaufstrom auch messen? Oder geht das so schnell 
dass ich mit dem Multimeter nicht erkenne?
Denn ich messe eine Stromaufnahme beim großen Motor am Anfang von 1,2A, 
die dann auf 0,8A abflauen.

Oder sind diese Ströme zu hoch?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.