mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Gleichrichtung und Verstaerkung


Autor: Peter (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe vor, ein PWM Signal zu glaetten und danach um den Faktor 2 zu
verstaerken. Ich habe mal meinen Schaltplan angehangen, leider
funktioniert die Sache so nicht...

Auf der Skizze ist ein Kanal zu sehen, ich habe 2. an dem einen OP
liegt eine Eingangsspannung von 2.4 Volt zwischen + und Masse, an dem
anderen 4.8V. Misst man aber zwischen den Ausgaengen und Masse, so
liegen bei beiden OPs 1.2V an.

An OP 1 sollten allerdings 4.8 und an OP 2 9.6V anliegen. Kann mir
vielleicht jemand bei diesem Problem weiterhelfen?

Autor: TravelRec. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
10 Ohm ist vielleicht ein klein wenig zu wenig Widerstand, 10kOhm klingt
besser, schafft dann auch der OP. Versorgungsspannung des OP ist
symmetrisch, ja?!

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ja, Versorgungsspannung ist symmetrisch, es scheint, dass der
Verstaerker bis 1.2V normal 2 fach verstaerkt, aber darueber hinaus
halt nicht. Koennte das an den Widerstaenden liegen (10 Ohm)?

danke schonmal

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach, ich meinte Versorungsspannung des OP ist einseitig, ist ein rail
rail Verstaerker, also nur einmal 12V angeschlossen, die andere auf
Masse...

Autor: Gerd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Peter,

die Widerstände sind zu klein. Rechne doch mal den Strom aus,
der da fließt. Nimm 10k, dann funktioniert das ganze. Übrigens
nehme ich gerne den LM324 für solche Aufgaben, der ist billig,
und man kann ihn bis zur negativen Versorgungsspannung nutzen.

Gerd

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

wollte mich noch bedanken fuer die Hilfe, jetzt klappt die Schaltung
auch :)))


Gruss, der Peter

Autor: Arno (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Warum gehst Du nicht mit Deinem PWM-Ausgang auf die gewüschte Spannung
und glättest dann? Die Spannung hast Du ja als Betriebsspannung für die
OPV da.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.