mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik meine light cube schaltung geht nicht


Autor: hans müller (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
also ich habe mal probiert einen light cube zu bauen und probe halber
eine schaltung auf dem steckbrett aufgebaut (siehe bild). Doch nun ist
mein problem: die leuchtdioden leuchten nicht richtig. (wenn nur eine
leuchten soll, dann tun das alle, aber unterschiedlich hell.
habe die schaltung schon mehrmals aufgebaut auch die kreise geändert,
hat aber nichts gebracht.

Was mach ich falsch? Gehen die BC4547C und BC557C überhaupt dafür?

Autor: Dirk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

bei einem NPN Transistor gehoeren die LED's an den Kollektor.

mfg
Dirk

Autor: Bri (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was soll die Schaltung eigentlich machen?

Autor: Uwe Nagel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mit Sicherheit ist beim unteren Transistor Kollektor und Emitter
vertauscht.

Autor: edi-edi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Leddiewillikillerschaltung

Autor: Bri (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ edi-edi
LED-Burn-O-Mat

Autor: Peter Dannegger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das 5V Netzteil sollte aber mindestens 1A können, damit die LEDs auch
schön schnell durchbrennen.


Ich weiß wirklich nicht, was denn daran so schwer zu merken ist, daß
LEDs grundsätzlich immer mit Schutzwiderständen beschaltet werden
müssen.


Peter

Autor: edi-edi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter,
es geht immer um's Sparen.
Vergewaltigung der Technik.
Edgar.

Autor: Edgar Renner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...vieleicht gibt's da Widerstände zu den LEDs.

Die Schaltung schaut aus, wie wenn Sie mit Paint und einer Mouse
(zusammengewackelt) gezeichnet wurde. Eine sehr mühsame Technik :-( Und
dann sind vieleicht die Widerstände nur nicht eingezeichnet, weils zu
viel Arbeit gemacht hat.

@hans müller: Gi9bt's da einen konkreteren Schaltplan?

Edgar

P.S. Bei LEDs geht auch anstelle von Vorwiderständen eine
Konstantstromquelle. Das ist aber noch teuerer.

Autor: hans müller (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
danke dirk, danke uwe.

ja, die schaltung ist mit paint "zusammen"-gewackelt (bin in der uni
und die haben in dem pool kein schaltplan-prog installiert) und
desshalb keine widerstände (das denke ich versteht sich von selbst den
strom zu begrenzen auch den basisstrom - was hier noch nicht mal von
den "meckerfritzen" angekreidet wurde ;) )...

einen konkreten schaltplan gibt es leider nicht, halt nur die
eck-daten:
jeweils n Matrizen von LEDs mit der Größe n*n, bei den LEDs sind alle
Kollektoren oder Anoden (je nach dem, wie es sich ergibt) je
Matrizen-Ebene zusammengeschlossen und für jede Ebene soll es einen
Transistor geben, der die gesamte Ebene ab oder anschalten kann.

Also, nun ein erneuter Versuch - müsste die Schaltung so korrekt
sein?(wieder keine Widerstände - bevor wieder jemand gehalb etwas
sagt)

Kann es auch sein, dass mein uC irgendwie (durch parasitäre Kapazitäten
in der Schaltung) zu schnell ist und die BCs nicht hinterher kommen
(aber warum steht dann in dem simulations-programm bei beiden Typen
"300MHz switching transistor?")

Autor: Dirk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

so ist es richtig

Mfg
Dirk

Autor: Stephan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Probier mal bei Deinem PNP-Transistor oben (sozusagen Dein
"High-Side-Switch") einen 10kOhm-R gegen 5V, und in Reihe zur Basis
ein 2,2kOhm-R. So funktioniert es bei mir in einer ähnlichen
Konstellation.

Stephan.

Autor: hans müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
die takt-frequenz war zu hoch (jetzt bei ca 0.75 MHz.

was sagen die 300 MHz in der bezeichnung der Transistoren aus? Wenn das
die Schaltzeit ist, wie kann dann die Taktfrequenz zu hoch sein (hatte
erst ca. 1.5 MHz)?

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die 300MHz ist der Wert, bei dem die Verstärkung in Emitterschaltung 1
ist. Ist also leicht zu messen, aber kein praktischer Betriebswert.

Im Digitalbetrieb ist es aber noch viel weniger, da da der Transistor
in die Sättigung gefahren wird und das dauert.

Ich nehme deshalb gerne die Kollektorschaltung, um LEDs zu treiben, da
dort der Transitor nicht gesättigt ist und dann treten keine
Schattensegmente mehr auf.


Peter

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.