mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Netzteilproblem: unerklärbare Nadelimpulse


Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe einen Prüfautomaten der mechanisch/pneumatisch aufgebaut ist.
Zur Steuerung des Automaten (NotAus, Ventile, Schütze, Relais, etc...)
ist ein 24V-Schaltnetzteil eingebaut. Dieses übernimmt ausschliesslich
die Steueraufgaben.
Zusätzlich ist ein 5V-Schaltnetzteil drin das nur primärseitig mit dem
24V-Netzteil verbunden ist. D.H. die beiden GND-Leitungen 24V und 5V
sind getrennt.
Das 5V-Netzteil dient der Versorgung der Messelektronik (2x ATMega32,
Relais, D/A, A/D). Die Messelektronik wird via RS232 vom PC ausgelesen.
Der ATMega besitzt einen externen Quarz!!! Die Kommunikation zwischen PC
und ATMega läuft einwandfrei.
Wenn die Prüfung beendet ist, fährt der Automat wieder auf
(24V-Netzteil ist zuständig). Und in diesem Moment bekomme ich
Nadelimpulse (bis zu ca.20V) und kurzzeitige (50µs) Spannungseinbrüche
auf der 5V-Leitung!!! Der ATMega macht nun einen Reset, was ich aber
nicht gebrauchen kann :-(
Können diese Störungen über die Primärseite kommen? Sekundär haben die
zwei Spannungen ja nichts miteinander zu tun.

Ich bin am Verzweifeln...

Autor: Rüdiger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
Ich würde mal so auf die schnelle die Relais beschuldigen.
Hast du eine Freilaufdiode an den Relais ?

Rüdiger

Autor: Hauke Radtki (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
naja die spulen sind ja nebeneinander gewickelt ... da können sich schon
ströungen übertragen! entweder du filterst die spannung mit
Kondensatoren oder du verwendest einen anderen Trafo, der 12V
ausspuckt, und nimmst nen regler, der das ganze dann auf V bringt ...
wobei sich die Kondensator methode natürlich viel leichter noch
integieren lässt (z.b. kleine extra platine) nimm am besten nen relativ
großen Elko (je nach dem wie lang, "tief" deine einbrüche sind) und
nen nicht zu großen kerko oder so, um die spannungsspitzen zu filtern!
(sollte sowieso an jedem IC sitzen!!) und evtl noch ne spule, dann
sollte eigenndlich nichts mehr durchkommen

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
D.H. die Störungen übertragen sich irgendwie von der 24V Seite zurück
auf die Primärseite und dann wieder über's 5V Netzteil in meine
Messelektronik?

Autor: Rüdiger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das glaube ich weniger
Vielmehr glaube ich das die Relais ein problem bereiten
um dies auszuschließen ist die frage wieviel schütze schaltest du ?
Liefert dein 5V Netzteil genügend Strom um die Schütze bzw. Relais
anzusteuern. Dies erklärt vielleicht den einbruch den du hast.
und dann noch die freilaufdiode.
das würde erklären warum die die spitzen auf den 5v hast

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das 5V-Netzteil ist ein PC Netzteil. Bringt mehrere Ampere. Relais sind
16 Stück (5V/10mA, wird direkt vom ATMega-Port angesteuert) verbaut.
Das sind allerdings Reedrelais.

Autor: Rüdiger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein PC Netzteil braucht um richtig zu funktionieren einen mindeststrom
denn wirst du wahrscheinlich nicht erreichen wenn keine Relais
angesteuert werden
Daher diese Impulse
Probier mal einen Verbraucher so anzuschließen.
so um die 100mA das musste reichen, denn der minsteststrom ist von
netzteil zu netzteil verschieden
vielleicht findest du ein datenblatt zu dem Netzteil

Rüdiger

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich werde am Montag mal Versuche machen. Mal schauen was ich rausfinde.
Ich berichte dann davon.

Danke mal soweit...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.