mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik avr-ctrl atmega8535 proggen


Autor: Christian Dresel (Chrisi01) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi

so hab nun das programmierkabel gebaut und auch ponyprog installiert

wollte nun mal das lauflicht programm draufschreiben

mein erstes problem ist wir hatten in der beruffschule einen at90S8535
ich hab hier nen atmega8535 aufm avr-ctrl

weiß net so genau was ich unter dev. typ einstellen soll hab mal avr
und avr auto eingestellt da sagt er beim programmieren nur:

Device missing or unknown device (-24)

calibration hab ich gemacht

unter setup hab ich aufm lpt port avr ISP I/O gewählt

muss ich sonst noch was einstellen und welches device typ soll ich nun
nehmen find den atmega 8535 leider net

auch im programm (nutzte bascom) was soll ich als $regfile nehmen?
8535def.dat wird die gehen? die haben wir ind er schule beim at90s8535
genommen

mfg

Christian Dresel

Autor: Andi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Probiers in BASCOM mal mit "M8535.DAT".
In Ponyprog wählst Du als Device "ATmega8535".
Wenn Du das im Ponyprog nicht findest, ist nicht Alphanumerisch
sortiert, hol Dir die aktuelle Version von Ponyprog bei
www.lancos.com.

MfG
Andi

Autor: Andi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach ja, hast Du Deinen ISP-Adapter nach dem Bauplan von Ponyprog
gebaut?
Hat nicht die selbe Pinbelegung wie z. B. der für AT-Prog.

MfG
Andi

Autor: Christian Dresel (Chrisi01) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
gebaut hab ich ihn so:

http://s-huehn.de/elektronik/avr-prog/avr-parallel.gif

http://s-huehn.de/elektronik/

M8535.dat werd ich mal testen

und atmega8535 find ich net hab die neuste version denk ich (1.17h)

werd dann mal die beta testen vllt. is da was dabei

vielen dank auf jeden fall

mfg

Christian Dresel

Autor: Christian Dresel (Chrisi01) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also mit der M8535 geht es auch nicht aber auch in der beta version
2.05a von ponyprog find ich den atmega8535 auch nicht. wie bekomm ich
den da rein?

mfg

chrisi01

Autor: Andi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In Ponyprog 2.05 ist es ab AVR-Auto der 16-te.
Vom Huehn habe ich mir den seriellen Adapter nachgebaut.
Kleiner Tip: Knall Dir auch in der MISO-Leitung eine 1K
Schutzwiderstand rein, man weiß ja nie.
Habe hier die BASCOM-Version 1.11.irgendwas und da ist die
"M8535.DAT" vorhanden.
Klick in BASCOM mal auf Open (STRG + O), unter Dateityp "All Files"
auswählen, in den BASCOM-Ordner gehen und da müßtest Du fündig werden.

MfG
Andi

Autor: Andi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach ja, Habe hier die Ponyprog-Version 2.06c.

MfG
Andi

Autor: Christian Dresel (Chrisi01) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi

danke für die hilfe habs eben mal mit avr auto und atmega16 probiert
der fehler von oben bleibt hab v2.05a von ponyprog und als typ hab ich
auch die m8535.dat genommen bei der miso hab ich etz keinen 1k werd ich
aba dann nachholen :) danke fürn tipp

sonst noch wer ideen wieso sich das ding net proggenlässt? an der LED
leiste leuchtet auf jeden fall die LED auf wenn ichs versuch

mfg

Christian Dresel

Autor: Christian Dresel (Chrisi01) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
achja die M8535.dat ist bei mir auch da ;) geht ja nur ums ponyprog

Autor: Andi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe gerade mal Testweise die alte Version 2.05c runtergeladen und
installiert.
Der Mega8535 ist da nicht dabei.
Installiere Dir die aktuelle Version 2.06f.

MfG
Andi

Autor: Christian Dresel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi

geht immer noch net hab ponyprog installiert hab mit bascom und M8535
compiliert dann im ponyprog die Calibration gemacht anschließend unter
Interface Setup hab ich auf LPT1 und AVR SPI I/O gestellt hab dann auf
avr micro und ATmega8535 gestellt und anschließend auf Write device und
wieder kam der fehler grml was kann es noch sein.  Kabelfehler oder hab
ich irgendwas vergessen einzustellen?

mfg

chrisi01

Autor: Christian Dresel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
so brauchst mir nimmer helfen ich hab das parraelkabel spiegelverkehrt
gelötet lol so blöd muss man erst mal sein is mir eben beim durchpipsen
aufgefallen und jetzt hab ich natürlich keinen lötkolben da also muss
ich das morgen machen :( schade

mfg

Christian Dresel

Autor: Tobias Remmel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich bekomme mit einem gekauften, seriellen Adapter (Pollin) und einem
selbstgebauten Programmer (seriell) auch immer die gleichen
Fehlermeldungen.

Ich habe bereits AVR Studio, Bascom und PonyProg getestet, nichts
funktioniert. Der AVR hat seine 5V, die Daten kommen am AVR an, aber
immer gibt es Fehler.
Der AVR scheint allerdings zu antworten, da das Programm bei
abgestecktem Programmer meldet "Device not responding".

Ich bin ein totaler Neuling in Sachen Mikrocontroller.
Kann mir jemand helfen? Vielen Dank.

Autor: Tobias Remmel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK. Hat sich.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.