mikrocontroller.net

Forum: Compiler & IDEs Problem mit WinAvr unter XP


Autor: MaFilla (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi
Nach dem installieren von WinAvr tritt beim compilieren immer ein
Fehler auf (das aber gleich sehr oft hintereinander).
"Es befindfet sich kein Datenträger im Laufwerk. Legen Sie einen
Datenträger in Laufwerk\device\harddisk1\dr3" ein. Aber eine Hex
Datei wird erstellt (und einige andere auch noch). Das ganze Läuft auf
einem WinXP Rechner. Verwendet wir die aktuelle WinAvr Version
(20040720).

Autor: Calik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schau mal hier nach:

http://www.hebel23.de/index.htm?/projekte/avr/Tutorial.htm

, ist von einem gewissen hebel23. super gemacht. ich habe es
ausprobiert, es klappt alles wunderbar. ausser das ich die hex-dateien
mit ponyprog2000 in den avr schreibe.

Autor: Jörg Wunsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Prima Seite, ohne Javascript passiert gleich gar nichts, weil selbst
die Frame-Verwurschtelung unbedingt in JS gezimmert werden mußte.
Weiter hatte ich dann keine Lust zu gucken.  Ich denke, am Problem des
Originalposters wird das ohnehin 100 % vorbeigehen.

Soweit ich von Eric weiß, ist ihm das Problem bekannt, er hat nur
keine Idee, woran das liegt.  Muß irgendwo ein Cygwin oder MinSYS
Problem sein das damit zusammenhängt, daß er die Compilierung bei sich
auf Laufwerk E: vornimmt.  Offenbar gelangt davon noch irgendeine Spur
in das Binary hinein.  Wenn mich nicht alles täuscht, ist das bislang
auch nur von WinXP-Nutzern berichtet worden.  Go figure.

Autor: MaFilla (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi
Also liegt definitiv an WinXP!
Habe es mit W2k versucht, und der Fehler tritt nicht mehr auf.
Daher bin ich jetzt kurzerhand auf Win2000 umgestiegen. Das Ständige
klicken hindert sonst am vernünftigen Arbeiten.

Bin froh das es nicht an mir liegt, da ich schon angefangen hatte an
mir zu zweifeln.(:

Mfg

Autor: Calik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also, ich weiss nicht, was ihr habt. Ich habe es genauso gemacht, wie
auf der Seite beschrieben und es funktioniert wunderbar. Ich habe schon
mehrmals auch damit Programme in den AVR gebrannt, es läuft.....

mfg Calik

Autor: Jörg Wunsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du brauchst dafür keine positive Bestätigung zu schicken und kannst es
denen, denen das trotzdem passiert, ruhig glauben, daß sowas
gelegentlich unter WinXP offenbar auftritt.  Suche nach dem Pfadnamen
in avrfreaks.net, und Du wirst mehr als einen Fehlerbericht dieser Art
vorfinden.  Auch wenn es nur in 0,1 % der Fälle auftritt (und damit
mit großer Wahrscheinlichkeit halt bei Dir gerade mal nicht), bleibt
es trotzdem irgendwo ein Bug (kein tödlicher, aber für die, die's
betrifft eben ein nerviger).

Einziger Hinweis, den ich bislang irgendwie gelesen habe ist, daß es
möglicherweise damit zusammenhängen könnte, daß bei denen, die davon
betroffen sind, ,,Laufwerk'' E: nur gelegentlich existiert (CD-ROM,
Wechselmedium oder sowas), und daß die Meldung immer dann kommt, wenn
das Laufwerk gerade nicht verfügbar ist.  Vielleicht trifft das ja
auch auf den OP zu?

Verflucht sei das 30 Jahre alte CP/M-,,Laufwerks''konzept in einem
vermeintlich modernen Betriebssystem...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.