mikrocontroller.net

Forum: Compiler & IDEs Problem beim bauen der avr-libc


Autor: Jörg Dreßler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallöchen,
bei mir läuft das
./doconf
problemlos durch, aber danach erhalte ich folgende Fehlermeldung:

Fortress:/daten/Ablage/avr-libc-1.2.0 # ./domake
cd .. && automake --foreign --include-deps Makefile
configure.in:146: your implementation of AM_INIT_AUTOMAKE comes from
an
configure.in:146: old Automake version.  You should recreate
aclocal.m4
configure.in:146: with aclocal and run automake again.
make: *** [../Makefile.in] Fehler 63
automake-version : 1.93
autoconf-version : 2.59

Nach einem "aclocal" meckern doconf und domake, dass diese libc nur
für'n avr ist.
Was kann ich machen?

Gruß
    Jörg

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nach aclocal noch automake ausführen ?

Autor: Jörg Wunsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmpf.  Sche*** autofoo-Gewurschtel.

Kannst Du Deine autotools mal so lange zur Seite räumen (aus dem Pfad
entfernen, in was ungefährliches umbenennen oder so) und das danach
nochmal versuchen?  Dann sollte das doconf nicht merken, dass es
überhaupt automake und Konsorten verfügbar hat und diese auch schön
aus den Makefiles rauslassen.

Dieser Kram hat eine unwahrscheinliche Neigung besser wissen zu wollen
als der Entwickler, der vor dem Rechner sitzt, wann man automake & Co.
aufrufen solle.  Das ist ein Punkt, den ich völlig krank am Konzept
von automake finde.

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
pff...wenn man drauskommt ists kein gewurschtel. sonst halt mal autobook
lesen.

Autor: Jörg Wunsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
autofoo ist Gewurschtel, sorry.  Das Zeug lässt einem ziemlich die
Haare zu Berge stehen.  Zweifellos hat es seine guten Seiten, aber es
ist auch deutlich mehr als nur eigenwillig in seinem Verhalten.

Autor: Jörg Dreßler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Soweit jetzt nicht noch irgendwelche anderen (ungeahnten) Probleme
auftreten, hat erst mal alles funktioniert :-)
Vielen Danke, von jmd der noch nie Kontakt mit dem auto-Gewurschtel
hatte.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.