mikrocontroller.net

Forum: Compiler & IDEs Probleme mit dem WinAVR System


Autor: Ger Kautzmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Forum,

ich habe ein Problem mit dem WinAVR Problem.

Ich versuche zur Probe die Demos unter C:\WinAVR\examples\demo zu
übersetzen. Wenn ich 'make' aufrufe bekomme ich:
C:\WinAVR\examples\demo>make
MAKE Version 5.2  Copyright (c) 1987, 1999 Inprise Corp.
Fatal: 'demo.o' does not exist - don't know how to make it

Da ich unter DOS irgendwie keinen 'Which' oder 'where' Befehl finde
weiß ich nicht mal welches 'make' genomen wird.

Wenn ich make aus c:\winavr\utils\bin\make.exe benutze bekomme
ich:
C:\WinAVR\examples\demo>c:\winavr\utils\bin\make
avr-gcc -g -Wall -O2 -mmcu=at90s2313    -c -o demo.o demo.c
process_begin: CreateProcess((null), avr-gcc -g -Wall -O2
-mmcu=at90s2313 -c -o
demo.o demo.c, ...) failed.
make (e=2): Die angegebene Datei wurde nicht gefunden.
C:\WINAVR\UTILS\BIN\MAKE.EXE: *** [demo.o] Error 2

Also irgendwie habe ich in den Tutorials und Readmes nichts gefundeen,
dort wird die Installation nicht groß besprochen.

--------------------------------------------------------

Hmm also irgendwie sind keine Pfade gesetzt und funktionieren tut sonst
auch nichts .... gibts irgendwo eine Anleitung wie man WinAVR
installiert ? Also was muss man tun wenn dieses Installshield fertig
ist ?

---------------------------------------------------------

Irgendwei krieg ich das existierende Projekt bestehend aus demo.c und
makefile nicht in das Programmers Notepad rein, also ich kann eine
Projektdatei erstellen aber die hat mit den Programmen irgendwie nichts
zu tun.

-----------

System: WínME, Alles auf Festplatte C: ....

Vielen Dank für die Hilfe

Autor: Gerd Kautzmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habs raus jetzt geht alles auch das anlegen von Projekten.

Ist halt besser ein Programm noch mal zu installieren wenn der PC vor
der Beendigung abstürzt ....

Autor: Rufus T. Firefly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das make von Inprise (Borland) wird wohl irgendwo im Suchpfad stehen.

Gib' mal im Kommandozeilenfenster
  set path
ein und sieh' Dir die Ausgabe davon an.

Das Borland-Make kann keine makefiles für gnu-make verarbeiten und
fällt daher auf die Schnauze.

Der Pfad wird unter dem Betriebssystemsurrogat, das Du verwendest,
vermutlich noch in der Autoexec.bat gesetzt.

Autor: Gerd Kautzmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
We gesagt, auch mit der richtigen Pfadangabe hat nichts funktioniert.

Lag alles daran dass der PC hängen blieb beim Installieren.
Alles noch mal installiert, jetzt stimmen auch die Pfade.

Danke für die Hilfe.
cu

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.