mikrocontroller.net

Forum: Platinen Eagle 3d


Autor: Steve Bennet (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

aus Spass habe ich ein wenig mit Eagle3D rumgespielt, bzw. versucht.
Export des Platinen-Modells geht wohl, wenn ich es aber in Pov-ray
rendern will, kommen Fehlermeldungen das z.B. die Tool.inc und user.inc
Dateien nicht gefunden werden. Ich habe Pov-Ray frisch installiert und
habe keine Ahnung davon. Wie oder wo kann ich den Pfad zu den inc-Files
    eintragen? Oder hab ich was anderes fasch gemacht.

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

am einfachsten:
Alle .inc-Dateien und die Texturdatei für die Elkos in das POVRay
Include-Verzeichnis kopieren.

besser:
POVRay per INI-Datei zusätzlichen Library-Pfad mitteilen. Wie das geht
steht in der Doku zu POVRay. Wie so eine INI-Datei aussehen könnte
findet sich in der Doku zu Eagle3D.

Matthias

Autor: Raki Due (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Boa! Das habe ich ja noch nie gesehen, daß es sowas gibt. Alles alleine
gebaut? Hochachtung!!!!  Werd' ich auch mal probieren.!!

Autor: Steve Bennet (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@matthias
Danke für die Antwort, jetzt klappts natürlich. Jetzt hab ich nochmal
ne Frage. Gibt es eine Möglichkeit andere Formate zu erzeugen, also ich
bräuchte Max bzw. 3ds. Oder gibt es einen Konverter dafür. Ich habe mir
eine Demo von 3dwin5 gezogen, der konvertiert pov in 3ds, allerdings
ist das 3ds-File leer. Vielleicht kennstDu da eine Lösung. Ansonsten
sehen die Platinen echt schick aus.

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Nein, die Möglichkeit gibt es nicht. Ich arbeite allerdings zur Zeit
etwas aus das es ermöglicht polygonbasierte Modelle aus den
POVRay-Dateien zu erzeugen. In meinem Kopf ist der Konverter schon
fertig. Nur an der Zeit zur Implementierung mangelt es mir.

Matthias

Autor: Tobias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe die .pov Datei erstellt und mit Pov-Ray geöffnet, aber es kommen
immer Fehler wie dieser: "Parse Error: Illegal Character in input
File, value is ffffffb5"

Er tritt in der folgenden Codezeile auf:

#ifndef(pack_Z700µF_1) #declare global_pack_Z700µF_1=yes; object
{CAP_DIS_ELKO_7MM5_18MM("",)translate<0,0,0>
rotate<0,0.000000,0>rotate<0,-90.000000,0> rotate<0,0,0>
translate<23.010900,0.000000,37.786700>}#end    //Elko 7,5mm Pitch, 18mm
Durchmesser, 35,5mm Hoehe 4700µF-1  E7,5-18

Habe ich die .pov Datei falsch erstellt oder woran liegt es?

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

da macht das µ-Zeichen Probleme. Ersetz das mal gegen ein anderes.

Matthias

Autor: Tobias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe das µ mit einem anderen Zeichen ersetzt und jetzt geht es. Ist das
ein Fehler in der Software der noch behoben wird, oder muß ich das
immer von Hand ändern?

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

das ist ein Zeichencodierungsproblem. Ich hab das in der aktuellen
Entwicklungsversion behoben. Du kannst in der 3dfunc.ulp die Zeile

in = strreplace(in,". -&$+:;,!\"§%/()=#*~'<>",'_');

mit

in = strreplace(in,". -&$+:;,!\"§%/()=#*~'<>µ",'_');

ersetzen. Dann sollte das dauerhaft funktionieren.

Matthias

Autor: Marik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Bei mir kommen immer folgende Fehler in der datei tools.inc wenn ich
auf "Run" klicke:
1. Parse Error: Expexted 'numeric expression', undeclared identifier
' global_solder'found instead

2. Parse Error: Expexted 'numeric expression', undeclared identifier
' inc_testmode'found instead

mfg
Marik

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

das hört sich irgendwie nach unpassender ULP-Version zur Version der
tools.inc an.

Matthias

Autor: Syd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich kann mein POVRAY 3.6 unter xp nicht mehr Starten.
Startbildschirm ist da, aber dann schließt sich alles wieder.
kennt einer ne Lösung??


Vielen Dank..

Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
/*
ich kann mein POVRAY 3.6 unter xp nicht mehr Starten.
Startbildschirm ist da, aber dann schließt sich alles wieder.
kennt einer ne Lösung??
*/

Neuinstallation?

Autor: Syd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

hab ich schon hinter mir, aber es bringt nichts.
(Fehler bleibt)
das Komische, es ging mal. ich hab auch nichts verändert
oder gelöscht.

Ich weiß nicht mehr weiter??

:-(

cu

Autor: Hauke Radtki (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
liegt wahrscheinlich wie immer an windoof ... mich kotzt das auch immer
an ... irgendwas funzt super, doch plötzlich funzts am nächsten tag
nicht mehr

Autor: Stefan Seegel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das hat ich vor ein paar Tagen auch. Folgendes hat geholfen: PovRay über
die Systemsteuerung deinstallieren, und dann nochmal im Explorer ALLE
Dateien in Programme/povray die übriggeblieben sind löschen. Dann
Neuinstallation und es funzt wieder.

Stefan

Autor: Michael D. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi @all,

anscheinend hat die fehlermeldung was mit dem speicherbus zu tun von
AMD,auf nen Intel läufts bis heute, auf nen AMD nur ne weile oder
garnicht, einfach schlechte verwaltung der prozesse von win.
leider hauts bei mir immer noch nicht richtig hin, das povray meckert
über zu langen string, weisst einer wie ich dem fehler beheben kann??

MfG
Micha

Autor: Michael D. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hi,
so, nach langen rumprobieren läuft das alles auf beiden architekturen
(intel, amd) fehler frei, habe statt der version 3.6 von ray die
version 3.5 genohmen....

MfG
Michael

Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> einfach schlechte verwaltung der prozesse von win

Ja genau, wenn der Programmierer unfähig ist, liegts an Windows.

Autor: Michael D. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi,
du darfst nicht vergessen das windows auch programmierer programmiet
haben und das ist weit unfangreicher als so ein ray, also sind in win
die fehler wahrscheinlicher als in ray...

MfG
Micha

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.