mikrocontroller.net

Forum: Offtopic ALI M6759-A1


Autor: STANDBYRADIOTVSERVICE (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Microcontroller ALI M6759-A1 welcher sich in einem LCD Monitor
befindet hat einen Themperaturfehler d.h. wenn er warm wird
funktioniert der Monitor nich mehr. Kühle ich ihn ab, funktioniert das
Gerät wieder einwandfrei.
Hab mir als einen neuen ALI gekauft. Hab mit meinem Programmierer
BeeProg von Elnec versucht die Firmware des def ALI auszulesen und auf
den Neuen raufzudrücken. Irgendwo mache ich aber einen Fehler, weil der
Monitor sobald ich den neu programmierten ALI einbaue überhaupt nicht
mehr funktioniert.
Hab mir die Datenblätter des ALI besorgt, da steht dass die geladene
Firmware durch Sicherheitsregister geschütz werden kann. Kann es daran
liegen?? Gibt es eine Möglichkeit diese zu umgehen ??
Wenn ich den Puffer ansehe, nachdem ich die Firmware des def ALI
ausgelesen habe sehe ich keine Programmcodes, der gesamte Puffer ist
voll mit dem gleichen Symbolen (Kügelchen mit 2 Strichen, einer nach
Oben einer nach Unten)

Irgend jemand eine Idee

Mfg
Raimund

Autor: Rufus T. Firefly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Hab mir die Datenblätter des ALI besorgt, da steht dass die geladene
Firmware durch Sicherheitsregister geschütz werden kann. Kann es daran
liegen??"
Ja, allerdings.

"Gibt es eine Möglichkeit diese zu umgehen ??"
Nein, denn genau das ist der Sinn eines solchen Ausleseschutzes.

"Wenn ich den Puffer ansehe, nachdem ich die Firmware des def ALI
ausgelesen habe sehe ich keine Programmcodes, der gesamte Puffer ist
voll mit dem gleichen Symbolen (Kügelchen mit 2 Strichen, einer nach
Oben einer nach Unten)"
Den Hexcode anzugeben ist vermutlich sinnvoller. Aber auch so wird das
Phänomen eines nicht auslesbaren Programmspeichers gut beschrieben.

Du könntest versuchen, dem thermischen Problem durch bessere Kühlung
beizukommen. (Kühlkörper? Propeller?!)
Vielleicht funktioniert ja -beispielsweise- der Oszillator nicht
richtig (wenn der denn mit einem simplen Quarz oder Keramikresonator
aufgebaut ist), und ein Ersatz durch einen richtigen Quarzoszillator
löst das Problem - oder miss' doch mal die Betriebsspannung nach
Warmwerden.

Wenn Du all' die anderen Fehlerursachen bereits ausgeschlossen hast,
hast Du allerdings ein Problem, denn der Hersteller des Monitors wird
die Firmware kaum freiwillig 'rausrücken.

Autor: Tobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail, Yahoo oder Facebook? Keine Anmeldung erforderlich!
Mit Google-Account einloggen | Mit Facebook-Account einloggen
Noch kein Account? Hier anmelden.