mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik STK500 defekt


Autor: Günter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Durch eigenes Verschulden (Design-Fehler in einer Schaltung an den 
Port's (Port.B) ist das bei mir im Einsatz befindliche Starter-Board 
STK500 defekt (geworden)

Da die Fehler-Situation unmittelbar nach dem Experimenieren mit der 
neuen Schaltung aufgetreten ist, vermute ich einen von mir verursachten
Hardware-Fehler (der eingesetzte AVR 2313 ist übrigens auch kaputt 
gegangen!)

Folgende Fehlermeldungen erscheinen bei Verwendung von AVR-Studio

Setting device parameters, serial programming mode ok
Entering programming mode  failed   <------!!!
Leaving programming mode ok

Auch die Übertragung direkt aus BASCOM (send to chip)funktioniert nicht 
mehr

Auf dem STK-500 leuchten:

Power-LED (rot)
Status-LED (grün)
Target-power-LED (grün)

Die Com-Schnittstelle ist überprüft; sie ist ok

AVR-IC's (2313 / 8515) habe ich auch schon getauscht

Die eingesetzten AVR's habe ich zwischenzeitlich auf
einem anderem Board getestet -- sie sind ok !!!

Es scheint sich tatsächlich um einen 'elektrischen'
Fehler auf dem Board zu handeln

Wer kennt jemand aus der AVR-Scene, der ein STk500-Board überprüft und 
reparieren könnte (Kostenübernahme selbstverständlich)???


Günter

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo !!!
Ich hatte mit meinem STK500 auch so ein ähnliches Problem.
Versuche doch mal im AVR-Studio (Schaltfläche STK500,Board)den 
Taktgenerator zurückzusetzen und dann wieder mit 4Mhz zu beschreiben.Hat 
bei mir funktioniert.Mit einem extra Quarz ging es nähmlich.
Gruß Mario

Autor: Olli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hatte auch ein ähnliches Problem. Bei mir war die Stromzuleitung an die 
AVRs scheinbar defekt. So konnte ich auf dem Board zwar Spannung messen, 
an den AVR's kam aber nichts an. Habe dann einfach die Stromversorgung 
extern über den VTG Pin an einem der Portleisten aufgebaut und schon 
ging es wieder....

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.