mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ponyprog brennt steckbrett durch


Autor: hans müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,
mir ist folgendes passiert: ich hab mit si-prog (einfache version ohne
7805) einen uC geproggt und dann abends vergessen den SI-Prog
abzuziehen. Folge ist nun das mein Steckbrett unter dem chip
geschmolzen ist (siehe Bild). Was nicht so schlimm wäre, wenn es nicht
ein größeres brett wäre.

Liege ich richtig in der Annahme, das über den RESET eine negative
Spannung an den uC gekommen ist und der deshalb so heiß geworden ist?
Kann man das irgendwie reparieren oder ist es günstiger den Teil
auszutauschen?

Autor: hans müller (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
ok, sorry, bild vergessen

Autor: Steffen DB1Ulm (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
MEi wo gehobent wird fallen späne, wird dir auf jedenfall nicht mehr
passieren :) Naja steck halt die ics woanders rein und nutz das
verbrannte für Widerstände und so nen Kram.

Würd mir da keine weiteren GEdanken machen...

Autor: hans müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hat jemand eine idee, wie man das reparieren kann? irgendwie müssen die
kontakte ja in das brett reingekommen sein...

Autor: Kasperle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
... Du hast Probleme ...

Autor: MISZOU (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

wo hast du das Steckbrett her. Normalerweise sind das alles einzelne
Module, die zusammengesteckt sind. Diese sind dann mit doppelseitigen
Klebeband auf der Trägerplatte montiert. Besorg dir vom gleichen
(andere Hersteller;verschiedene "Nut und Feder") Hersteller ein
kleineres Experemtierboard oder nur ein einzelnes Modul und tauscht das
defekte aus.

Gruß MISZOU

Autor: Peter Dannegger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aus Schaden sollte man klug werden.

Nimm das nächste mal entweder ein Netzteil mit einstellbarer
Strombegrenzung oder strombegrenzte Spannungsregler z.B. 78L05 (max
100mA).

Wenn ich was bastele, dann ist meine Devise immer: nur soviel Strom wie
nötig.

Man lebt dann auch gesünder (weniger kanzerogene Gase).


Peter

Autor: hans mülller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich hab jetzt mal das steckbrett losgeschraubt und das Klebeband
abgepopelt. werde mal probieren das raster wieder hinzubiegen.

das durchbrennen liegt definitiv an der reset leitung, die +12V - ein
schöner alter rs-treiber ;(  - gingen durch den transistor durch, der
ja dann nur als diode gewirkt hat. dumm ist nur, dass der 10k
widerstand davor den strom nicht wirklich begrenzt hat.

mir fällt gerade auf, dass ich den seriellen port an meinem mainboard
auch noch testen sollte ... also macht es mal gut...

Autor: Peter Dannegger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"dumm ist nur, dass der 10k widerstand davor den strom nicht wirklich
begrenzt hat."

Das hat er schon, denn bei nur max 15mW brennt nichts durch.

Das kann nur ein zu starkes Netzteil für die VCC Deines µC gewesen
sein.


Peter

Autor: hans mülller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich hab spassenshablber mal probiert, den nochmal auszulesen und es hat
funktioniert. signatur ok, erster speicher-block ok.

Scheinbar gibt es hier einen Heisen-Bug: Die Simulation von SI-Prog
zeigt, dass da eigentlich nichts so warm werden kann. Wann geschlossen,
dann sind SCK und MISO -0.7 und RESET bei 0.07 und wenn
ich den Port öffne dann sind SCK und MISO bei 4.8V (ca.) und RESET
ändert sich nicht. (bei abgeschaltener versorgungssapnnung)

Jetzt bin ich echt am verzweifeln... was das nun eigentlich war...
was passiert eigentlich, wenn beim reset ein RJMP PC-0x0333 ausgeführt
werden soll? (Das steht im Speicher)

@peter: da war halt nur si-prog dran und sonst nichts. (abgesehen
davon: die spannung die am netzteil eingestellt ist überprüfe ich jedes
mal vor dem einstecken.)

Autor: Andi K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Beim Reset wird rein gar nichts ausgeführt, da steht der AVR und wartet
auf Signale an den Prog-Pins.
Reset wird ja von den Prog-Geräten auf GND gezogen.
Vielleicht hattest Du an Reset einen kurzen mit VCC, vielleicht unter
dem Steckbrett, das deshalb so viel Strom geflossen ist.
Wäre natürlich schlecht für die COM-Schnittstelle, außer der Reset wird
über einen Transistor auf GND gezogen, dann wäre es schlecht für den.

MfG
Andi

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"die spannung die am netzteil eingestellt ist überprüfe ich jedes
mal vor dem einstecken.)"


Spannung alleine macht keine Hitze.

Pi mal Daumen würde ich sagen, für so einen Brennfleck müssen
mindestens 5W umgesetzt worden sein, also z.B. 5V * 1A.

Und soviel Leistung kriegst Du aus keiner PC-UART raus, sondern nur aus
einem zu starkes Netzteil !


Peter

Autor: Thomas O. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich denke die fehlende Diode vom Reglerausgang zum Reglereingang hat
das verursacht, ein kurzer Spike und der 7805 souckt keine 5V sonder
die Eingangsspannung aus. Und wenn da jetzt 12V und 1A geflossen sind
ist das schon möglich.

Deswegen immer die Diode mit reinbauen und das Brett zusätlich durch
eine Spannungbegrenzung mittels Wiederstand und Z-Diode.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.