mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik MCU Schaltung störfest machen


Autor: Wiesi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe das Problem, dass ich eine Zündspule (von Auto) mit einer MCU
ansteuern will, was vom Schaltungstechnischen her auch klappt.

Wenn die Zündspule einen Funken erzeugt fange ich mir aber enorme
Störungen auf der Versorgung ein. (Kurzzeitige Überschwinger von 50V!
auf der 5V Leitung für etwa 100-250ns).

Hat irgendjemand eine Idee, wie ich anfangen soll dieses Problem zu
lösen?

   Danke.

Autor: A.K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Andi K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Optokoppler mit ausreichendem Vorwiderstand?
Allerdings gibt es doch irgendwo im KFZ entweder das Steuersignal
direkt vom Zünd-STG oder eines, was zum DZM vor einem
Frequenz/Spannungswandler geht.

MfG
Andi

Autor: Wiesi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Andi: Erstmal danke für die Antwort. Das Problem ist, das mir
ein Optokoppler nur was bringen würde, wenn ich getrennte Versorgungen
für die Zündspule und die Schaltung hätte (was ich leider nicht hab).

Um Mißverständnissen vorzubeugen: Die Spule befindet sich NICHT mehr
in einem Auto sondern wurde für eine andere Anwendung zweckent-
fremdet.

Autor: Andi K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann folge dem Link von A.K.
Oder hier aus dem Link eine 5V-Stromversorgung für µC was die
Überspannung schlucken sollte:
http://www.dse-faq.elektronik-kompendium.de/dse-faq.htm#F.23

MfG
Andi

Autor: Thomas K. (thkais)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe irgendwo im Netz eine Schaltung für eine Motorradzündung
gesehen. Dort hat der Autor die Sache - so finde ich - recht elegant
umschifft, indem er auch die 5V-Versorgunsspannung galvanisch getrennt
hat (Oszillatorschaltung + selbstgewickelte Spule).
Frag mich jetzt aber nicht, wo die war...

Autor: Thomas K. (thkais)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habs gefunden:
http://www.12move.de/home/hanskrause/elektro.htm

Die Datei "mzs.zip" herunterladen.

Autor: Wiesi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank für die URLs. Ich hatte schon befürchtet, dass es
ohne galvanische Trennung nichts wird, wollte es aber trotzdem
versuchen.

Ich werd´s jetzt mal mit Trennung probieren.

    Wiesi

Autor: Wiesi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Optokoppler sind eingebaut und die MCU lässt sich nun auch
durch heftiges Funkengebrutzel nicht mehr stören.

Leider muss irgendwie eine Spannungsimpuls in das Netzteil
gelangt sein, und hat dieses zerschossen, wobei ich keine Ahnung
hab´ wie das passiert sein soll.

ASCII Schaltung:

                ^ +12V
                |
   ^+12V        o
   |        Zündspule
   |            o
  10k           *-----------.
   |          |-'           |
   *----------| HV MOSFET   400V Transsil
   |          |-.           |
OC C\|  <--     |           |
   E/|  <--    ---         ---
   |
  ---

Ich frage mich, wie bei der Schaltung eine Überspannung an die
Versorgung kommen soll. Die Hochspannung baut sich ja am
Drain des MOSFET auf. (Hat da jemand eine Idee?)

Ich denke, ich werde noch einen Überspannungsableiter bei der
12V Versorgung hinzufügen oder ein ungeregeltes 0815 Trafo+Dioden+
Elko Netzteil nehmen.

    Wiesi

Autor: A.K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann lies halt mal den Link oben, was im Auto funktioniert, funktioniert
auch ohne Auto. L,Transil,C vor dem Regler und das Problem ist weg.

Autor: Wiesi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@A.K. Den Link hab ich schon gelesen. Das Problem ist nur folgendes
(um nicht wieder aneinander vorbeizureden):

Bei der Schaltung, wie sie bei dem Link gezeigt ist hängt bei mir
links (da wo Ubat steht) nicht die Versorgung des Autos, sondern
einfach ein Trafo+Gleichrichter+Elko.
Rechts (wo +5V/1A) steht hängt die Zündspule (und andere Elektronik).

Also nochmal ASCII (so siehts bei mir aus):

                                        +12V/4A
             .------.           .------.
     ----..--|      |---*-------|Regler|--*-----*--------->
         )(  |      |   |       '------'  |     |          Rest
  230VAC )(  | -|>- |  === Elko     |   100nF  Zündspule   der
         )(  |      |   |           |     |     |          Elektronik
     ----''--|      |---*-----------*-----*-----*--------->
             '------'

Un da wird der Regler durch (wahrscheinlich) einen Überspannungspuls
zerstört. (Regler ist übrigens kein 7812, wegen Stromverbrauch).

Ich wollte das nur klarstellen, nicht dass ihr mich für Ignorant oder
so was haltet.

    Wiesi

Autor: A.K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich geht davon aus, dass der µC von einem weiteren Regler mit 5V
versorgt wird. Und vor ebendiesen soll die EMV-Schutzschaltung damit
die Induktion der Spule nicht durchschlägt.

Und eine Diode parallel zum 12V-Regler schadet sicher auch nicht. Die
Dinger nehmen Strom rückwärts bisweilen übel.

Autor: Wiesi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der µC wird momentan von einem galvanisch komplett entkoppelten
Netzteil versorgt und steuert die Zündspule per Optokoppler.

Der haken mit der Paralleldiode ist nur, dass das Netzteil in
der obrigen Schaltung nur schematisch sein sollte. In Wahrheit ist
das ein fertiges Gerät wo ich nix dran machen kann.

Das Netzteil hab ich mittlerweile repariert. Damit mit das nicht
wieder passiert, hab ich in die 12V Leitung eine 600V Diode
geschaltet:

   -------*--|>------
Netzteil  |
         50Ohm    Zündspule und Rest
          |
   -------*----------

Der 50 Ohm Widerstand soll helfen den eventuellen Leckstrom der
Diode (obwohl der zu gering sein sollte um zu schaden) zu schlucken.

Das Geht - Dachte ich. Nun is das Teil schon wieder hin.

Am Kopf Kratz

   Wiesi

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.