mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Kommunikation mit TUSB3410 bleibt stehen


Autor: Mario Richter (mario001) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich hab schon von diversen Problemen mit USB-seriell-Konvertern hier im
Forum gehört, diesmal hat's mich selber erwischt ;-)

Ich hab einen -selbstgebauten- USB-seriell-Wandler mit dem TUSB3410 von
Texas Instruments (ich selbst war ja für den FT232, aber mein Betreuer
in der Diplomarbeit ist halt Fan von TI... ). Jetzt hab ich das
Problem, dass der an manchen Computern nicht richtig funktioniert.

Auf der Hardwareseite ist ein MSP430 angeschlossen, der kontinuierlich
Daten sendet. Geh ich in ein Terminal-Programm, kann ich diese Daten
auch für einige Zet sehen, plötzlich bleibt die Übertragung aber
stehen, obwohl der MSP430 nachweislich brav weiterschickt. Starte ich
das Terminal neu, geht's wieder kurz weiter, bis es wieder aus ist.
Die Zeit ist dabei nicht immer gleich, manchmal ist es gleich vorbei,
manchmal geht's auch etwas länger gut.

Geh ich mit dem Teil allerdings an einen anderen Rechner, tritt dieser
Fehler nicht auf und alles funktioniert ganz brav so, wie es sein soll.


Meine Frage: Kann das an der Schnittstelle liegen ? Ich selber hab ne
"alte" USB-Schnittstelle im Laptop, der andere Rechner (an dem's
funktioniert) hat schon ne USB 2.0. Oder vielleicht ein Treiberproblem,
das soll ja bei "billigeren" in PCs verbauten Interfaces auch
vorkommen ...

Grüße und Danke schon mal für alle Tips und Erfahrungsberichte,

Mario

Autor: Sebastian F. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das hört sich schon nach nem Rechnerproblem an. Ich habe hier auch
diverse Geräte die nur an USB 2.0 funktionieren wenn ich einen 1.1 Hub
dazwischen hänge. Was ist den für Software auf dem TUSB?

Seb

Autor: Mario Richter (mario001) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Sebastian,

danke für deine Antwort und Bestätigung ! Ich verwende den VCP-Treiber
von der TI-Webseite, der mir gleichzeitig auch die Firmware in den TUSB
reinlädt. Externes EEPROM mit den Konfigurationsinformationen hab ich
derzeit nicht dran.

Grüße, Mario

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.