mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik HILFE der Reset funktioniert nicht!


Autor: Hossa (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
also ich bin so langsam am verzweifeln.
Ich habe hier ein at90s8515 und er funktioniert nich richtig.
Ich kann ihn wunderbar beschreiben/löschen, aber das programm läuft
einfach nich.
Ich habe mal am Reset pin gemessen und da ligen nur 0,7 V an, es
müssten doch aber so ca. 5 sein oder??
Hab den 10 k OHM widerstand geprüft (der zwischen reset und vcc hängt)
und der ist in ordnung, leiterbahnen sind auch okay.
Beide Fusebits sind auf null (laut ponyprog).
Woran kann das liegen??

Autor: Jadeclaw (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn der Chip ziehbar ist (Fassung), dann mal herausziehen und nochmal
testen.
Liegen dann 5 Volt an, hat es evtl. eine Schutzdiode am IC-Eingang
zerlegt.
In dem Falle ist dann wohl ein neuer Controller fällig.
Ich gehe natürlich davon aus, dass du den Programmierstecker abgezogen
hast.

Gruss
Jadeclaw.

Autor: Hossa (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also am VCC Pins des Controllers liegen genau 5 V an, eine schutzdiode
benutze ich nich.
Und den Programmierstecker hab ich natürlich abgezogen.

Leider is das Teil festgelötet und ich kann es nicht entfernen.
Ich bin echt ratlos..

Autor: Jadeclaw (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gemeint war, dass die 5Volt ohne Prozessor am Resetpin der Fassung
anliegen sollten.
Die Schutzdiode ist im Prozessor, es ist üblich, dass die Eingänge von
CMOS-ICs mit integrierten Dioden geschützt werden,
nur diese Dioden haben ihre Grenzen.
Ein herumbaumelndes Kabel kann da was töten.
Nur da das Teil eh eingelötet ist, ist natürlich nichts mit
rausziehen.
Was für eine Platine ist das überhaupt?
Wenn das so ein Teil mit integriertem Programmieradapter ist,
kann dort was defekt sein,
wenn ohne Programmierkabel nichts am Resetpin hängt ausser dem
PullUp-Widerstand, dann tippe ich recht sicher auf den Prozessor.
Lötbrücken, falschrum eingelötete Bauteile und ähnliches mal
ausgeschlossen.

Gruss
Jadeclaw.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.