mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit Triac bzw. Entstörung


Autor: nides (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen!

Hab mehrere Dimmer mit Wellenpaketsteuerung in Betrieb, bei der mir
regelmäßig die Triacs durchknallen.

Erstmal eine kurze Beschreibung der Schaltung:
Verwendet hab ich 2N6075 (Datenblatt dabei!), jeder Kanal hat einen
max. Strom von 200mA, die Last ist eine Glühbirne also nicht besonders
induktiv.
Die Ansteuerung erfolgt über MOC3041, die einen Nulldurchgangsdetektor
haben. Die Triacs schalten brav immer nur eine ganze Halbwelle oder
garnicht.
Entstörung ist keine verbaut, weil ja eigentlich nicht nötig.

Nun zum eigentlichen Problem:
Beim Einschalten der Steuerung (Anschließen am Netz) kommt es
gelegentlich zum dauerhaften Durchzünden der Triacs.
(ca. jedes 10te mal ist der Triac tot).
Die MOCs sind zu diesem Zeitpunkt noch aus,
daher vermute ich als Ursache den zu starken Spannungsanstieg.
Im Datenblatt des Triacs findet sich leider nur eine Angabe über die
"critical rise of commutation voltage" die ja den Max.
Spannungsanstieg beim Nulldurchgang des Stroms, der ja bei induktiven
Lasten relevant ist.
Eine Angabe zur "critical rise of off-state-voltage" gibt es keine,
aber haltet ihr es für möglich, dass die bei diesem Triac so niedrig
ist, dass er so leicht durchbrennt?

Bin schon gespannt auf eure Antworten,

Nides

Autor: TravelRec. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Suche mal nach Snubber-Glied (R-C-Kombination) im Netz, wird über den
Triac geschaltet um eben diese schnellen Spannungssprünge zu
verhindern. I.d.R. handelt es sich um einen 47 Ohm Widerstand und einen
150nF Folienkondensator, die in Reihe liegen, beide natürlich
ausreichend spannungsfest.

Autor: Michael Wilhelm (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich glaube nicht, daß der Fehler mit einer RC-Kombination zu lösen ist,
da, wie beschrieben, der Fehler nur im Einschalten auftritt.

Meine bisherigen Erfahrungen mit den MOC304X haben ergeben, daß diese
Biester sich auch einschwingen müssen. Das heißt, in dem Moment, wo die
Schaltung unter Spannung gesetzt wird, hat der Treiber einen
undefinierten Zustand und schaltet garantiert zumindest eine Halbwelle
durch.

Wenn man sich weiter überlegt, daß eine Glühlampe ein Kaltleiter ist
und, wenn die Betriebsspannung im Moment der Spitzenspannung des Sinus
eingeschaltet wird, kann der dann fließende Strom schon beachtliche
Werte annehmen.

Vorschlag: Deutlich belastbare Triacs nehmen und/oder in die
Stromversorgung eine fette Drossel setzen, die den Einschaltstrom
begrenzt.

Weiterhin "Entstörung ist keine verbaut, weil ja eigentlich nicht
nötig." ist ein Trugschluß, da ein Triactreiber sicher nicht in der
Lage ist, im Nullpunkt zu schalten (wo soll der Gatestrom herkommen,
wenn der Sinus im Nullpunkt ist?). Da kann ein Snubber helfen oder auch
eine Drossel im Ausgang (zur Entstörung).

MW

Autor: Klaus K (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich denke mal:
Die Mindestlast für den Triac ist nicht erreicht und der Triac zündet
"Überkopf"
Achte mal auf einen handelsüblichen Dimmer, da steht drauf: Mindestlast
60 Watt...Der Einschaltstrom ist auch bei einem Kaltleiter der
Sinuskurve ähnlich, wenn er denn mit dem Nulldurchgang anfängt, d.h. Wo
keine Spannung, da auch kein Strom...

Autor: nides (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

@ TravelRec:
Aus meiner Frage geht eigentlich hervor, dass mir die Funktion eines
Snubber-Networks wohl bekannt ist.
Trotzdem Danke!


Der Einschaltstrom der Lampen wurde bei der Konstruktion
berücksichtigt. Er ist auch im schlimmsten Fall weit unter dem
Nennstrom des Triacs.
Möglicherweise ist aber die Anstiegsgeschwindigkeit des Stroms
problematisch! Zumindest tritt diese Konstellation nur beim Einschalten
auf. Allerdings ist die Leitung zu den Lampen so lang, dass aufgrund der
Leitungsinduktivität eine ausreichende Drosselung gewährleistet sein
müsste. Werd ich aber mal nachrechnen!

Dass mit dem Trugschluss halte ich für einen Trugschluss :-), weil der
Triac exakt im Nullpunkt ohnehin nicht zünden kann. Die Zündung erfolgt
immer erst ein wenig später. Das ist für die Entstörung aber vollkommen
irrelevant, da das Snubber-Glied ja zur Entstörung des Ausschaltens und
nicht des Einschaltens dient.


Die Variante auf andere Triacs auszuweichen ist natürlich eine Lösung
des Problems, bietet nur leider keine Möglichkeit die Ursache
herauszufinden :-).

Nides

Autor: Jadeclaw (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Triac verdaut 30A für eine volle Periode, das schafft ein
200mA-Glühbirnchen nie und nimmer.
Snubber und Drossel sind allerdings zwingend notwending, da es sonst
durch Störimpulse auf der Leitung zu einer Überkopfzündung kommt.
Und der Effekt, dass es beim Einschalten per Netzschalter passiert,
sagt mir ganz klar: Überkopfzündung, weil die Spannung zu schnell
ansteigt. (Einschalten im Spannungsmaximum, evtl. sogar mit
Schalterprellen.)
Sowas zerschießt dir dann den Triac.
100nF + 47 Ohm in Serie, das dann parallel zum Triac.
Und eine handelsübliche Entstördrossel in Serie zum Verbraucher.
Siehe hier:
http://www.mikrocontroller.net/attachment.php/3719...

Deine Triacs werden es dir danken.

Gruss
Jadeclaw.

Autor: TravelRec. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das mit der Mindestlast würde ich so nicht unterschreiben, dies bezieht
sich hauptsächlich auf Dimmer, die zwischen Verbraucher und Netz
geschaltet werden, also keine eigene Versorgung haben, wenn man die
Glühbirne ´rausdreht. Damit sie also genug Saft abbekommen, muß die
Glühlampe oder der Halogenstab mindestens so und so viel Watt haben...
Ich habe hier 7x TIC226-Triacs laufen, die mittels Gatterschaltung kurz
nach Nullduchgang zünden (wenn U~ etwa 6V hat) und noch nie beim
Einschalten oder auch sonstwann Probleme gehabt (Lichtorgel mit je 220
Watt Lampen pro Kanal - kein Snubber dran übrigens)...

Autor: Klaus K (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Jadeclaw
Snupperglied hilft immer, weil es auch so`n Spannungsanstieg
beherscht.

@nides
Mach mal den Test: nimm mal 100Watt Lampen und schalte doch mal
mehrfach ein warte 5 Sec. und dann nochmal. Schätze mal die Triac
sterben nicht mehr.

Autor: nides (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Klaus:

Warum sollte ein ausgeschalteter Triac eine Mindestlast brauchen?
Die Last wirkt sich nur aus, wenn ein Strom fliesst (Ohmsches Gesetz).
Ausserdem müsste dann ein Dimmer ohne angeschlossene Lampe (nichts
eingesteckt) immer abrauchen.
Im eingeschalteten Zuistand ist der minimale Haltestrom lt. Datenblatt
<30mA da bin ich weit drüber!

Höchstwahrscheinlich wird es eine Fehlzündung wegen zu starkem
Spannungsanstieg sein.
Das sollte sich dann durch eine Entstörung der Zuleitung beheben
lassen.
Üblicherweise liegen die dU/dt für off-state wesentlich höher als für
commutation, im Datenblatt des 2N6075 ist aber dazu überhaupt keine
Angabe zu finden. Hat vielleicht jemand ein anderes Datenblatt zu dem
Triac?

Nides

Autor: PeterL (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo

dem Triac ist´s egal wann und wie er zündet, dadurch habe ich noch
keinen geschossen (Vorausgesetzt IGate ist nicht zu hoch)
es gibt nur eigentlich  3 Todesarten :
Überstrom (partielles Überhitzen der Chipstruktur)
Überlast (Sperrschichttemp über zulässigem Wert)
und Überschreiten der max. Sperrspannung, da würde ich ansetzen

Peter

Autor: nides (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem am Überkopfzünden ist ja gerade der hohe Strom, der durch
den Spannungsanstieg kapazitiv auf das Gate eingekoppelt wird!

Nides

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.