mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Handfunkgerät - Endstufe reparieren


Autor: Bernhard Gebert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo ihr alle,

ich habe ein Stabo SH 7000 ersteigert, bei dem alles funktioniert bis
auf das Senden.
Ach so, es handelt sich um ein 10 Jahre altes CB-Handfunkgerät. Da ich
bereits ein solches Gerät besitze möchte ich das Gerät unbedingt
reparieren und kein neues kaufen.

Ich habe gehört, dass bei Funkgeräten die "Endstufe herausfliegt",
wenn man mit eingezogener Antenne sendet.
Heißt das, dass vielleicht einfach nur ein Transistor defekt ist?

Wäre klasse, wenn mir jemand von euch weiterhelfen könnte.

Viele Grüße,
Bernhard

Autor: Thorsten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Servus!

Wie siehts aus, kein Interesse an meinen PICs?

Autor: Bernhard Gebert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So unheimlich günstig sind sie halt nicht; um momentan geht diese alte
Kiste vor.

Autor: Bernhard Gebert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was ich noch gefunden habe: Ein 2sc2078 ist auf einem Kühlkörper
befestigt, ein NPN-HF-Leistungstransistor. Dieser funktioniert, wie ich
gerade getestet habe.

Autor: Gerado (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
oft geht der Treibertransistor baden,
die Endstufe bleibt heile!!
Gerado

Autor: Bernhard Gebert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Leider habe ich weder einen Schaltplan noch richtig viel Ahnung.
Sonst gibt es noch einen 7-Poligen IC im TO-Gehäuse, der auf einem
Kühlblech sitzt und einen 2SC2314; ungekühlt, aber TO-Gehäuse.

Ansonsten sind im gesamten Gerät, es hat 40 Kanäle FM und 12 AM, nur
noch ein paar kleine Transistoren und in IC verbaut. Und diverse
Kondensatoren, Spulen u.s.w.

Aber auf jeden Fall mal Danke, Gerado!

Autor: Bernhard (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

den Schaltplan habe ich sogar vorzuliegen. Der 2SC2078 ist ein bei
CB-Geräten häufig verwendeter Endstufentransistor, der 2SC2314 ein
ebenso gerne benutzter "driver".

Wie hast du die Funktion des 2078 getestet?

Sendet das Gerät überhaupt nicht mehr, oder nur sehr schwach? Ist mit
angeschlossener Antenne im Nahbereich noch etwas empfangbar?

Autor: Bernhard Gebert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Bernhard, (noch so einer :-) )

vielen Dank für den Schaltplan. Wenn ich jetzt noch etwas Hilfe von
jemandem bekomme, der auch jenseits des TTL-Pegels Ahnung hat, dann
sehe ich eine echte Chance.

Beide Transistoren habe ich mittlerweile so gemessen:
* Emitter auf 0 V
* Collektor über eine Leuchtdiode an 3,3 V
* Basis über 100 Ohm an 3,3 V

Wenn ich den Widerstand auf 3,3 V gelegt habe hat die Leuchtdiode
geleuchtet, sonst nicht.

Mit einem funktionierenden Gerät habe ich bei 30 cm Abstand auf keinem
Kanal irgendetwas empfangen.

Kurz eine andere Frage: Macht es etwas aus, wenn ich mit 4 W sende und
der Empfänger fast direkt daneben ist? (Nur im Voraus, falls das Ding
mal geht)

Autor: Bernhard (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

wenn irgendwas im Bereich Endstufe/Endstufentreiber defekt ist, dann
sollte im Nahbereich immer noch ein Signal empfangbar sein. Es sieht
also so aus, als ob der Fehler woanders liegt.

Wenn tatsächlich 4W herauskommen, wäre es wirklich besser, einigen
Abstand zu wahren. Oder man nimmt gleich einen Dummyload (besser).

Ich würde nun Q10 (TX VCO) anschauen, ob er überhaupt schwingt -> an
der Koppelwicklung, welche Richtung "doubler" geht messen. Falls
möglich, Frequenz messen.

Interessant wäre auch die Steuerspannung für die Varicap, welche über
R53 zugeführt wird -> TP2 messen (nicht direkt an der Varicap, dort ist
es HF mässig heiss). Liegt sie zu nahe bei Null oder zu hoch im Bereich
der Versorgungsspannung, dann kann man evtl. auf einen verstimmten VCO
schliessen. Auch ein "Flackern / Oszillieren" dieser Spannung kann
darauf hindeuten. Wie diese Spannung normal aussehen sollte: reine
konstante Gleichspannung 'im mittleren Bereich', abhängig von
gewähltem Kanal.

Dabei fällt mir ein, dass es einen Versuch wert wäre, das Senden auf
der niedrigsten Frequenz also Kanal 41 sowie der höchsten also Kanal 40
auszuprobieren.

Für den ersten Versuch braucht es schon ein Oszilloskop, der zweite
Versuch sollte auch mit Multimeter machbar sein.

Gruss,
Bernhard

Autor: Bernhard (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit Versuch im letzten Absatz meinte ich natürlich nicht das Senden auf
K40+41, sondern das Messen von VCO/TP2. Viel Erfolg!

Autor: Bernhard Gebert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also jetzt habe ich einige Neuigkeiten.
Nachdem ich das Gerät jetzt nochmals in Betrieb genommen habe, sendet
es (!!!). Alle Abschirmbleche sind fast komplett dran, die
Sendeleistung ist auf 1 W und das funktionierende Gerät zeigt S-Wert
9+30 an bei 5 m und einer dicken Wand Abstand.
Das war vorher definitiv nicht so. Und so oft wie ich es versucht habe
glaube ich nicht, dass ich vorher AM/FM oder den Kanal verwechselt
habe.
Ich schaue mal, dass ich die Transistoren und die Diode auf jeden Fall
bestelle und suche nach kalten Lötstellen und Leiterbahnrissen.

Es wird aber kein Signal aufmoduliert. Stimme oder Der Roger-Beep sind
also nicht zu hören. Außerdem ist mir noch etwas aufgefallen: Wenn ich
unter AM sende, dann kommt aus dem Lautsprecher (des sendenden,
defekten Geräts) ein abnehmender Pfeifton (ca. 3 s lang).

Und jetzt wünsche ich eine gute Nacht, morgen geht's weiter.

Viele Grüße,
Bernhard

Autor: Bernhard Gebert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also es geht weiter mit der Fehlersuche.
Leider habe ich keinenBestückungsplan zu dem Gerät und man kann die
Bauteilbeschriftungen nicht im eingelöteten Zustand lesen.
Also am TDA2002 kommt in jedem Fall nichts mehr an.

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Also am TDA2002 kommt in jedem Fall nichts mehr an.
der wird auch nur bei AM verwendet...

Autor: Bernhard Gebert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was man nicht im Kopf (oder den Augen) hat, das hat man auf dem Hintern
am Messplatz.
Ok, also bis hinter den TDA2002 bei AM und zu Q14 bi FM habe ich das
Signal verfolgt. Bloß den "Doppler Amp" habe ich nicht gefunden. Ist
die Modulationsschaltung vielleicht in dem vergossenen Teil?

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oje...

deine Modulation wird mit C80 ausgekoppelt und gelangt schliesslich
über den Umschalter "AM/FM" und über C81 und R80 zur Kapazitätsdiode
D11. Hier erfolgt die eigentliche Modulation deiner Sendefrequenz im
Takt der Sprache (FM) über die Sperrschichtkapazität dieser Diode. Die
grundfreguenz liegt bei 13,xx Mhz und wird von Q10 generiert. Diese
Frequenz wird jetzt mit L16 ausgekoppelt und über den Spannungsteiler
C91/C90 dem Q16 zugeführt und hier verdoppelt. Das ist der
"DopplerAMP". Das du am "DopplerAmp" keine NF mehr nachweisen
kannst, liegt auf der Hand, weil da keine mehr ist...
Liegt die Modulation noch am Mittelpin vom Umschalter "AM/FM" an?
Hier ist doch sicher nur ein Draht ab, oder so.
Ist das dein erstes Funkgerät, welches Du reparieren möchtest/muss?
Frag einfach weiter

Gruß
AxelR.

Autor: Bernhard Gebert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Axel,

der Schalter für AM/FM hat 12 Anschlüsse, von denen jeder weggeführt
wird; teilweise sogar über Kabel.
Eine echte Diagnose habe ich so also nicht hinbekommen.
Aber: Am TDA2002 kommt das Signal an, wenn ich auf AM bin. Nur am
nächsten Glied, dem "Doubler Amp" hänge ich wie gesagt, weil ich ihn
nicht finde.

Ja, es ist meine erste Reparatur an einem Funkgerät.

Viele Grüße,
Bernhard

Autor: Bernhard Gebert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...und jetzt geht das Gerät. Ich veräpple nicht euch, es veräppelt
mich.
Repariert, also ausgetauscht, gereinigt o.ä., habe ich nichts und ich
habe auch keine losen Kabel oder kalte Lötstellen mehr gefunden.

Ich hoffe, dass ich den Fehler nch finde und schaue mir den Schalter
mal genau an.

Viele Grüße und einen schönen Abend,
Bernhard

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.