mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Probs mit OPV TLC274 als Subtrahierer


Autor: Matthias Beckmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
ich wollte einen TLC274CN als Subtrahierer nutzen. Dazu hab ich erstmal
2 Testspannungen mit Trimmern und dann ein Spannungsfolger erstellt.
Beim Subtrahierer dann (wie auch in dem Artikel hier auf der Seite
beschaltet, falls es da noch andere Möglichkeiten gibt) alle
Widerstände  gleich, auf 1K. Soweit alles klasse, ergebnis auch, bis
sich die beiden Spannungen nr nich auf ca. 100mV unterscheiden, danach
keine Änderung mehr. Differenzen unter 100mV werden also nicht mehr
"verarbeitet". Hatte das eigengentlich vorher mal in einem
Simulationsprogramm durchgespielt, aber das muß wohl an irgendwelchen
Eckdaten des Omamp liegen? Hab aber keine Ahnung, welche Daten im
Datenblatt ich da zu Rate ziehen soll, oder gibts da noch andere
Fehlerquellen? Ich bin ratlos...
Sinn des Ganzen soll die Verstärung eines Sensorsignals sein, der
Mangnetsensor KMZ51, nur dessen Arbeitsbereich liegt im mV-Bereich.

Autor: Arno H. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie hast Du den OP versorgt?
0 Volt Ausgangsspannung lassen sich mit Single Supply nur sehr schwer
erreichen. Diese Daten verschlechtern sich zudem rapide mit zunehmendem
Ausgangsstrom und sinkender Differenzeingangsspannung.
Wenn die Auflösung nicht zu sehr darunter leidet, kannst Du 0,5V oder
einen Bruchteil der Referenzspannung (in dieser Größenordnung) addieren
und im µP rausrechnen.
Ansonsten:
Abb 14 bis 19 in
http://focus.ti.com/lit/ds/symlink/tlc274.pdf

Autor: Matthias Beckmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja stimmt, ich hab den OPV mit Single Supply betrieben. Ich hab jetzt
mal die Variante Instrumentenverstärker, is auch hier auf der page, und
gleich mit einer verstärkung größer 1. ich hab zwar ein signal des
sensors, der aus einer Brückenschaltung besteht und eben ein positives
und ein negatives signal zu referenz 2,5V ausgibt, aber wenn diese sich
zu stark annähern, macht der OPV ja wieder bei 0,1V schlapp. Das mit dem
addieren von 0,5V um immer eine differenz größer 0 der beiden signale zu
haben is eine idee, aber nicht die lösung, da ich das signal um ca. 1600
verstärken muß, damit es zwischen 0-5V schwankt. alles was ich addiere
macht die auflösung zu schlecht. ich hatte die idee, erst zu einem
signal 0,5V zu addieren, dann die differenz mit einem subtrahierer zu
zuhalten, ud diese dann mit einer referenzspannung von wieder 0,5V zu
verstärken, dann könnte ich das ursprüngliche signal unverfälscht
verstärken, nur gabs durch die vielen einzel opamps und die vielen
dafür zu ungenauen widerstände ein total unsauberes signal.
Wie kann ich also einfach dieses problem anders umgehen?
Gruß

Autor: Arno H. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann solltest Du für die OPV eine kleine negative Spannung basteln. Eine
Diodenflussspannung oder zwei reichen schon aus. Wenn Du ans Netzteil
rankommst, ginge es am Besten, ansonsten über einen Multivibrator aus
ein paar Gattern (Datenblatt 7107 enthält sowas) oder ein IC ( 555 und
Spezial-IC).
Arno

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.