mikrocontroller.net

Forum: Platinen KiCAD: Polygone werden nicht gefüllt, wenn.


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Max M. (gbl1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Mit KiCAD habe ich neuerdings das Phänomen, daß Polygone nicht mehr 
gefüllt werden können, wenn eine Signalverbindung (Netz) berücksichtigt 
werden soll.
Mit <no net> werden die Polygone gefüllt.

Offensichtlich habe ich irgendwas in meinem Projekt verstellt.
Auch nach DRC kann die Fläche nicht gefüllt werden.

Lege ich ein neues Projekt mit ein paar Bauteilen an, so funktioniert 
alles so wie es soll.


Ich bin komplett ratlos.

LG
Günter

Autor: Bernd W. (berndwiebus) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Günter W.


> Mit KiCAD habe ich neuerdings das Phänomen, daß Polygone nicht mehr
> gefüllt werden können, wenn eine Signalverbindung (Netz) berücksichtigt
> werden soll.
> Mit <no net> werden die Polygone gefüllt.

Welche Version von PCBnew verwendest Du?

Mit freundlichem Gruß: Bernd Wiebus alias dl1eic
http://www.dl0dg.de

Autor: Bernd W. (berndwiebus) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Günter W.

> Mit KiCAD habe ich neuerdings das Phänomen, daß Polygone nicht mehr
> gefüllt werden können, wenn eine Signalverbindung (Netz) berücksichtigt
> werden soll.
> Mit <no net> werden die Polygone gefüllt.

> Offensichtlich habe ich irgendwas in meinem Projekt verstellt.
> Auch nach DRC kann die Fläche nicht gefüllt werden.

Nein. Vermutlich enthält Dein Polygon NICHTS von Deinem Signal. Solche 
Polygone werden auch nicht gefüllt.
Das Verhalten deutet darauf hin.

Wenn Du ein Polygon mit irgendeinem Netz verbindest, sollte irgendwo 
etwas von diesem Netzt vom Polygon umhüllt werden, weil sonst keine 
elektrische Verbindung hergestellt werden kann. Das Polygon wird dann 
gefüllt, bis auf die Stellen, wohin aus räumlichen Gründen keine 
Verbindung geführt werden kann.
<No NET> füllt allerdings auch diese Polygone, solange keine 
elektrischen/räumlichen Gründe dagegensprechen.

Meine Version: Application: Pcbnew
Version: (2013-03-30 BZR 4007)-stable
Build: wxWidgets 2.8.10 (no debug,Unicode,compiler with C++ ABI 1002,GCC 
4.4.5,wx containers,compatible with 2.6)
Platform: Linux 2.6.32-5-686 i686, 32 bit, Little endian, wxGTK
Boost version: 1.53.0
Options: USE_PCBNEW_NANOMETRES=ON
         KICAD_GOST=OFF
         USE_WX_GRAPHICS_CONTEXT=OFF
         USE_WX_OVERLAY=OFF
         KICAD_SCRIPTING=OFF
         KICAD_SCRIPTING_MODULES=OFF
         KICAD_SCRIPTING_WXPYTHON=OFF

Mit freundlichem Gruß: Bernd Wiebus alias dl1eic
http://www.dl0dg.de

Autor: Max M. (gbl1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Bernd,

danke für deine Antwort. Gestern und heute früh habe ich es mehrmals 
probiert - ging nicht.

Jetzt soeben hat das Füllen der Flächen wieder funktioniert.

Kann leider nicht sagen was nun anders ist.


LG
Günter

Autor: Bernd W. (berndwiebus) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Günter W.


> Kann leider nicht sagen was nun anders ist.

Das passiert bei mir gerne, wenn ich unkonzentriert bin, und 
versehentlich auf das falsche Netz geklickt habe...... ;O)

Mit freundlichem Gruß: Bernd Wiebus alias dl1eic
http://www.dl0dg.de

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.