mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LCD Dislplay mit 8515


Autor: Marco Beffa (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe ein 2 Zeilen LCD Display wie in dem uC Tutorial auf dieser
Seite an meinen 8515 angeschlossen!

Aber das tut sich absolut nichts! Ich hab die entsprechende Software
(auch von dieser Page) in den uC geladen, das ist alles i.o. Ich habe
mein Display ebenfalls an Port D angeschlossen, wie hier beschrieben,
ich verwende den selben Code. Da ich zuerst nicht wusste was .include
"m8def.inc" bedeuet, habe ich zuerst die include Datei des 8515ners
geincludet, ging auch nicht...

Ich hab die Verdrahtung 100mal gechekt, daran kanns nicht liegen. Ich
habe ebenfalls ein neues Display angeschlossen, das selbe ergebniss,
das Display bleibt dunkel wie di nacht, absolut nichts ist zu
erkennen.

Die Versorgungsspannung liegt am Display an, 5.02 Volt gemessen. Die
Kontrastspannung habe ich Testweise auf GND gelegt, nach dem ich sie
wie beschrieben mit nem 10k Poti zwischen GND und Vcc gelegt habe..

Dann dachte ich der uC ist kaputt, der ist aber in Ordnung habe ihn
getestet.

Kann mir jemand einen Hinweis geben voran es noch liegen könnte?

Ich bin mit meinem Latein am Ende..

Autor: Jan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Das Display bleibt dunkel wie di nacht, absolut nichts ist zu
>erkennen.

Wenigstens einen schwarzen Streifen sollte man aber schon sehen, wenn
es ein LCD mit einem HD44780 kompatiblen Controller ist, sonst stimmt
die Stromversorgung und / oder Verkabelung nicht.

Autor: Hannes Lux (hannes)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Viele Displays benötigen eine negative Kontrastspannung. Dies sind
besonders die Industrieversionen für erweiterten Temperaturbereich.
Vielleicht hilft ja ein Blick in das Datenblatt des betreffenden LCDs.

Wenn das Display korrekte Stromversorgung hat, aber (noch) nicht
initialisiert wurde, dann sollte die obere Zeile komplett aktiv sein
(alle Pixel aktiviert).

...

Autor: Marco Beffa (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
soo jetz habe ich das display angeschlossen ich sehe die Balken, also
handwaremässig alles in ordnung...

Nun habe ich bereits ein weiteres problem, ich krieg es einfach nicht
gebacken irgend einen buchstaben auf dem Ding auszugeben!!

Ich habe alles versucht, die Initialisierung wie im Datenblatt gezeigt
erledigt. dann die weitere konfiguration wie gezeigt, aber es
funktioniert einfach nicht!

ist es normal dass ich auf ein paar steuerleitungen 5 Volt habe? wenn
ich am uC messen gehe liegt da ne 1 an..


nun, könntet ihr mir vieleicht ein kleines Code schnipsel kopieren, wo
ihr sicher seid dass es funktioniert! ich will keinen fertigen Code
etc, z.b. nur für einen Buchstaben anzuzeigen, den rest kann ich dann
schon selbst austüfteln irgendwie.

Das display ist im 8-bit modus angeschlossen und ich wäre um ein
programm in assemlber froh.

ich krieg das sonst einfach nicht gebacken! bitte um hilfe


Marco Beffa

Autor: Klaus (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Nehmste den da!

gruß Klaus

Autor: Klaus (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Oder nehmste den da!

Allerdings nur 4Bit Modus!

Wenn Du willst kannste  Umstricken auf 8 Bit Modus!

Du musst nur die Befehle rausschmeissen die das Low-Byte senden.

Im 8 Bit modus kannste ja das zeichen komplett senden :)

Gruß klaus

Autor: Marco Beffa (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke ichs habs jetzt schon hingekriegt!

habe vergessen, die daten dann auch mit Enable abzufragen ;-) lol

Grüsse, Marco Beffa

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.