mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit Interrupt von Schrittmotoransteuerung


Autor: David Huber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi!

bin seit kurzen beim programmiern eines Atmega32 und versuche
verzweifelt eine motoranschnittssteuerung zum laufen zu bringen!

Sourcecode-Ausschnitt:

void moto_move (uint8_t ID, int8_t Schritte)
{
  // Anschluss an L297 über
PA4=Enable,PA0=Drehrichtung(HIGH=clockwise),PA2=Takt

  DDRA   = 0xFF;    // Datenrichtungsregister wegen
                                // Interrupt erneut setzen

  PORTA |= (1<<PA4);          // Motor einschalten

  // Drehrichtung einstellen (positiv = rechts)

  if(Schritte > 0)
     PORTA |= (1<<PA0);

  // Takt ausgeben
  uint8_t i;
  i=0;

  while(i<Schritte)
  {    PORTA |=  (1<<PA2);
    _delay_ms(9000);
    PORTA &= ~(1<<PA2);
    _delay_ms(1000);

    i++;
  }

  PORTA &= ~( (1<<PA4)|(1<<PA0)|(1<<PA2) );

  return;
}

die Funktion moto_move wird von einem Interrupt ausgelöst!
jedoch sobalt ich den interrupt auslöse kann ich keine spannung an PA4
und PA2 messen!! aber das delay funktionier!!!!

die parameter (uint8_t ID, int8_t Schritte) welche übergeben werden,
sind beide "0xFF" also 256!!


vielleicht kann mir ja einer helfen!

Autor: Rahul Der trollige (rahul)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
1. ruf nie eine Funktion über einen Interrupt auf, sondern steuer mit
dem Interrupt ein Flag an, das in der Main-Funktion abgefragt wird.
2. Wenn du Pins an einem Port für Interrupts benutzt, mußt du das
DD-Register nicht neu beschreiben, weil die eigentliche
Interrupt-Steuerung eine höhere Priorität als das DDR hat.
Das DD-Register kann man auch der Anwendung entsprechend maskieren (in
diesem Fall müsste DDRA = 0x07 reichen zu Beginn des Programms
reichen).

Wenn man wüsste, welches Interrupt du bei welchen Controller wofür
verwendest, dann könnte man dir vielleicht auch etwas besser helfen.
Die Übersichtlichkeit wird durch Variablen-Deklarationen mitten im Text
nicht wirklich erhöht.
delay_ms(9000) erzeugt IMHO eine Pause von 9 Sekunden - etwas lang,
oder?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.