mikrocontroller.net

Forum: PC Hard- und Software Freigabe - Schreibschutz wegbekommen?


Autor: Dirk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe Probleme mit der freigabe!


ich möchte gern eine Freigabe unter XP (SP2)  erstellen und soweit so
gut, allerdings ist es Schreibgeschüzt und auch wenn ich unter
Eigenschaften des Ordners den Schreibschutz raus mache gehts nicht, er
Schreibschutz kommt wieder rein (FAT32).

Wie bekomme ich den Schreinschutz weg ?

Autor: Rufus T. Firefly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ich Dich richtig verstehe, siehst Du beim Zugriff über das Netzwerk
einen Schreibschutz. Dieser kann sich an zwei Stellen verbergen:
- Schreibschutz im Dateisystem mit Zugriffsberechtigungen
Da Du FAT32 verwendest, ist das eher unwahrscheinlich.
Zugriffsberechtigungen im Dateisystem sind nur mit NTFS möglich.

- Schreibschutz auf Netzwerkfreigabeebene
Du musst Dir die Berechtigungen der Netzwerkfreigabe näher ansehen,
nicht die des Ordners.

Autor: Dirk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wo finde ich diese in XP ?

Autor: Rufus T. Firefly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Explorer: Maus auf Ordnernamen bewegen, rechte Maustaste drücken,
"Freigabe und Sicherheit" im Kontextmenü auswählen.
Auf der Dialogseite "Freigabe" kann der Knopf "Berechtigungen"
angeklickt werden.

Erscheinen diese Dinge nicht, muss die "einfache Ordnerfreigabe"
deaktiviert werden ... und eventuell ein kastriertes XP Home
"entkastriert" werden (siehe Artikel in der c't von gestern).

Autor: Dirk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe XP Profi und die sachen die du da meist sind nicht da, könnest
du mir sagen was in der c`t steht ?

Autor: Rufus T. Firefly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Artikel in der c't bezieht sich nur darauf, wie man aus einem XP
Home ein XP Professional machen kann.

Das scheint Dein Problem nicht zu sein; Du musst die "Einfache
Dateifreigabe" deaktivieren.

Explorer: "Extras->Ordneroptionen", auf der Seite "Ansicht" das
Häkchen vor "Einfache Dateifreigabe verwenden" entfernen.

Autor: Dirk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe ich gemacht , allerdings läßt sich der Schreibschutz nicht
entfernen. Habe Vollzugriff und schreiben und lesen ein Hägen drin für
jeden Benutzer.

Autor: Rufus T. Firefly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wo exakt und wie nimmst Du den Schreibschutz wahr?

Schildere präzise, was Du auf dem Rechner machst, der die Freigabe zur
Verfügung stellt und was Du auf dem Rechner machst, auf dem Du die
Freigabe nutzt. Schildere insbesondere, wie Du mit Benutzerkonten
umgehst - verwendest Du auf beiden Rechner gleich benannte Konten; hast
Du schon mal die Impersonation ausprobiert?

BTW:
Was ist ein "Hägen"?

Autor: Dirk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Übers Netzwerk mit zwei XP Rechner.
Auf den einen XP Rechner (1) erstelle ich die Freigaben und da wo die
Freigaben eingerichtet werden. Sehe ich unter Eigenschaften
Schreibschutz ein rechteck, welches ich anklicke sodas es frei von
Häckchen oder Rechteck ist. Ist dann klar das ich von XP Rechner (2)
auch nicht drauf zugreifen kann. Allerdings ist mir auch aufgefallen
das dieses Rechteck auch bei anderen Verzeichnisen (Lokal) auch ist.
Lokal kann ich aber ein Ordner erstellen und Dateien anlegen, aber
nicht durch das Netzwerk.

Autor: Rufus T. Firefly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du meinst die erste Seite des Eigenschaften-Dialogs, wo das Wort
"Attribute" danebensteht.

In der Checkbox wird vom Explorer immer ein graues Häkchen
dargestellt, es sei denn, man ändert es, dann wird, bis der Dialog
geschlossen wird, kein Häkchen oder ein schwarzes Häkchen dargestellt.

Das graue Häkchen bedeutet nicht, daß das Schreibschutz-Attribut
gesetzt ist, es bedeutet nur, daß der Explorer zu doof/faul ist,
nachzusehen, wie es um das Schreibschutzattribut aller Dateien im
Verzeichnis und allen Unterverzeichnissen bestellt ist.

Wenn Du eine Verzeichnisebene weiter nach oben gehst, kannst Du den
Verzeichnisnamen in der rechten Hälfte des Explorerfensters anzeigen
lassen (Ansicht-Details); mit einem Rechtsklick auf die graue
Überschriftenleiste ("Name | Größe | Typ" etc.) kannst Du weitere
Spalten einblenden lassen. Eine davon heisst "Attribute", und die
solltest Du Dir ansehen.
Wenn da nicht 'R' steht (auch in Kombination mit anderen Buchstaben),
dann ist das Verzeichnis nicht schreibgeschützt.

Wenn Du genau hinsiehst, wirst Du feststellen, daß über den
"Eigenschaften"-Dialog es nicht möglich ist, das
Schreibschutzattribut des Verzeichnisses zu setzen. Der Explorer
behauptet zwar, er setzte es, macht es aber nicht. Allerdings werden,
so man dies wünscht, alle enthaltenen Dateien schreibgeschützt.

Setzen kann man das Schreibschutzattribut in der Kommandozeile:

  attr c:\bla\fusel\MeinVerzeichnis +R

und löschen

  attr c:\bla\fusel\MeinVerzeichnis -R

und sich anzeigen lassen

  attr c:\bla\fusel\MeinVerzeichnis

Das ergibt folgende Ausgabe:

  A   R   c:\bla\fusel\MeinVerzeichnis

bzw. dasselbe ohne 'R'.

Kläre mal, wie sich das ganze bei Dir verhält.

Autor: Dirk (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Also bei mir steht nichts, und als Anhang siehst du das es ein grünes
Rechteck ist, normalerweise kenne ich das nur wie du gesagt hast mit
graues Häckchen und schwarzes Häckchen.

Der Zugriff klappt jetzt, recht herzlichen Dank.

Autor: Rufus T. Firefly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vermutlich ist das grüne Rechteck das Äquivalent des grauen Häkchens.
Ich benutze nicht die Tupperware-Oberfläche von XP und kenne die daher
nicht so genau.

Ein Tip am Rande: Um so einen Screenshot anzuhängen, kannst Du ihn auch
mit mspaint (das Du ja offensichtlich auch verwendet hast) im JPG-Format
abspeichern. Dann ist er auch klein und wird nicht auf zwei Seiten einer
PDF-Datei verteilt.

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
Könnt ihr mir helfen? ich hab alles so gemacht wie es Rufus gesagt hat 
aber im Cmd sagt der,  wenn ich das eingegeben hab nur: Der Befehl 
"attr" ist entweder falsch geschrieben oder konnte nicht gefunden 
werden.
so long...

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
s/attr/attrib/

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
geht noch immer nicht :(
ich hab bis jetzt alles probiert.
(achja was ich nicht gesagt habe bei mir sind alle ordner 
schreibgeschützt (ALLES!!!) ich kann also gar nichts vom inet downloaden 
oder sonst irgendwas

Autor: Avr Nix (avrnix) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Robse (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi Leute ich habe da aber noch so ein anderes Problem
Wenn ich dass eingebe sagt der pc : parameterformat falsch -
was iss denn das??

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
a) DATEIFORMATE verdammt nochmal. Das ist ein Fenster, das Text 
enthält, warum machst Du davon einen Screenshot?!

b) Dein Pfad enthält Leerzeichen. Kommandozeilenparameter werden aber 
durch Leerzeichen voneinander getrennt - damit das bei Deinem Pfad nicht 
geschieht, musst Du den in Anführungszeichen schreiben:

attrib "blöder pfad den ich nicht abtippe" -r

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.