mikrocontroller.net

Forum: FPGA, VHDL & Co. 5V Signal


Autor: Martin Krause (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi @all,

seit kurzem hat mich das CPLD-Fieber gepackt und steh` nun vor einem
Problem(chen).

Ich benutze einen XC95144XL Baustein, versorge den mit 3.3V und einem
100MHZ Oszillator, ebenfalls an 3.3V. Im Innenleben befindet sich eine
kleine Schaltung, die mir die Eingangsfrequenz Teilt und um +-90°
verschiebt und an einen Ausgang legt.

So, nun brauche ich am Ausgang aber einen Pegel von 5V weil ich
dahinter einen TTL Schaltung dranbasteln will. Wie könnte ich dieses
Problem lösen? Oder gibt es einen anderen Baustein auf den ich
ausweichen könnte?

Kann mir von euch jemand weiterhelfen??

Vielen Dank und Gruß ans Forum.
BB MK

Autor: Kest (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es gibt auch CPLDs die 5V haben - XC95144 und alles andere. Sonst nimm
einfach einen Buffer 74hc244 oder wie auch immer (245 ?)

Kest

Autor: Neutron (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Martin Krause (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank an euch beide,

hab den 74hc244 genommen. Der gibt ein anständiges Signal heraus. Ich
kann leider nicht auf die XC9500 Familie zurückgreifen, weil ich ein
Eingangssignal von 100MHZ oder noch mehr verarbeiten muss, da machen
die schon schlapp.

Schönes Wochenende

Gruß MK

Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der XC9536 kann aber doch locker 100MHz.

Autor: Martin Krause (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Jens,

120MHZ müsste er schon aushalten können. Hab grad nochmal im Datenblatt
nachgeschaut, allerdings für den XC9536-10, denn den hätte ich noch
zuhause, ->fSYSTEM 2 Multiple FB internal operating frequency  66.7
MHz. Da wird der wohl ins schwitzen kommen, was meinst?? Der -5 läge
bei 100MHZ...

Ich denke, wenn ich ein "direktes" 5V-Ausgangssignal aus dem CPLD
habe, ist mein Signal von der Form her besser( Flanke, Amplitudendach)


Gruß MK

Autor: Jörn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die XC9500 Serie bringt keine saueren 5V raus. Die Spannung an den
Ausgängen liegt bei etwa 3,9 Volt:

http://www.mikrocontroller.net/forum/read-9-133344...

Gruß Jörn

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [vhdl]VHDL-Code[/vhdl]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.