Forum: Mikrocontroller und Digitale Elektronik Tiefpass filter


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von SCK S. (mendric)


Angehängte Dateien:

Lesenswert?

Hallo
Ich habe einen Tiefpass Filter mit einem LM13700 aufgebaut.

und habe da so meine Schwierigkeiten.
Wenn ich mir die Messung ansehe, denke ist das da falsch gelaufen ist.

Was meint ihr?

: Bearbeitet durch User
von james (Gast)


Lesenswert?

Zum teil tippe ich, dass irgendwas nicht mit deiner Spannungsversorgung 
stimmt. Du hast nen überlagerten 50Hz Sinus (sieht jedenfalls schwer 
danach aus). Schau die mal sämtliche Masseverbindungen an. Verändert 
sich die Amplitude wenn du daneben sitzt und z.B. nen Heizkörper anfasst 
oder ähnlicher Hokus Pokus?

Dann ist da noch ne zweite rippleähnliche Spannung. Willst du mit dem 
Tiefpass ein PWM auf eine Analogspannung glätten?

Oder hast du irgendwo Leistungsschalter oder benutzt du vielleicht einen 
DCDC Wandler um auf die Versorgungsspannung zu kommen?
Mach mal noch ne zweite Aufnahme mit kürzerer Zeitbasis. Vielleicht gibt 
dir die Frequenz Aufschluss über die Quelle.

von SCK S. (mendric)


Lesenswert?

Sorry hätte sagen müssen das es sich um ein Audiosignal handelt.

und ja ich habe einen DC/DC Wandler um von 12VDC zu +-15VDC zu kommen

: Bearbeitet durch User
von james (Gast)


Lesenswert?

+-15V... klingt nach nem integriertem Stepper, nicht zufällig so ein 
roter von TRACO?^^ schau doch mal in dessen Datenblatt in welchen 
Frequenzbändern der sich bewegt. Obwohl ich skeptisch bin. Ich denke, 
der müsste so schnell sein, dass es kaum auf der 20ms Zeitbasis zu sehen 
ist. Aber 1.) vielleicht täusche ich mich da, und 2.) vielleicht hast du 
irgendwo eine Überlastsituation und in dem Stepper greift irgendein 
Abschltmechanismus. Miss wenn möglich doch auch mal den Ausgangsstrom 
und am DC Wandler.
Aber nimm die mal primär den Stepper als Rippleursache vor.

Ich habe selbst noch keine Audiogeschichten designt und weiß nur, dass 
man sich über Brummschleifen den Teufel ins Haus holen kann. Vielleicht 
sind die 50Hz auf dem Bild auch ne Brummschleife...

von SCK S. (mendric)


Angehängte Dateien:

Lesenswert?

bin es nochmal durchgegangen

das Gelbe ist immer das Audio Signal
das Blaue immer die Messpuntke

Das erste Bild zeigt das Signal nach dem im LM13700 benannten Stereo 
Volume Control

Das zweite zeigt das Signal nach dem Addierer

Das dritte nach dem Tiefpass

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.