mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Emitterwiderstände und Basiswiderstände bei 10A Netzteil E


Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich bin grad dabei ein Power Netzteil aufzubauen. Die Eingangsspannung
liegt bei 50V DC. Die Ausgangsspannung soll einstellbar sein von 0-45V,
mit einem maximalen Ausgangsstrom von 10A. Mir ist wohl bewusst das bei
kurzschluss und 10A Strombegrenzung ein halbes KW verheitzt werden
muss. Jetzt habe ich probleme mit den Emitter und Basiswiderständen.
Ich hatte anfangs 0,68 Ohm am Emitter und 220 Ohm an der Basis. Das
ging bis jetzt am besten (hat am längsten gehalten). Dann sind die
Basiswiderstände abgebrannt. Dann habe ich dort 33 Ohm eingesetzt. Das
hat mir sofort einen Emitterwiderstand gekillt. Jetzt habe ich 0,1 Ohm
am Emitter und 470 Ohm an der Basis. Jetzt fliegt immer einer (immer
verschieden welcher) der BD250C durch, er verabschiedet sich mit
richtigen flammen die aus dem Loch kommen welches beim Platzen
entsteht. Welche Kombinations von Emitter und Basiswiderständen nimmt
man bei solchen Dimensionen, bzw. wie lassen die sich berechnen?

mfg
Stefan

Autor: Pöschi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

am besten du Postest mal ein Pic von deinem Schaltplan, damit man mal
die Beschaltung drum herum sieht.

Autor: Stefan (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
hier der Plan.

mfg
Stefan

Autor: Nicky (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Stefan,

warum verwendest du nicht eine Schaltung als emitterfolger? die
spannung an der basis lässt sich doch leichter einstellen, als der
strom für die Transistoren - bin ich der meinung!?

Dann kannst du mit nem µA741 (glaub ich - muss heute abend nochmal
gucken) wunderbar ein solches Netzteil aufbauen.

Autor: Unbekannter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh je. Die Endstufe kannst Du so total vergessen. Die schwingt Dir
munter hin und her. Das bekommst Du (als Anfänger) nicht in den Griff.

Du hast da zweimal eine Exponitialfunktion hintereinander geschaltet.
Zum einem der Transistor T1, der aus einer Basis-Spannung einen
exponential abhängigen Kollektorstrom macht und diesen über R16 in eine
Spannung wandelt, und zum anderen das gleiche Spiel nochmals mit Deinen
Endsutfentransitoren. Zusätzlich wird die von T1 erzeugte
Spannungsquelle mit den 6 Basiswiderständen der Endstufe
(Parallelschaltung!) extrem belastet.

So wird das nichts. Keine Chance das in den Griff zu bekommen.

Davon abgesehen, thermisch bekommst Du 500 Watt über 6 TO-3 Gehäuse
auch nicht in den Griff...

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tolle Heizung.

Autor: Unbekannter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das sollte übrigens "Exponentialfunktion" heißen...

Autor: dds5 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie Unbekannter schon schreibt haben 2 aufeinander folgende Stufen in
Emitterschaltung eine so hohe und extrem nichtlineare
Spannungsverstärkung, dass die Schaltung kaum ruhig zu bekommen ist.

TO3 Gehäuse kriegen bei Überlastung aber kein Loch aus dem ein
Feuerwerk aufsteigt, die BD250 haben TO247 oder ähnlich.

500W in 6 Transistoren dürften wirklich auch bei sehr guter Kühlung
kaum zu "verbraten" sein.

Dieter

Autor: Peter Dannegger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein Blick ins Datenblatt (SOA-Diagramm) verrät:

Bei 50V DC sind maximal 1A erlaubt, die Dinger müssen Dir also um die
Ohren knallen.


Und wenn man Emitterwiderstände zum Symmetrieren nimmt, müssen alle
Basen verbunden sein !

Getrennte Basiswiderstände bewirken nämlich genau das Gegenteil (der
mit dem höchsten Beta brennt durch).


Und wie ja schon gesagt wurde, ne Darlingtonschaltung als Emitterfolger
läßt sich am besten regeln.


Peter

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich muss euch leider in einer hinsicht enttäuschen. Die Endstufe, oder
besser gesagt das komplette netzteil funktioniert wunderbar, da
schwingt nix. Die Regelung, sowohl Stromregelung und Spannungsregelung
geht über 3 OPs. Die Stellwerte kommen von einem AVR, da hängt auch ein
Display dran um Strom und Spannung anzuzeigen. Mein Problem ist eben nur
das ab und an die Emitterwiderstände wegbrennen. Das liegt aber
warscheinlich da dran das das nur 2Watt Typen waren, weis auch nicht
wieso ich das gemacht habe. Ich denke ich werd es nochmal mit 0,68 Ohm
und 5Watt austesten. Das die Basen verbunden werden müssen ist ein
guter Tip. Im nachhinein auch klar. Ich wollte noch ne
Temperaturabschaltung mit reinbringen. Dann komme ich wohl mit meinem
Kühlkörper hin, ich hab es ja bereits schon ausprobiert. Ich will das
ding ja nicht Stundenlang im kurzschlussbetrieb bei 10A fahren.

mfg
Stefan

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das wird nix!
Die Verstärkung deiner Endstufe ist viel zu groß für eine vernüftige
Regelung. Diese muss unter eins bleiben!
Such mal nach verschiedenen Reglertopologien hier im Forum (P,PI,PID
Regler) wie willst du an die Störgröße heranfahren, ohne diese zu
überfahren? Mach mal. Du must nicht auf uns hören...

Wenn dreie schreiben, dass es nicht geht - dann wird ja wohl drann
sein.
AxelR!

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Na ist doch war...

Autor: Stefan (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
na ich bin eben von dem überzeugt was ich gesehen habe. Bei mir
funtioniert das komischerweise. Es war zwar garnicht danach gefragt ob
es so funktioniert oder nicht, sondern lediglich warum meine
Stromaufteilung nicht funktioniert. Ich hab im anhang mal den
kompletten Schaltplan eingefügt. Aber Achtung, entwerder stimmen die
die Bauteilwerte nicht oder stehen garnicht erst dran.
Bitte klärt mich auf warum das theoretisch so nicht geht. Welche
verstärkung muss kleiner 1 sein?

mfg
Stefan

Autor: Christian G. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Axel hat da vollkommen Recht, dazu kommt noch daß diese Endstufe
einfach nicht in der Lage ist, 10A bei 45-50Vce zu liefern, jedenfalls
zuverlässig nicht viel länger als ein paar -zig Millisekunden. Das was
dir die Transistoren durchjagt nennt man Second(ary) Breakdown: zu hohe
Verlustleistung führt zu einem weiteren Ansteigen des Stromes, was
wiederum zu höherer Verlustleistung und höherer Sperrschichttemperatur
führt und so weiter.
Es kann allerdings auch sein, daß das Ding doch zu Schwingen anfängt
und bevor du es merkst, hat sich dein Power-Oszillator schon selbst
abgeschaltet;-)
Angenommen, du hast eine Eingangsspannung von 50V und eine
Ausgangsspannung von 5V bei konstant 10A, dann fallen über
Emitterwiderstände und Transistoren 45V ab. Bei sechs Transistoren sind
das 1.67A pro Stück. Die Emitterwiderstände von 0.22R müssen dabei
jeweils eine Verlustleistung von R*I^2=0.61W vertragen, ein 2W
Widerstand schafft das also locker. Dabei fallen 0.37V ab, der Rest für
die Transistoren.
Was den hFE bei 45Vce und 10A anbetrifft, gibt mein Datenblatt leider
nicht viel her, nehmen wir mal großzügig 20 an. Für 1.67A brauchts da
einen Basisstrom von ca. 80mA. Deutlich mehr wäre hier auch besser.

Das Problem kommt aber mit der Safe Operating Area. Bei 45Vce lese ich
im Datenblatt einen zulässigen DC-Kollektorstrom vom 1.5A, allerdings
bei einer konstanten Gehäusetemperatur von 25°C. Die 1.67A verträgt der
Transistor für ca.5ms, vorausgesetzt du schaffst es, das
Transistorgehäuse auf 25°C zu halten. Aber auch wenn du das schaffst,
(mit einem wirklich ganz, viel, sehr großen Kühlkörper) kann die
Sperrschichttemperatur trotzdem sehr schnell unkontrolliert ansteigen
und sich der Transistor zerstören.
Deswegen wird dein Netzteil unter den gegebenen Eckdaten nie sicher
funktionieren.
Würdest du stattdessen 10-12 Transistoren parallel nehmen, bewegst du
dich eher innerhalb der SOA, die Basiswiderstände raus und eine stabile
Regelung rein.
Besser wäre allerdings wenn du dir erst mal ein paar funktionierende
Netzteilschaltungen dieser Leistungsklasse ansiehst, gibt ja genügend
im Internet, Netzteildesign mit ein paar hundert Watt Verlustleistung
ist nicht wirklich trivial und eine Heizung mit intergriertem Feuerwerk
ist bestimmt auch nicht das, was du wirklich willst.

Gruß,

Christian.

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was glaubts Du denn, warum ein Widerstand auf einmal abbrennt?
Wenn deine Aussage so stehen bleibt, schliesse ich daraus, das es
schonmal funktioniert hat und auf einmal Schwubbs diwubbs brennt ein
Emitterwiderstand ab. Hmm, schon komisch.
Was genau für einen Widerstand hast Du verwendet? einen 2Watt-Typ,sagst
Du.
Das ganze wird irgentwo auf UKW angfangen haben zu schwingen und die
Induktivität deines Widerstandes hat dessen Wechselstromwiderstand
ansteigen lassen. Dadurch fiel an diesem mehr Spannung ab, als vorher,
die Verlustleistung steigt im Quadrat und bumm!
Ich habe zwar nur eine UKW-Lizenz, aber glaube mir - ich bin damit groß
geworden!
Unsere NF-Verstärer fingen daaamaaals auch an zu schwingen, weil wir
armen Ossis(Jammer,Jammer)ja keine PNP Transistoren hatten, mussten wir
im unteren Endstufenzweig NPN (KD503 oder wer hatte 2N3773)nehmen. War
das gleiche in grün: schwingt wie sau, nur das unser Referenzwert eben
nicht per PWM erzeugt wurde, sondern aus der Musik am Eingang bestand.
Deine Endstufe soll nur Strom verstärken KEINE Spannung. Diese
Spannungsregelung macht doch schon der teure OPV mit seinen zich
Transistoren. Meinst Du, dem gefällt es, wenn die Vorgabe, die er
gemacht hat, durch die Endstufentransistoren rebellisch missachtet wird
(Spannungsverstärkung weit >1). Die sollen dem armen OPV nur helfen, den
Strom zu liefern, den er selber nicht bringt, statt dessen pfuschen sie
ihm in die Spannungsregelung rein.

1. OPV-> vergleich der Stellgröße mit Referenz-> neue Stellgröße
liefern
2. Endstufe -> Stellgröße niederohmig bereitstellen (Buffer)
3. Belastung -> Stellgröße fällt ein wenig

von oben nach unten.

Und so isses bei deiner Schaltung in etwa:
1. OPV-> vergleich der Stellgröße mit Referenz-> neue Stellgröße
liefern
2. Endstufe -> Stellgröße noch *größer* machen, niederohmig
bereitstellen (Buffer)
zurück zu 1. (weil stellgröße auf einmal viel größer,als die Referenz)
<-- Schwingt!
......
3. __?




gut erklärt?
AxelR.

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
da hat er auch versucht, Bestätigung für seine unbrauchbare Schaltung zu
finden, komisch, mehr oder weniger alle sagen, so geht es nicht. Der
gute Stefan meint aber, schlauer zu sein - warum fragt er eigentlich?

PS - ich kann crossposter ohne Querverweis nicht verknusen :-(

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@crazy
wie spürts Du die blos immer auf?

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Unbekannter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stefan,

wie hast Du festgestellt, dass da nichts schwingt? Mach doch mal mit
Deinem Oszi ein paar Fotos bei verschiedenen Spannungs/Strom
Verhältnissen.

Z.B. bei 5 Volt Ausgangsspaund und 5 Ampere Laststrom:

a.) Ausgangsspannung, AC-Gekoppelt
b.) Ausgangssignal des OPV der als Integrator die Spannung regeln
soll.
c.) Ausgangssignal des OPV der als Integrator den Strom begrenzen soll.

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich wusste nicht das crossposten so ungern gesehen wird. Ich mach mir
da keinen kopf drüber wenn ich so etwas sehe. Ich will aber auch keinen
Streit anzetteln.
Ich hab leider nicht so viel erfahrung in dieser hochstromtechnik und
analogtechnik. Ich habe nur das geschrieben was ich gesehen habe. Auf
dem oszi konnte ich keine schwingungen feststellen. Ich dachte das das
abbrennen mit der nicht funktionierenden emitterwiderstand
gegenkopplung zusammenhängt. Das hat ja aber bestimmt auch was damit zu
tun. Ich wusste nicht das man in dem fall keine basiswiderstände
benutzt.

mfg
Stefan

Autor: Nicky (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
um sich eine geregelte spannungsversorgung aufzubauen, sollten man
wenigstens etwas von den stabilen regelvoraussetzungen wissen, die da
heisst --> verstärkungsfaktor max. 1 besser kleiner).

wenn du also wirklich ne saubere schaltung bauen möchtest, bau deine
endstufe auf nen emitterfolger um. der hat ne verstärkung kleiner 1 und
erfüllt somit das 1x1 der regelung.

die endstufe soll wie schon erwähnt nur den strom treiben, die spannung
wird der endstufensektion bereits sauber als basispotential vorgegeben,
wodurch sich auch die Ausgangsspannung ergibt. (Ua=Ubasis-Ube-Ure).

ausserden, reduziert sich deine schaltung enorm in der aufwand.
Spannung aus µC (DAC), mit OV auf gewünschte Ausgangsspannung + der
Abfälle treiben, dort die endstufe zum strom treiben und die
rückkopplung zum vergleich an den µC (ADC) zurück.

(für eine stromverstärkung also keine spannungsverstärkung) ist nunmal
der E-folger am besten geeignet. und wenn du es nun immer noch nicht
glaubst, dann nimm dir nen buch zur hand

z.b. Analoge Schaltungen von Seifart

da stehen die wichtigsten grundlagen zur Regelung drin, und die
grundlagen für transistorstufen.

also weiterhin viel erfolg, wie auch immer du es angehen möchtest.


mfg nicky

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.