mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik PortC.1 immer auf low


Autor: Daniel (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich habe ein Problem. Mein Atmega8 Portc.2 ist immer high. Alle LEDs
außer PC.2 leuchten. Aber PortC.2 nicht der Fall. LED bleibt dunkel.

Anschluß:
+5V o---[1KOhm]---[A LED K]---> PortC.X sowie PortB.X
Alle LEDs sind richtig gesetzt. Auch am PortC.2 ist LED nicht defekt,
hab getestet und es leuchtet.

Woran könnte es liegen? IC falschherum eingebaut ist ausgeschlossen,
weil ich IC-Kerbe immer geguckt habe, bevor ich reinsetze.
Atmega wurde so oft gelöscht/überschrieben und erleidet Abnutzung?

Autor: Hubert.G (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
AVCC und AGND angeschlossen?

Autor: Daniel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Hubert. G

Muss nicht sein. 2 von 3 Atmega8 funktioniert einwandfrei. Nur 1
Atmega8 PC.2 funktioniert nicht.

Autor: Hubert.G (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Steht im Datenblatt das Port C von AVCC versorgt wird. Das es teilweise
auch ohne funktioniert weiss ich aus leidlicher Erfahrung.

Autor: Daniel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also, ich habe AVCC und GND verbunden. Immer noch das gleiche.

Was mir aufgefallen ist, ich habe Netzgerät auf 3 Volt eingestellt.
Alle LEDs außer PC.1 sind ausgeschaltet. Nur PC.1 leuchtet ständig als
sei PC.1 automatisch GND verbunden ??? Stelle ich auf 2 V, dann dimmt
LED PC.1 schwächer.

Autor: Daniel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab nochmal mit Durchgangsmesser zwischen GND und PortX gemessen

PC.5 = ~560
PC.4 = ~560
PC.3 = ~650
PC.2 = unendlich
PC.1 = ~310
PC.0 = ~650
PB.5 = ~645
PC.4 = ~660
PC.3 = ~630
PC.2 = ~660
PC.1 = ~660
PC.0 = ~660

Autor: Daniel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorry

Hab nochmal mit Durchgangsmesser zwischen GND und PortX gemessen

PC.5 = ~650 <-korrigiert
PC.4 = ~650 <-korrigiert
PC.3 = ~650
PC.2 = unendlich
PC.1 = ~310
PC.0 = ~650
PB.5 = ~645
PC.4 = ~660
PC.3 = ~630
PC.2 = ~660
PC.1 = ~660
PC.0 = ~660

Autor: Hubert.G (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das sieht allerdings nach defekten µC aus. Den wirst du nur verwenden
können wenn du die beiden Ports nicht benötigst. Ob sich das allerdings
auszahlt? Wer weis was er sonst noch abgekriegt hat. Kostet bei Reichelt
2,75€

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.