mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Olimex Starterkit MSP430-449STK2


Autor: pivo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Leute,
ich habe mal ne kleine Frage zum oben genannten Starterkit. Nachdem ich
ein wenig mit der USART rumgespielt habe und nie eine Kommunikation
zwischen Board und PC hinbekommen habe, ist mir aufgefallen, dass die
Signale (TX) einen sehr niedrigen Pegel (< 3V) haben. Die RS232 an
meinem PC reagiert bei diesen Pegeln ueberhaupt nicht. Hat jemand
Erfahrungen mit dem Board? Ist das normal? Warum fuehren die die
komplette Schnittstelle nach aussen, wenn ich dann doch noch den Pegel
wandeln muss?

Danke und Gruesse,

pivo

Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab gerade mal einen Blick in das Datenblatt geworfen, sehr seltsam.
Vergiss am besten den ganzen Tranistorkram und führe die Signale RXD
und TXD einem Pegelwandler von Maxim zu. Bei 3V ist klar, dass da
manche PCs nicht reagieren.

Und wieder mal eine Konsequenz von "unter allen Umständen billig
produieren". Dabei gibts die Pegelwandler doch auch von Sipex für
wenig Geld.

Autor: pivo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Von TI soll es dieses Kit ja auch original geben und Olimex baut es
eigentlich nur guenstig selbst. Ich werde mal sehen, ob es ein
Datenblatt von TI gibt. Wuerde mich interessieren, ob das Original
anders beschaltet ist.

Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
TI verbaut einen MAX3232.

Autor: pivo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tja, dann hat mir mein Studentenbudget wohl ein Schnippchen geschlagen
und ich muss ein wenig "nachbasteln".

Autor: Holger Menges (holger)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Beim MSP430-449STK war noch ein ST3232 drauf.

Autor: Stephan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Komisch; der 3232 hat ja nur eine Betriebsspannung von 3,3V. Die +/-12V
kommen normalerweise auch bei diesem Chip heraus! Würde ich nochmal
nachmessen; vielleicht ist irgendwas kaputt oder sogar schon im
Schaltplan falsch. Sowas hatte ich mal bei einem EvalBoard.

Stephan.

Autor: dds5 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die 232er Mäxe haben alle nur einen Spannungsverdoppler und einen
Spannungsinverter on chip.
Das sollte aber kein Problem sein, da die RS232 Pegel mit +-3 bis +-25V
spezifiziert sind.
Viele 232-Receiver arbeiten bereits mit TTL-Pegel zufriedenstellend.

Dieter

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.