mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik STK500 Firmaware update Probleme


Autor: Daniel Braun (khani)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

der im Folgenden dargestellte Fehler wurde bisher hier nicht (und sonst
anscheinend auch nicht) diskutiert :

Stand der Dinge : neues STK500, AVRStudio (neueste Version build 460),
keine Kabel dran, alle Jumper frabikneu und überprüftermaßen richtig
gesetzt, Windows 2000.

Beim Einschalten des AVRStudios und dem Versuch, einen
Programmiervorgang mit dem STK500 zu starten, wird einem ein Upgrade
der STK500-Firmware nahegelegt. Bestätigt man dies, passiert folgendes
:
 - ein Fenster poppt herbei, das einem erzählt, man solle das STK500
aussschalten, alle Kabel abziehen und dann unter halten der
"Program"-Tste das Board wieder einschalten. Anschließend soll man OK
drücken.
 - wenn man genau so verfährt, dann erscheint die Fehlermeldung "No
ISP-Programmer found", es wurde also nichts getan !
 - Eigentlich sollte die Status-Led (rot/grün) aus sein, wenn ein
Firmware-Update durchgeführt wird. Sie wechselt aber während des oben
beschriebenen Startvorgangs auf grün, wie als hätte man nicht die
Program-Taste gedrückt gehalten.

Hat jemand einen solchen Fehler schon mal beobachtet und/oder behoben
?! Oder ist das Board einfach nicht in Ordnung ?

MfG, Daniel.

Autor: Rolf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> - ein Fenster poppt herbei, das einem erzählt, man solle das STK500
>aussschalten, alle Kabel abziehen und dann unter halten der
>"Program"-Tste das Board wieder einschalten. Anschließend soll man
OK
>drücken.

Ich habe vor ein paar Tagen auch ein Firmwareupdate gemacht. Bei mir
hat es geklappt. Ich war etwas unsicher, wie die Anweisung zu verstehen
ist: Soll man die "Program"-Taste noch gedrueckt halten, wenn man OK
drueckt, oder nicht.

Ich habe mich spontan fuer loslassen entschieden und es hat geklappt.
Wie hast Du es gemacht? Hast Du die Taste noch gedrueckt gehalten, als
Du OK gedrueckt hast oder nicht?

Vielleicht liegt darin Dein Problem.

Rolf

Autor: TravelRec. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alle Kabel abzuziehen macht ja auch irgendwie keinen Sinn. Das
Stromkabel und das RS232-Kabel zum PC muß auf alle Fälle dranbleiben,
sonst kann die Update.exe das Board ja nicht finden... Update hat hier
tadellos geklappt mit STK 500 ausschalten, PROGRAM drücken, STK 500
einschalten (PROGRAM gedrückt halten, bis Farbwechsel-LED zur Ruhe
gekommen ist), PROGRAM loslassen, im PopUp OK klicken. Nach dem Update
das STK 500 ausschalten, einschalten und fertig.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.