mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LCD an MSP430 anschliessen ?


Autor: Jens O. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe heute probiert, ein LCD an einen 1232 anzuschliessen. Als
Software habe ich das char_lcd Beispiel aus dem mspgcc cvs genommen
(examples/char_lcd).

Das Problem ist : solange ich die 4 LCD Datenleitungen 4-7 an den
Portpints P1.4-7 angeschlossen habe, kann ich über das JTAG interface
nix machen (programmieren, etc.). Löte ich das LCD aus, programmiere
den MSP430, löte es wieder ein, tut das Beispiel einwandfrei.

Ich habe das Phänomen schon früher mal mit dem selben LCD an einem PIC
Controller gesehen, aber nie gelöst bekommen.

Meine Frage : wie sollte ich das LCD am besten anschliessen, evtl. über
Vorwiderstände ? Welchen Wert sollte man da nehmen, damit das LCD und
JTAG noch tun ? Hat jemand eine andere Lösung für das Problem ?

Danke,

Jens

Autor: KoF (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
so ewas habe ich noch nie gesehen! das selbe lcd hat auch am pic schon
diesen fehler ausgelöst?

hast du eventuell eine zu schwache stromquelle? so das wenn das lcd
angeklemmt ist, die versorgungsspannung unter die benötigte
flashspannung sinkt???

mfg
KoF

Autor: Tom (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Gemäss http://www.olimex.com/dev/images/msp430-h1232-sch.gif werden die
Portpins 1.4, 1.5, 1.7 und 2.6 für den JTag benutzt. AFAIK wird der
Test-Pin bei angelegtem JTag-Adapter auf ein anderes Level gezogen
(high?), wodurch die JTag-Pins auf JTag umgeschalten werden. Genauers
findest du bei TI unter SLAA089.

Versuch's doch einfach mal mit den Pins des 3. Ports.

Gruss

Tom

Autor: KoF (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hat der 1232 überhaupt einen 3. port???

Autor: SuperGrobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hat er... !
sogar komplett 3.0 - 3.7.

Autor: KoF (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hmm...
http://www.amsc.co.jp/supplier/ti/msp430f1232_boar...
der 1232 hat nur 2 ports ;-)

Autor: SuperGrobi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
versteh ich da jetzt was falsch ?! grübel

laut DB hat der aber mehr...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.