Forum: PC Hard- und Software Programmprobleme mit dem Arduino Eclipse Plug-In


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Jörg T. (kallejoerg)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Zusammen,

ich nutze ein Arduino Mega 2560 (Atmega2560) für eine Anlagensteuerung 
(Testaufbau). Die Anlagenbedienung erfolgt über LabView. Ich habe somit 
eine USB Kommunikation zwischen PC und µC. Das Programm ist mit der 
Arduino IDE oder mit dem Atmel Studio 6 IDE voll funktionsfähig. Alle 
Anlagenfunktionen funktionieren. Nun wollte ich gern das Arduino Eclipse 
PlugIn nutzen. Ich habe alles, wie im youtube Video 
(https://www.youtube.com/watch?v=bmBrGRLOn98) bzw. auf 
http://www.baeyens.it steht, installiert. Ich binde die wire, SPI und 
timer3 lib ein. Das complieren und der Upload zum µC funktioniert. 
Leider musste ich feststellen, dass ich Probleme habe mit dem Timer3 und 
mit serial-Funktionen.


Zum Timer:
------------------------------

Ich initialisieren den Timer:

  time_refill=2000000;                 // Nachfuellzeit in µs
  Timer3.initialize(time_refill);      // initialsiert timer3, 
Nachfüllzeit
  Timer3.attachInterrupt(stop_refill); // startet den Interrupt
  Timer3.stop();

In einer Funktion öffne ich ein Ventil (wta_PWM) und starte den Timer3:

  Timer3.start();

Wenn die 2000000µs zu ende sind, müsste void stop_refill() Funktion 
aufgerufen werden und das Ventil wieder schließen.

void stop_refill(void)
{
  sei();                         // Interrupt Enable
  analogWrite(wta_PWM, 0);       // Ventil schliessen
  Timer3.stop();                 // Stopt den Timer
  wta_vent=0;                    // Ventilstatus: "geschlossen"
}

Mit Eclipse öffnet das Ventil und schließt sofort wieder.

Zur Serial Funktion:
------------------------------

Ich Nutze die Funktion SerialEvent() um zu prüfen, ob etwas über den 
Port von Lab View kommt.

void serialEvent()
{
  time_serial_run=millis();
  char variable = Serial.read();
  datachanged++;
  switch(variable)
  {
    case 1: // AscII 1 in Hex? oder Dez?
    {
      delay(10);
      byte temp1 = Serial.read();
      Sensor=bitRead(temp1, 0);
      break;
    }

                ...

        }
}

Leider kommt kein Event an.

Hat jemand ein ähnlichen Problem mit eclipse und dem plugin gehabt.
Würde mich über Hinweise und Tipps freuen.

Danke im Voraus.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.