mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Problem mit PWM und Transistorarray


Autor: Jan Lohage (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen!

Ich habe meinen ersten PWM-Aufbau erfolgreich aufgebaut und getestet.
Wenn ich jetzt allerdings am PWM-Ausgang einen Transistor in Form eines
ULN2803A anschließe mit der Basis am PWM-Signal, dem gemeinsamen Emitter
an der Masse und dem Kollektor am Minuspol einer LED, die über einen
Widerstand mit 12V betrieben wird, dann wird die LED lediglich etwas
dunkler anstatt ganz auszugehen (Ich habe eine Routine geschrieben, die
langsam das Compareregister auf 255erhöht und danach wieder auf 0
verringert). Hat jmd eine Ahnung woran das liegen könnte? Wenn ich die
LED direkt an dem PWM-Ausgang betreibe, funzt alles tadellos? oO

Wünsche eine geruhsame Nacht,
Jan

Autor: Läubi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja der ULN geht auf Maximal 5V hoch, das sidn 12-5 = 7V gug für die
LED.
Versuch mal die Freilaufdiode an +12V zu klemmen, oder benutz nen
Pullup nach +12V

Autor: A.K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was sollte der Pullup bringen? Noch mehr Strom durch die Diode?

Der "Common" Anschluss vom ULN muss an die höchste beim ULN
verwendete Versorgungsspannung ran. Hier also die 12V.

Autor: Jan Lohage (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja, hab die freilaufdiode auch an 12V. Die LEDs gehen aber trotzdem
nicht ganz aus. Könnte es eher sein, dass ich nen Pulldown-Widerstand
am PWM-Pin brauche?

Autor: Jan Lohage (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh Gott, Leute...
Ich hab mir grad die ganze Schaltung und die Platine angesehen... und
was lese ich auf dem vermeindlichen ULN2803A? MAX232ECPE! Äußerst
verwunderlich, dass überhaupt irgendetwas geleuchtet hat! Sowas kann
auch wieder nur mir passieren, also niemals ICs mit dem gleichen
Package nebeneinander legen beim basteln :D
Trotzdem ein Dankeschön an euch zwei, dass ihr euch Gedanken gemacht
habt ^^

Grüße, Jan

Autor: A.K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moment mal. Der ULN2803 hat doch 18 Pins und der MAX232 nur 16. Sowas
fällt nicht auf??

Autor: Jan Lohage (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
auf ner total verbastelten lochrasterplatine nicht ;) naja und im eifer
des gefechts... hab jetzt alles umgelötet und funzt astrein, gehen auch
sauber aus und so :)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.