mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit OP-integrator


Autor: Sebastian (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo
Ich hoffe ihr könnt mir helfen. Hab schon einen Physiklehrer und einen
Elektrotechniker gefragt - erfolglos.

Habe mit einem Operationsverstärker (LM324, +/-14V) einen Integrator
aufgebaut. Ziel ist jedoch nicht dass das integrieren an sich, sondern
dass sich bei einer schnellen Eingans-änderung der ausganz nur langsam
ändert. Die Genauigkeit ist also nicht so wichtig.
Der "freie" Potieingang kommt von einem anderen OP, der Ausgang des
Integrators geht über einen 47k Wiederstand auf den Eingang eines 3.
OPs.
Da ich aber als maximalen Ausgangswert nicht die Knapp 14 Volt des OP
haben will hab ich parallel zum Kondensator eine Zener-diode gelötet
(siehe angehängten Schaltplan)
 --> Der OP geht von -Uz bis 0V.
Bei einer 10V zenerdiode funktioniert die sache auch einwandfrei. Hab
dann die sache mal mit 4,7V versucht.
Der OP hat auch weiterhin integriert, aber je nach Poti-stellung nur
bis 2 bis 4 Volt (minus). Das Poti ist eigentlich dafür gedacht zu
bestimmen wie schnell sich die Ausgangsspannung ändert.
Kann mir das beim besten willen nicht erklären. Würde mich sehr freuen
wenn ihr mir weiterhelfen könnt.

MfG
Sebastian

Autor: Frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Ziel ist jedoch nicht dass das integrieren an sich, sondern
dass sich bei einer schnellen Eingans-änderung der ausganz nur langsam
ändert."

Wie wäre es mit einem einfachen RC-Tiefpass (und Spannungsfolger), oder
ist das nicht, was Du suchst?

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei einem RC-Tiefpass hab ich aber wieder die krumme Kennliene des
Kondensators, oder? Und genau das will ich nicht.
Die Integration muss in hinblick auf die Zeit nicht so genau sein, da
ich ja nicht das Integral an sich will. Sollte aber schon eine
möglichst konstante änderung sein.

Sebastian

Autor: dds5 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das liegt mit hoher Wahrscheinlichkeit daran, dass die Kennlinie von
Z-Dioden mit niedriger Spannung sehr "weich" ist.
Die Diode fängt schon bei 2 bis 3 V unter Nennspannung an und leitet.
Der fließende Strom bewirkt eine Verringerung der Verstärkung und der
Integrator begrenzt deshalb zu "früh".

Dieter

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Würde die sache jedenfalls erklären. Dake schon mal.
Und als Gegenmaßnahme? nen Spannungsteiler an Ausgang und ne 10V Diode
nehmen...?

Autor: dds5 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn die Spannung begrenzt werden muss, bietet sich Dein Vorschlag an.
Falls der nachfolgende Verstärker am inv. Eingang angesteuert wird kann
man auch einfach den Eingangswiderstand erhöhen.

Dieter

Autor: jaja (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
na ja, der Eingangstrom ist ja Ue/(47k-Potistellung). Die Sperrkennlinie
der Z-Diode ist nicht unendlich steil, d.h. von Null an wird das Teil
integrieren, und ab der von Dir genannten Spannung "übernimmt" die
Z-Diode. Weiter wird dann nicht integriert.
Guck Dir mal die Funktionweise eines invertierenden OPAMP an, und die
Kennlinie der Z-Diode, also bei welchem Strom ist die Spannung etwa da
wo ich hinwill. Dieser Eingansstrom muß bei vorhandener
Eingangsspannung, Potistellung + 47k auch fließen können.

Was ist denn das erklärte Ziel, mal genauer beschrieben?

gruß

ts

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also wenn ich dich richtig versteh, dann fließt zu wenig Strom über die
Zener-Diode? Muss zugeben: das 1MOhm Poti ist vielleicht etwas groß.
Würde jedenfalls auch die abhängigkeit der Ausgangsspannung von der
Poti-stellung erklären.
Hab allerdings auch schon direkt am 47k Widerstand (also zwischen
Wiederstand und Poti) mal mein Kabel (mit +/-14V) rangehalten, und hab
trotzdem keine 4,7V gekrigt. Weiss nicht mehr genau was es war, halt so
2 bis 3 Volt.

Ziel der Schaltung ist nen Sollwert für ne PWM vorzugeben. Quasi als
Hochlaufgeber lass ich halt integrieren.

Sebastian

Autor: jaja (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...selbst ohne Poti kommen bei den 47K halt nur so 0.3 mA raus.

Ach so?! Eine Rampe soll vorgegeben werden. Dann mach das alles mal
niederohmiger, und dafür halt einen größeren Kondesator.

Also volle Spannung anlegen, und der Widerstand mal so 2k (statt 47k)

An Stelle der 2K kannst Du ja auch mal ein 5k Poti versuchen.

Dann geht das auch...wetten?


ts

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da halt ich nicht gegen. Würd sowieso verlieren. Das mit den niedrigeren
Widerständen is scho net schlecht, aber der Kondensator ist von der
Größe her jetzt schon an der Toleranzgrenze. Brauch halt auch ne
Verzögerung von durchaus einigen Sekunden.

Werds bei Gelegenheit mal probeweise aufbauen mit kleineren
Widerständen, aber bauen werd ich dann den Spannungsteiler. Der Is im
nächsten OP (nichtinvertierender Addierer) quasi eh schon drin. Einfach
einen Widerstand ändern. Aber trotzdem danke. Tut gut trotzdem zu wissen
warum's nicht ging.

Autor: AxelR. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>>
aber der Kondensator ist von der
Größe her jetzt schon an der Toleranzgrenze.
>>
10uF gibt es in 1206, 2xparallel.. geht das, oder schon zu viel Platz?

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Doch das müsste gehn. Muss mal schaun, dass ich zeit find es
auszuprobieren. Muss (trotz Ferien) recht viel für die Schule tun, und
ich hab mich ja jetzt eh schon für den Widerstand (Spannungsteiler)
entschieden, da der eh schon vorhanden ist und nur nen anderen Wert
bekommt.

Anyway: Danke!

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So hab heut mal zeit gefunden. Bei einem 4k Widerstand in der
Ansteuerung gehts, aber das ist mir echt zu gering. Aber ich hab ja
noch ne andere Lösung.
Hab dann auch mal ne Messkurve von der 4.7V und von der 10V Diode. Da
liegen echt welten dazwischen. Die 10V hat quasi nen Knick drin,
während die 4,7V da schön gemächlich durchschaltet.
Auf jedenfall nochmal danke für die schnelle Hilfe

Sebastian

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.