mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR ISP


Autor: Tom K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Wie bekomme ich es schaltungstechnisch hin, daß ich meinen AVR (8515) 
ISP-mäßig programmieren kann, obwohl einige der entsprechenden I/O-Pins 
in meiner Schaltung anderweitig belegt sind (SCK & MISO sind Ausgänge, 
MOSI ist noch frei)!?
Muß ich das immer umstecken oder gibt es da eine elegantere Lösung?

danke,

ciao Tom

ps: was mache ich eigentlich mit unbeschalteten Pins? einfach freilassen 
oder irgendwie auf Masse legen oder wie? (sorry, bin Anfänger ;)))

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn die Pin's Ausgänge sind und nicht direkt eine Logik treiben, dann 
schalte Widerstände in Reihe zur Anwendung und schließe die ISP Signale 
direkt an den Prozessor. Wenn irgend ein CMOS oder HC Chip drann hängt 
brauchst auch garnix.


Freie Pin's irgendwie definieren entweder als Ausgang oder Eingang und 
die internen Pulup aktivieren.

Mike

Autor: Tom K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Mike!

An den Ausgängen hängen eigentlich nur 2 LEDs... wenn ich dich richtig 
verstehe und dementsprechend Widerstände in Reihe dazu schalten soll, 
würden diese ja unbeabsichtigt dunkler werden. (!?) Wie kann ich das 
umgehen? An was für Widerstandsgrößen dachtest du da?

ciao Tom

Autor: MarkusS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

wenn Du an den Ausgängen schon LEDs hängen, dann sind die Wiederstände 
ja schon da.
Ich kenne Diene Schaltung zwar nicht, aber in der Regel ist  die Led in 
Reihe mit einem Wiederstand geschaltet, entweder gegen Masse oder der 
Versorgungsspannung.

Nun brauchst Du nur noch die Programmierpins des Prozessors mit deinem 
Stecker für die Programmierung zu Verbinden.
Je noch Programmieradapter sollte man aber prüfen ob dann eventuell 
Ports gegeneinander treiben, wenn der Programmieradapter aufgesteckt ist 
und die Applikation läuft.

Gruß, MarkusS

Autor: Frankl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Versuche es aber bitte nicht mit PonyProg seriell, das geht nicht.

Autor: Axel (ojojo) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Frankl
Was macht das PonyProg den für Progleme?
Bei mir geht´s mit nem 4433er wunderbar und mit meinen 1200ern nur ab 
und zu (und z.Z. gar nicht mehr)

jo
Axel

Autor: Tom K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aha... also die LEDs sind ganz normal gegen die 5V Versorgungsspannung 
geschaltet. Programmieren wollte ich mit dem STK500 über den 6poligen 
ISP-Stecker. So wie ich euch also verstanden habe, reicht es also 
wirklich aus lediglich an die PINs vom AVR zusätzlich die ISP-Leitungen 
ranzuhauen... kommt mir irgendwie schon fast zu einfach vor :)

ciao Tom

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.