mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik 1 von 2 Identischen Schaltung funktioniert nicht


Autor: Tina Klein (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

mein Problem liegt darin, ich habe zwei fölig identische schaltungen
aufgebaut. Sie sind beide auf einer Platine. Es handelt sich dabei um
je  1 AtMega 32 ein GLCD Display. Leider funktioniert nur die erste
hälfte der Platine sprich ein Mega und ein Display. Komisch ist auch
das ich den anderen Mega zum laufen bringe wenn ich nach anlegen der
Spannung resete, dies funktioniert allerdings nur wenn der erste Mega
auch im betrieb ist, was eigentlich nicht sein dürfte es müssten beide
unabhängiglaufen. Da die Schaltung identisch ist kann ich folgendes
Auschliessen Display oder Softwarefehler.

Wie gesagt identisch aufgebaut, jeder mega hat nen eigenen quarz,
Resttaster usw. Folglich hängen nur die Spannungsversorgung der beiden
zusammen vom Spannungsregler 5V und GND.

Falls ihr eine Ahnug hab was es sein könnte wäre ich über eure
Antworten sehr dankbar.

Autor: Hubert.G (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Man soll nie etwas ausschließen das man nicht detailiert überprüft hat.
Mega und Disp schon einmal untereinander getauscht?
Sonst wird es ein Hardwarefehler sein und der ist schwer zu sehen.

Hubert

Autor: Klaus...(Norad) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Bitte deinen Schaltplan als *.PNG Posten sonst kann dir keiner helfen.

Gruß Klaus

Autor: Tina Klein (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

@Hubert
ja klar hab beides untereinander getauscht, es funktionieren beide MC´s
und Displays am ersten Port, nur am zweiten eben nicht.
Deswegen kann ich den MC und das Display getrosst ausschliessen.

@Klaus
Ich hab leider keinen schaltplan da ich die schaltung auf lochraster
habe.

Könnte es damit zusammen hängen das ich beide über diesen einen
Spannungsregler laufen lasse?

Autor: Die Waldfee (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Identische Schaltung bei Lochraster gibts nicht.
Irgendwo verzählt, eine Lötbrücke, ein Kabel nicht richtig angelötet.
Dann könnte noch sein, dass der funktionierende µC dies aus Zufall
tut...
Checkliste:
Kondensatoren am Quarz?
100nF Kondensatoren am Spannungsregler und an den µC nebst Display?
Elko vor dem Spannungsregler?
Dass der zweite nur dann läuft, wenn der erste auch läuft, hört sich
für mich nach ziemlich versauter Versorgungsspannung und fehlenden Cs
am Quarz an.

Autor: Unbekannter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja, rein von der Logik her:

a.) Die Schaltungen sind identisch und deterministisch, dann verhalten
sie sich auch identisch.

b.) Die Schaltungen verhalten sich unterschiedlich, dann sind sie
entweder nicht identisch, oder sie sind identisch aber nicht
deterministisch.

Langer Rede kurzer Sinn: Entweder ist die Schaltung an sich Schrott,
oder in einer ist ein Defekt...

Autor: Hubert.G (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das mit der Spannungsversorgung wäre möglich. Sind genügend C vorhanden,
bei Lochrasteraufbau doppelt wichtig, testweise je ein L, wenn nicht
vorhanden ca. 22 Ohm  in die Versorungsspannung einschleifen,
entsprechend mit C versorgt.

Autor: Klaus...(Norad) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Tina

Nicht, dass du ausversehen ne Reihenschaltung darausgemacht hast
sprich:
Die Spannungsversorgung für den 2 µC an irgend einen Port geängt hast.

Prüf mal ganz genau was Du da zusamengebraten hast.

Übrigens wie hast Du die Schaltung ohne Schaltplan zusammengekiegt ist
nämlich ein böser fehler! zumind. meiner Meinung nach.

Gruß Klaus

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.