Forum: Mikrocontroller und Digitale Elektronik ESP8266 an LM2596 -> TX-Müll


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Dan N. (dan1824)


Bewertung
0 lesenswert
nicht lesenswert
mahlzeit zusammen,

kurzer aufbau: LM2596 <-> ESP8266   ///   CP2102 <-> ESP8266


ich habe in einer bestehenden schaltung nun auf einen LM2596 (fertiges 
modul) für 3.3v umgerüstet.

das problem: am CP2102-RX kommt seitdem einfach nur noch müll vom 
ESP8266-TX an.

ich habe hier drei dieser fertigen module von verschiedenen herstellern 
getestet; bei allen dasselbe phänomen.

ändere ich die spannungsversorgung wieder zurück (also ohne den LM2596), 
dann kommen saubere serielle daten (ergo: ESP8266 und CP2102 unbeschadet 
und funktionsfähig).



FRAGE:
ist bekannt, dass der LM2596 stört?
was kann ich tun, um diese schaltung zu betreiben? (elko irgendwo 
zwischen setzen, andere maßnahmen?)

: Bearbeitet durch User
von Timmo H. (masterfx)


Bewertung
0 lesenswert
nicht lesenswert
Hast du ne möglichkeit mal die ESP-TX mit nem Scope anzugucken?
Sind die GNDs von LM2596, ESP und CP2102 vernünftig verbunden und VCC 
von LM2596 und ESP (nicht Steckbrett?)

: Bearbeitet durch User
von Dan N. (dan1824)


Bewertung
0 lesenswert
nicht lesenswert
>Hast du ne möglichkeit mal die ESP-TX mit nem Scope anzugucken?
das wäre schön, aber leider nein

>Sind die GNDs von LM2596, ESP und CP2102 vernünftig verbunden (nicht
Steckbrett?)

das passt soweit; (aus steckbretterfahrungen lernt man ja irgendwann :)



seltsam ist, dass nur schrott ankommt, wenn spannung über den LM2596 
anliegt.

lasse ich alles gleich und gebe direkt 3.3v drauf läuft's perfekt

von Timmo H. (masterfx)


Bewertung
0 lesenswert
nicht lesenswert
Vielleicht ist der LM2596 unterfordert. Viele Schaltregler brauchen eine 
minimale Last damit die Regelung vernünftig funktioniert. Habe beim 
LM2596 jetzt allerdings auf die schnelle nichts gefunden. Kannst ja aus 
Spaß noch mal eine zusätzliche Last ran hängen (der ESP braucht ja nur 
beim Senden etc. seine ~300mA Spitze).
Vielleicht auch nochmal einen kleinen Abblockkondensator zwischen VCC 
und GND versuchen.

: Bearbeitet durch User
von Dan N. (dan1824)


Bewertung
0 lesenswert
nicht lesenswert
au super, danke dir, das ist ein sehr guter einfall!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.