mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik LF50CDT und Wechselspannung


Autor: Philipp Burch (philipp_burch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich hab' hier eine Schaltung mit einem LF50CDT (5V Spannungsregler,
Low Drop Voltage). Das funktioniert alles wunderbar, wenn ich vor
meinem Gleichrichter bereits eine Gleichspannung anhänge. Komme ich da
aber mit Wechselspannung ist die Ausgangsspannung des Reglers 0V.
Abblock-Kondi (100nF) ist vorhanden, die Eingangsspannung sieht am KO
wunderbar gerade aus (100µF-Elko drin) und alles ist tipp top. Nur
kommt einfach nix raus. Ich hab' auch schon die gesamte "Last"
(Standby ca. 20mA) abgehängt und es kommt trotzdem nix raus. Aber
sobald ich dann wieder eine Gleichspannung von 6 - 25V anlege ist alles
in bester Ordnung. Da kann ich vor dem Gleichrichter auch + und -
vertauschen, alles kein Problem.
Frage: Woran kann es liegen, dass der bei einer Eingangsspannung, die
ich aus einer gleichgerichteten Wechselspannung (50Hz) gewinne, nicht
funktioniert? Wie gesagt, ich sehe beim Eingang keinerlei Störungen.
Und wie könnte sich das Ding dann bei einer Freq von ca. 20KHz
verhalten? Dafür ist die Schaltung eigentlich ausgelegt (Rotor für eine
PropClock).

Ich wäre sehr froh, wenn mir jemand helfen kann, mit meinem Latein bin
ich langsam am Ende...

Hier noch das Datenblatt:
http://www.ortodoxism.ro/datasheets2/0/00ciacs9p08...

Danke schonmal im Voraus für Hilfe!

Autor: Arno H. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn Du das Datenblatt nicht nur verlinkt, sondern vorher gelesen
hättest, wäre Dir bestimmt aufgefallen dass LDO-Regler eine andere
Ausgangsbeschaltung brauchen als ein 7805!
Alle Spezifikationen dieser Reglerfamilie beziehen sich auf einen 2,2µF
Elko am Ausgang.
Arno

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Normalerweise glättet man erstmal nach dem Kondensator, nur so.

Ich denke das mit dem Kondensator sollte nicht das Problem sein, aber
du solltest nach dem Gleichrichter einen dicken Elko (je nach Last)
einfügen, um die "Lücken" aufzufüllen.

Autor: Philipp Burch (philipp_burch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie gesagt, vor dem Regler ist ein 100µF Elko und ein 100nF
Abblock-Kondi drin. Also die Spannungs hat keinerlei Spikes oder
anderen Müll, von daher sollte das eigentlich kein Problem darstellen.
Nach dem Regler habe ich einen 22µF Kondi, der ist wohl etwas zu gross,
da muss ich noch einen 2.2µF testen, wenn's dann des wär'...
Danke jedenfalls für die Antworten.

@Arno:
Ich habe es gelesen, also reg dich ab. Wenn es wirklich am
Ausgangskondi liegen sollte, dann ist es mein Fehler, ok. Wenn nicht,
dann weiss ich auch nimmer.

PS: Momentan beträgt die Last nur einige Milliampère, also sollte der
Kondi am Eingang auf jeden Fall genügend gross sein. Die maximale Last
beim Betrieb ist aber auch nur etwa 200mA, wenn überhaupt.

Autor: Arno H. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
2,2µF ist das Minimum, eventuell muss er grösser sein. Bei jedem
Abschnitt ist in der letztenm Zeile der C0 noch mal mit 2µF min und
10µF typisch angegeben. Wichtig ist auch gerade hier der ESR!
LDO sind leider nicht so gutmütig und eigenstabil wie ein 78XX.
Lesenswertes dazu:
http://www.national.com/an/AN/AN-1148.pdf
Arno

Autor: Philipp Burch (philipp_burch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Öhm... Ich glaube, ich weiss jetzt woran es lag. An Wechselspannung war
die effektive Spannung am Regler ungefähr 23V und ich habe das kleine
Sternchen bei 40V im Datenblatt übersehen :$
"(*) For 18 < VIN < 40 the regulator is in shut-down"

Tut mir leid, wirklich mein Fehler.

Trotzdem danke an alle!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.