mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik NE555 Schaltung?


Autor: Freak5 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
http://www.freak5mynew.no-ip.info/muell/NE555-50DC.gif
Für T2 ist dort in der Gleichung CLn angegeben(Zeile 7). Meinen die
C*natürlicher Logarithmus?

Autor: Burt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
http://www.elektronik-kompendium.de/public/schaere...

hier ist das ganze besser erklärt..... jedoch nur für den
CMOS-timer....

mfg Burt

Autor: Mücke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Meinen die C*natürlicher Logarithmus?

Ja, meinen die. Kommt von der Ladegleichung des Kondensators, da steckt
ja die e-Funktion mit drin.

Autor: Freak5 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thx. Ich habe noch ein Problem:
http://www.infogr.ch/roehren/zuendspule/zsp_1_08.jpg
So ähnlich habe ich die Schaltung aufgebaut(genauso aufgebaut
funktioniert alles wunderbar. Ich habe allerdings keine Spule am
Ausgang). Die Kapazität ist ~560pF
Der Wiederstand R1(an Pin7) ist 380Ohm der an Pin 6 ist zwischen 380
und 22kOhm regelbar.
Das ergibt eine Frequenz von ~420kHz anstatt ~1kHz der
Originalschaltung.
Transistor1: BC556B
Transistor2: BU508 AW

Der Transistor 1 liefert bei 400kHz keine steilen Flanken mehr und am
Außgang von Transistor 2 ist nurnoch die Störung der Flanke zu
erkennen, obwohl am Eingang eigentlich noch ein Rest des Signals zu
erkennen ist.
Wenn ich die Schaltung länger betreibe um den Fehler zu suchen sieht
Transistor1 nach ~2 Minuten aus, wie ein kochender Topf. Mit dem
Unterschied, dass er langsam breiter wird und dass er nach Plastik
stinkt. Wenn man dann noch weiter arbeitet gibt er den Löffel ab.

Ist der Transistor nicht für diese Frequenzen ausgelegt, oder woran
kann das Problem liegen?
Ich habe auch schon die Kapazität weggelassen.


Meine Last besteht wie schon gesagt nicht aus einer Spule. Ich habe 3
12Ohm Widerstände benutzt. Inzwischen habe ich 2 12Ohm Widerstände und
(2x 380 parralel)

Kann mir jemand helfen? Ich wollte heute mit der Schaltung eigentlich
die Resonanzfrequenz einer Spule messen...

Autor: Freak5 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe das Datenblatt von Transistor 2 Studiert. Kann dieser den
Schaden an Transistor 2 verursacht haben, weil ich die Maximale
Frequenz überschritten habe? Wenn ja, warum? Ich habe doch einen
Widerstand dazwischen. Kann Transistor 2 auch Schäden genommen haben?

Ist die Schaltung nicht normalerweise auch mit Mosfets möglich? Dann
tausche ich den. Ich sehe keinen Grund, warum es nicht funktionieren
sollte, aber ich frage besser nach.

Später möchte ich damit die Resonanzfrequenz einer Spule messen. Sollte
ich noch eine Zenerdiode an die Basis klemmen?

Autor: TriccyMan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

sieht nach einem Problem "Grundlagen Transistorschaltungen" aus.

Überlegung: Der BD242 hat durch den 10Ohm (Rest vernachlässigt) einen
Kollektorstrom ca 1000mA. An der Basis begrenzt der 1K den Strom auf
10mA. Der BD242 ist bei 1A mit hfe 25 min angegeben, wird daher nicht
durchgesteuert und warm.
Nimm mal 120Ohm an die Basis, dann fliessen dort 100mA (schafft der
normale NE555) , der BD242 wird dann sicher durchgesteuert.

mit Gruß vom
TriccyMan

Autor: Daniel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
..als Altautofahrer .... die Zünsspule wird keine 400Khz mitmahcne ...
der Kern würde in Dauersättigung kommen.... Freulaufdioden ;-) .....


vgl. http://www.s800.langhammernet.de/zundung.html

Autor: Freak5 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@TriccyMan: Da steht doch, dass ich das nur so ähnlich aufgebaut habe!
Ich habe einen BC556B genommen.
Ich habe mir das Datenblatt zwar nicht angesehen, aber ich meine, dass
der so wie so nur mit ~1mA geschaltet werden sollte, da die
Schaltgeschwindigkeit bei 10mA schon abnimmt und er so wie so schon
voll durchgesteuert ist.

@Daniel: Ich habe den Schaltplan nur angegeben, weil es ungefähr
stimmt. Ich habe einen Ohmischen Widerstand benutzt keine Zündspule!!

Autor: Axel R. (axelr) Flattr this
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi, der BC556 ist definitv zu schwach.
Die maximale Stromverstärkung liegt bei einem Kollektorstrom von 10mA,
so vie auch alle anderen Parameter im Datenblatt mit 10mA
Kollektorstrom angegeben werden.
Der BC640 könnte gerade so klappen.
Beschalte mal dann die Basis-Emitter Strecke noch mit 47Ohm, damit die
Basis schneller ausgeräumt wird. Zusätzlich kannst Du noch einen
kleinen Elko (1uF) parallel zum 1K Basiswiderstand löten.(Dieser ist
natürlich - wie TriccyMan schon sagte - viel zu groß! 100 Ohm maximal)
Ich tendiere aber trotzdem zu einem BD244. lass mich das kurz
begründen:

Der BU508 hat bei angenommenen 3Ampere Kollektorstrom noch eine
sagenhafte Stromverstärkung von FÜNF! Das ist bei der Dimensionierung
der Treiberstufe zu beachten.
Interessant ist auch die Spannung, die im BU508 "hängen bleibt".
Du müsstest 500mAmpere Basisstrom liefern, um bei 2Ampere
Kollektorstrom die Sättigungsspannung unter 0.5V zu bekommen. Sollten
3Ampere fliessen, kommst Du bei 500mAmpere Basisstrom in Bereiche der
Restspannung, die im Diagramm garnicht mehr angezeigt werden (>2.8V).
Also hier ist richtig "Bums" angesagt. so wie bei MOSFETS auch, nur
mit dem entscheidenen Unterschied, das hier der Steuerstrom über die
GESAMTE ON-Phase anliegen muss.
Alles nicht so einfach mit Bipolartransistroen. Du könntest Versuchen,
zwei BU508 als Darlington zu schalten? Die Stromverstärkungen
multiplizieren sich dann (Sind dann immerhin schon 25).
Es gibt die BU Typen auch als Darlington auf einem Chip. Schonmal
gesehen?
siehe Anhang -> Eigenbau von 1985
(ich hab sowas mal gelernt, glaube ich :-o ...)

Viel Spass noch bei diesem interssanten Thema

AxelR.

Autor: Freak5 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Endlich mal jemand, der meine Angaben gelesen hat.
Ich denke, dass ich versuche gleich einen Fet zu benutzen oder mit
einem Powerfet den Transistor zu schalten(wobei das keinen Sinn macht,
falls das mit dem Fet schon funktioniert)

Liegt es nur an der veränderten Last, dass es bei 1kHz und Zündspule
funktioniert und dass es bei 400khz + 36-160 Ohm keinen Output mehr
gibt?

Im Datenblatt steht nämlich, dass der BU Transistor auch nur bis 16khz
schalten kann.

Mein Lehrer meinte, dass ich eine Resonanz getroffen habe ^^. Ich habe
ihm aber auch nicht gesagt, welchen Transistortyp ich schalten wollte.

Autor: Freak5 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
http://www.freak5mynew.no-ip.info/muell/NE555-45kh...
Stimmt der Transistor zerstört schon das Ausgangssignal. Ich denke,
dass ich mir also eine Mosfetendstufe bastelt werde und auf den
Powerfet ganz verzichte. Der Transistor zerstört das Signal
signifikant.
http://www.freak5mynew.no-ip.info/muell/NE555-45kh...
Der Ausgang des Leistungsmosfet über dem Ohmischen Widerstand sieht
garnicht so viel schlimmer aus ^^
Um die Resonanzfrequenz von irgendetwas zu testen wird es aber sicher
nicht reichen.

Autor: Freak5 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
WICHTIG...
Wenn man nun den Transistor(BC556) nur sehr schwach belastet(1kOhm)
Dann funktioniert er nur bei niedrigen Frequenzen, da ab 100kHz die
Fallzeit zu lange dauert:
http://www.freak5mynew.no-ip.info/muell/NE555-45kh...
Bei niedrigeren Frequenzen:
http://www.freak5mynew.no-ip.info/muell/NE555-45kh...
Woran liegt das? Kapazitäten im Transistor, die durch den
1kOhmWiderstand nicht schnell genug entladen werden?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.