mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik LM5122 (Boost-Converter) Strombegrenzung / Spannungseinbruch bei Last


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Marian K. (krocky)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe einen Boost-Converter (Eingang 12V - Ausgang 26V (Max. 120W)) 
konstruiert.
Zum Einsatz kommt ein LM5122 von Texas Instruments.
Verwendete Spule: COILCRAFT  SER2915H-153KL
Verwendeter Shunt: VISHAY WSK06124L000FEA (4mOhm)

Die Beschaltung ist an die Demoboards/Datenblatt/WEBENCH angelehnt.

Anbei der Schaltplan und das Layout.

Nun zu meinem Problem:

Der LM5122 schafft es bei Last nicht sich auf eine Ausgangsspannung von 
26V einzuregeln.
Wenn lediglich das Oszi am Ausgang angeschlossen ist, schwankt die 
Ausgangsspannung zwischen 26V und 24V bis er wider anfängt die Mosfets 
zu Schalten. Die Schaltpause dauert 2 Sekunden. Danach werden die 
Mosfets wieder geschaltet, bis einen Spitzenspannung von 26V erreicht 
ist.

Bei einer Last von 5W (siehe Anhang) wird lediglich nur noch ein kurzer 
Peak mit 26V gemessen, die restliche Zeit liegen 12V (Eingangsspannung) 
am Ausgang an.
Bei Erhöhung der Last (25W) steigt die Anzahl der Schaltvorgänge, die 
lange Pause (12V Ausgangsspannung) zwischen drin ist weiterhin 
vorhanden.

Besonders auffällig: wenn der Shunt überbrückt wird, ist ein nahe zu 
dauerhaftes Schalten zu erkennen, die Ausgangsspannung erreicht aber 
lediglich einen Peak von 22V (Siehe Anhnag). Mit dem Oszi messe ich eine 
Spannung von 500mV über dem 4mOhm Shunt (-> 125A), meine 
Spannungsgenerator ist aber bei 5A schon in der Begrenzung.


Hat von euch jemand Erfahrung mit dem LM5122, oder ähnlichen 
Schaltregler mit Überlastsicherung?

Ich würde mich sehr freuen, wenn mir jemand weiterhelfen könnte.

: Verschoben durch Moderator
von geb (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich hab den Eindruck, dass du noch nicht viel Erfahrung hast. Ein Boost 
Converter für 125W bei 500kHz Schaltfrequenz ist jetzt keine 
Kleinigkeit, auch für einen erfahrenen Elektroniker.
Zu deinen Problemen:
1.) wenn du an solchen Schaltungen mit dem Oszi misst, ist das was auf 
dem Schirm zu sehen ist nicht unbedingt das, was in Wirklichkeit 
passiert. Du musst die Masseleitung des Taskopfs so kurz wie möglich 
halten, besser noch ohne die Krokoklemmenmasse arbeiten, und dafür einen 
kurzen Draht in die Schaltung löten, der dir die Masse direkt an den 
Taskopf führt.
2.)Es scheint ein Problem mit Spannungs und Stromregelung zu geben. 
Ursache ist meist ein schlechtes Layout mit zu langen Leitungen, was 
Störungen verursacht. Schau ins Datenblatt, dort sieht das Layout 
deutlich anders aus als bei dir. Du kannst einmal mit den 
Dämpfungskondensatoren für die U und I Regelung spielen (d.h. vergrößern 
bzw. mal nachmessen ob überhaupt richtig) und schauen was passiert.Wenn 
du Glück hast,funktioniert das dann bereits.
3.)Der lückende Betrieb des Schaltreglers wär jetzt nicht ungewöhnlich, 
wenn er für 125W dimensioniert ist, und nur 5W entnommen werden. Bei 25W 
sollte er aber konstant laufen.
Sonst musst du da wohl einfach selbst Erfahrungen sammeln.

Grüsse

von Marian K. (krocky)


Bewertung
0 lesenswert
nicht lesenswert
Danke für deine Rückmeldung.
Ja, viel Erfahrung habe ich leider nicht.

Die Dämpfungskondensatoren habe ich ausgetauscht, jedoch weiterhin das 
gleiche Fehlerbild.
Die Intension meines Layouts war es, das ganz so Kompakt wie möglich zu 
gestallten. Das dies solch Einfluss auf die Funktion nehmen kann war mir 
nicht Bewusst.

Ich werde mein Layout überarbeiten.

von Mike (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Das Layout sieht eh nicht so schlecht aus.

Wennst du Top-Seite mit Bauteilbezeichner getrennt mit Bot-Seite mit 
Bauteilb. als pdf anhängst ist es leichter zu verifizieren.

Als Last verwende keine Glühlampen(wegen den geringen KaltWiderstand )
nur Lastwiderstände.

ich würde folgendes Ausprobieren:
Den Minus-Anschluss des Lastwiderstand auf den Minus-Anschluss des 
Einganges. Lastwiderstand 5W. Ist die Ausgangsspannung 24V?

Zusätzlich:
Ich würde bei Schaltreglern generell immer Supressordiode z.B. SMBJXXA 
am
Eingang einbauen, weil Schaltregler Transienten produzieren welche so 
hoch werden können dass der IC zerstört wird und/oder beim 
Ein/Aus-Schalten der IC defekt wird. Ist mir oft passiert.

von Marian K. (krocky)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

danke für deine Rückmeldung.
Anbei nun das Layout getrennt von Bottom und Top.

Wenn Ihr hier einen Fehler findet, der für das Verhalten verantwortlich 
sein könnte der nicht auf das Layout zurückzuführen ist, wäre ich 
natürlich sehr froh. Ansonsten muss ich das im anderen Thread 
vorgestellte Layout fertigen.

Als Last wurde eine elektronische Last verwendet.
Wird die Supressordiode einfach am eingang zwischen Vin und GND gelegt?
Ist es mir möglich in irgendeinerweise die Fehlersignal zu entkoppeln?

von Mike (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo

Mir fällt auf, dass die Source-Pads nicht verbunden sind. Es sollte 
schon
alle 3 Source-Anschlüsse miteinander verbunden sein.


Wird die Supressordiode einfach am eingang zwischen Vin und GND gelegt?
Ja.
Die Suppressor-Diode dient zur Reduzierung der Transienten.

Ist es mir möglich in irgendeinerweise die Fehlersignal zu entkoppeln?
Ich machs mit einer kleinen Eienspirale vom Kugelschreiber.
Nur ca. 1cm lang. Auf die Spitze des Tastkopfes. Krokoklemm.-Kaber 
abnehmen.

Oder: Am Ausgang 10cm 2 pol. Leitung verdrillen mit 100nF Kond. und am 
Kondensator den Tastkopf angängen.

Mike

von Mike (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo
Nochwas eingefallen ;-)
Das Exposed Pad(EP) unter dem IC soll mit dem Pad verlötet sein.
Wennst du das EP nicht verlötest, kann die Wärme nicht abgeführt werden.
D.h. Bei Last würde er sich immer ein und ausschalten wegen der therm. 
protection des ICs.

Vielleicht is es des ;-)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.