mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik warum stirbt mein FET ?


Autor: Ssss Ssssss (sssssss)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Warum ist mir schon zweimal der Mosfet bei folgendem Einsatz
"gestorben" ?
(gestorben = ich messe immer 80 Ohm zwischen Drain und Source)


Mosfet: BSS138 N-Kanal, Logic level, 0,2A
        http://www.fairchildsemi.com/ds/BS/BSS138.pdf

Schaltung:
                                  ,-------------o --> zur h bridge (low
side)
                                 |
                                 +---[4,7k]-----o + 12V
                                 |
                             G  _. D
0/3.3V o---------[330]--------||_
                                 | S
                                 |
                                 `--------------o GND

Angesteuert wird der Mosfet über 3,3V Pegel, maximale Taktfrequenz =
100Hz oder so.

Der obere Anschluss geht zu einem LowSide FET von einer BTS7710G
H-Bridge:
http://www.ortodoxism.ro/datasheets/infineon/1-BTS...
Der BSS138 wird also nur zum Richtungsumschalten benutzt.


Rekonstruktion wie er gestorben ist:
Platine gelötet, getestet (mit ESD Armband).
Bin dann nochmal in den Keller gegangen um ein paar Löcher in die
Platine
zu bohren, hab das dann in eine ESD Verpackung getan und bin zur Uni
gefahren.
Dann angeschlossen und der BSS138 war defekt.

Evtl waren kurzzeitig die 12V nicht am BTS7710 angeschlossen.

Jedenfalls bin ich jetzt irgendwie ratlos warum der FET gestorben ist.
Dasselbe ist mir vor gut 5 Tagen mit der gleichen Schaltung und einem
BTS7710GP passiert. Da war aufeinmal an der Uni
auch ein BSS138 tot.

Nachdem ich die BSS138 ausgetauscht habe funktioniert der Motortreiber
1A und ist auch >30min im Dauereinsatz gelaufen.

Was mache ich falsch ?!

Evtl elektrostatische Aufladung beim in den Keller gehen ?!
Während der gesamten Lötprozedur etc hab ich ein ESD Armband getragen
und auch sonst nichts angefasst ohne Erdung.
(hatte nur zwei von den BTS7710 und wollte kein Risiko eingehen 8) )

Komisch ...

Gruss,
Simon

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

1A ist zuviel nach Datenblatt bei UGS 3V -> ID 0,1A

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

sorry nicht richtig gelesen, vorherige Antwort streichen.
Ich vermute das die Gate-Ladung des Lowside-Fets den Transitor killt.
Ich würde mal einen Widerstand zwischen Drain und Eingang der h-Bridge
schalten.

Autor: Ssss Ssssss (sssssss)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wo hast du die 1A her ?
Der schliesst doch nur die 4,7KOhm kurz (-> 0,002A).
Ok die Gatekapazität kommt noch dazu von der HBridge aber ist die so
heftig ?!

Sehe gerade dass ich oben das falsche H-Bridge pdf verlinkt habe,
korrekt ist:
http://www.infineon.com/upload/Document/cmc_upload...

Gruss, Simon

Autor: Ssss Ssssss (sssssss)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ah ok ;)

Also du meinst in die obere Leitung einfach zb 330 Ohm hinzu ?
Werd ich mal einplanen fürs neue Layout ;)

Hmm aber wieso stirbt er dann nicht während meines 30min tests ?!

Gruss, Simon

Autor: Sepp -O- (Sepp_O) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Salve

Normalerweise gibt man doch den Widerstand beim FET zwischen Gate und
Masse.

Durch den Widerstand zwischen Gate und Masse wird verhindert bei hohen
Tahtfrequenzen die eventuell tötlichen Reflexionen.

So wurde es mir jedenfalls gesagt.

Benötigt man eigentlich einen seriellen Widerstand am Gate?

Mehr als in die Sättigung kann man einen FET nicht treiben und auf der
Drainseite begrenzt der 4,5K Widerstand den Strom sowiso.

Oder hab ich irgendwo einen Fehler in meinen Annahmen?

mfg Sepp

Autor: SuperUser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Simon,

ein Widerstand zwischen Gate und VSS verhindert, das sich das Gate auf
mehr als die erlaubte Ugs auflädt.

Das würde ich dir sehr empfehlen. Z.B. 470k.

Ansonsten ist - wenn der Gate-Treiber Ausgang hochohmig ist - dein Gate
extrem hochohmig und kann sich leicht auf zerstörerische Spannungen
aufladen.

Wenn die Schaltung läuft passiert natürlich nichts, da der
Treiber-Ausgang niederohmig ist.

Gruesse
   SU

Autor: Ssss Ssssss (sssssss)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Danke euch allen,
im Prinzip ergibt sich dann folgende Schaltung:

                                  ,--[330]------o --> zur h bridge
                                 |
                                 +---[4,7k]-----o + 12V
                                 |
                             G  _. D
0/3.3V o---------[330]-+------||_
                       |         | S
                       |         |
                       `-[100k]--+--------------o GND


Die zwei Widerstände passen sogar noch relativ gut auf die Platine
drauf 8)
Hab sie mal angehängt als eagle3d file
(die C's auf auf den Pinleisten kommen noch ordentlich daneben, waren
nur für den Prototypen da)

Danke ;)

Gruss, Simon

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.