mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Instrumentenverstärker mit 0p07


Autor: sputnik (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Ich hab diese instrumentenversärkerschaltung aufgebaut mit 3
OP07. Am Ausgang habe ich 400mV erwartet, gemessen habe ich wie immer
total was anderes, nämlich 1,53 V.
Beim Eingang U1 waren ursprünglich über ein poti 100mV eingestellt,
nachdem ich den OPV angeschlossen hatte plötzlich 136mV. Beim Eingang
U2 stieg die Spg um ca. 15mV.
Danach habe ich nur einen 0P07 als Impedanzwandler beschaltet und als
Eingangsspg. 110mV gewählt nach dem anschließen des OP stieg die spg
wieder auf 125mV und am Ausgang waren 1,33V.
Danach habe ich einmal 5V angelegt und am Ausgang waren dann auch 5V.

Gibt es eine Möglichkeit diese kleinen Spg. richtig zu verstärken, oder
muss ich mir einen teuren ina118 besorgen?

Gruß sputnik

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie hoch sind denn Deine +/- Versorgungsspannungen ?

Autor: sputnik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
die beschriebenen Werte sind bei +- 12V aufgetreten, danach habe ich wie
im datenblatt angegeben +-15V verwendet, dadurch ist die Ausgangsspg auf
1,53V angestiegen.

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kann es sein, dass die Schaltung schwingt? Kondensatoren an den
Betriebsspannungsanschlüssen?
Falls vorhanden, Betriebsspannung und Ausgangsspannungen der OPs mal
mit einem Scope anschauen.

Autor: sputnik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ein Scope steht mir leider nicht zur Verfügung, aber ich glaube nicht
dass die schaltung schwingt da ich die betriebsspannng über einen
festspannungsregler einstelle(LM317)...

Autor: Unbekannter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du hast doch nicht etwa normale Kohleschichtwiderstände mit 5% Toleranz
verwendet?

Autor: sputnik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nein metallschicht mit 0,1%

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich weiss jetzt nicht, welches Murphy'sche Gesetz es ist, aber:
Verstärker schwingen immer, Oszillatoren nie.
Mit dem Glauben ist es so eine Sache. Die Symptome sprechen jedenfalls
sehr dafür.

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Na ja, die OP07 sind eigentlich zu lahm, um noch schwingen zu können :-)
Aber LM317 schwingen sehr gut !

Autor: Hegy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aus Erfahrung: die Schaltung hatte ich auch mal aufgebaut, aber bei
Verstaerkungsfaktoren von 1000 wurde da nix raus, zuviel abweichung.
Daher habe ich mich dann fuer ein OPA entschieden und es funktionierte
wesentlich besser. Aber bei 13facher Verstaerkung unbedingt nen
ziemlich teuren INA118 zu verwenden ist schon heftig. Wie gross ist
denn ueberhaupt die Spannungsdifferenz am Ausgang von U1 & U2?
Warum nicht einen (nicht) invertierenden Verstaerker mit nur 2 OPs
(erster als Spannungsfolger (nicht inv. Verstaerker mit Faktor 1) und
einer Verstaerkerstufe mit Faktor 13?

Autor: Michael Michael (mike_s)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

warum baust du einen Instrumentationsverstärker diskret auf??

Gibts fix und fertig von z.B. Analog Devices AD524.

Ist abgeglichen und funktioniert. Diskret hast du immer Probleme mit
Offset R1,R3,R4,R5 müssen exakt gleich groß sein R7 und R6 auch gleich
groß usw.

Nimm einen fertigen, und du bist in derlei Hinsicht ssorglos.

Grüße,

Michael

Autor: 3 Newton (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Instrumentenverstärker in dem Design bauen ist imho nicht sinnvoll. Eher
einfachen Differenzverstärker mit OPA oder kaufen das Vih. Gibts ab 5
Eusen aufwärts.

INA1xx AD5xx
3N
INA 111 ist Standart und recht gut. Geil ist INA116, bereits mit Schutz
und extrem kleinem Bias.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.