mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit ULN2803


Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich schaffe es einfach nicht (auch wenn es sich dämlich anhört) den ULN
so anzusteuern, dass ich damit etwas schalten kann.
Ich habe an Pin9 GND und an Pin10 +5V, an Pin18 (dem ersten Ausgang des
ULN) habe ich zum Testen eine 5V LED mit der Kathode dran, die Anode
habe ich auf +5V liegen. Leider ist es jetzt ziemlich egal was für ein
Signal ich auf den Pin1 (Eingang 1 des ULN) lege, die LED leuchtet
einfach immer.

        ->  I Pin1   Pin18 I  -> LED-> +5V
             I                    I
GND ->  I Pin9   Pin10 I  -> +5V

MfG
Sven

Autor: Alexander (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andere Pins probiert? Anode-Kathode der LED evtl vertauscht?
oder Chip im Eimer.
Liegen am Eingang wirklich die 5V/0V an?

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Momentan probiere ich ohne Microcontroller und lege direkt die 0V/5V an
den Eingang. habe jetzt auch schon eine Led anders herum angeschlossen,
leuchtet dann gar nicht. Den Chip habe ich auch schon getauscht...

Autor: Barti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du zur LED in Reihe noch einen Widerstand zur Strombegrenzung?
Sonst kann man mal raten was zuerst kaputt geht...LED oder ULN. Die 5V
an PIN10 kannst Du erstmal weglassen, da Du keine indukiven Lasten
schaltest. PIN9 ist richtig. Wenn jetzt PIN1 auf log. 1 liegt, steuert
der ULN GND durch und die LED müßte leuchten. Ist eigentlich ne ganz
einfache Schaltung. Die LED müßte leuchten...

Autor: Gustav (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Verbinde mal Pin 10 über einen 100k Widerstand mit GND.

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Barti: Die Led ist für 5v und sie leuchtet immer, egal was für ein
Pegel an Pin1 liegt.

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Gustav: Leider das gleiche Ergebnis, trotz Widerstand

Autor: Barti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aso...nu bin ich auch ratlos. Ich würde auf defekten ULN tippen, aber da
Du ihn schon getauscht hast un die Teile eigentlich relativ robust sind,
kommt das eher selten vor dass 2 kaputt sind.

Autor: Alexander (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also wenn der Eingang auf 0V liegt, was ist denn dann am Ausgang? Sollte
hochohmig sein. Teste mal ohne LED und nimm vom Ausgang zu 5V einen
Widerstand. Irgendwas hochohmiges am besten. Wenn dann immer noch 0V
anliegen ist was faul am Chip.

Autor: Marc Meise (bytewood) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nur so ne Idee:
Wie steuerst Du den ULN an? Mit einem Controller (STK?), oder einfach
nur so, über ein Strippen?

Wenn Du über den STK ansteuerst:

Hast Du eine gemeinsame Masse?

Autor: Barti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hat er doch oben geschrieben, dass er es erstmal nur mit 0 und 5V Pegel
ohne Controller versucht.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.