mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik MSP430F147 & FT232BM/ keine Treiberinstallation möglich


Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo.

Ich soll im Rahmen eines Praktikums eine USB Schnittstelle
programmieren. Nachdem ich mich eingelesen habe, wollte ich dann den
aktuellen D2XX Treiber installieren, um die Funktionen der
dazugehörigen DLL nutzen zu können.
Bei der Installation kommt ständig folgender Fehler:
 "Error, ftdiun2k.ini not found"
Habe anschließend FTClean ausgeführt, was allerdings nix gebracht hat.
Der Fehler blieb der gleiche.

Betriebssystem ist XP/SP2.

Wenn ich meine Platine an den USB Anschluss anstecke, erscheint der
Controller auch nicht. Allerdings weiß ich nicht, ob die Platine 100%
in Ordnung ist. Sollte aber normal schon stimmen.

Wenn mir jemand helfen könnte, wäre ich dankbar.

Grüße, Markus

Autor: Jörg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also Windows hat kein Gerät gefunden beim einstecken vom USB?

Autor: Steffen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Existiert die Datei denn? Wenn nicht entpacke den Treiber mal neu. Die
Version die ich hier habe verschiebt die Datei auch immer an statt
diese zu kopieren. Beim zweiten Installationsversuch bringt er daher
immer diese Meldung.

Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Jörg
Genau, ich hab meine Platine mit dem FT232 eingesteckt und Windwos sagt
gar nix.

@ Steffen
Wie, ob die Datei existiert? Ich konnte den Treiber gleich beim ersten
Mal schon gar nicht installieren.
Der Support von FTDI hat dann irgendwas gemeint von wegen, dass
irgendwas total mit der Installation schief ging:
"It looks like something is screwed up with your install"
aber das weiß ich selber :-)
Die meinten auch, ich sollte alles manuell aus der Registry
rauslöschen. Das wollte ich dann auch lustigerweise machen, aber ich
hab nix von FTDI in der Registry gefunden, außer 2 Einträge im IE.
Seitdem warte ich nochmal auf eine Antwort von denen.

Hab auch versucht, den Treiber auf den PC´s meiner Kollegen zu
installieren, genau das gleiche.

Jetzt weiß ich nicht mehr weiter.

Grüße aus dem verschneiten Bayern

Autor: Steffen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du hast doch mit Sicherheit das *.zip-File von FTDI oder? Da sollte die
Datei enthalten sein. Also noch mal entpacken und dann erneut
versuchen.

Manuell die Registry zu durchsuchen ist eigentlich Quatsch. Auf der
Homepage von FTDI gibt ein extra Bereinigungsprogramm (nicht die
mitgelieferte UnInstall-Routine). Damit werden alle Einträge entfernt.

Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab das zip-File von FTDI.

Der Support von FTDI schrieb:
"If you are installing the D2XX driver then the uninstaller looks for
FTD2XXUN.INI, for VCP ftdiun2k.ini is used."

Genau das ist meiner Ansicht nach das Problem. Bei der Installation vom
D2XX sagt er nämlich "ftdiun2k.ini not found". Aber laut FTDI sollte
er diese Datei gar nicht brauchen, außer ich verstehe falsch, was die
geschrieben haben.
Die FTD2XXUN.ini hab ich schon.

Dieses Bereiningungsprogramm, solltest du FTClean meinen, dass hab ich
bereits mehrmals laufen lassen und es hat jedesmal gemeldet:
Successful.

Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe es auch mit verschiedenen Unzip Tools versucht, keinen Erfolg.
Immer das gleiche

Autor: Steffen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was hast Du mit verschiedenen Unzip-Tools versucht?

Wie schon geschrieben, die FTDIUN2K.INI wird bei der Installation
verschoben oder gar gelöscht (da liegt der BUG). Wenn Du die Datei
wieder in das Installationsverzeichnis (aus dem *.zip-File) kopierst,
sollte sie auch gefunden werden. Hat bei mir jedanfalls dann
funktioniert.

Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab mit verschiedenen Zip-Tool dieses File von FTDI "ausgepackt",
das meinte ich.

Ich habe aber diese Datei FTDIUN2K.ini überhaupt nicht. Sie vor dem
Entpacken nicht da und nach dem Entpacken auch nicht.

Kannst du mir die Datei evtl auf obige Adresse schicken. Das wäre toll

Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oder am Besten wäre es evtl auch, mir das ganze ZIP-File von FTDI zu
schicken für den FT232BM USB-Controller

Autor: Steffen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist unterwegs.
Ähhmmm, die FTDIUN2K.ini gehört zum VCP-Treiber. Beim D2XX-Treiber gibt
es die nicht. Egal, ich habe dir beide Treiber dazugepackt. Evtl.
funktioniert damit ja die Installation.

Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stimmt, die gehört zum VCP-Treiber. Da hab ich was verwechselt.
Werde es testen, hoffentlich funktioniert es bald.

Dankeschön fürs schicken.

Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit diesem Treiber funktioniert es auch nicht. Ich will den D2XX Treiber
installieren und er bringt wieder genau das gleiche, dass er die
FTDIUN2K.ini nicht findet.
Aber die braucht man ja gar nicht für den D2XX ???

Hab es auch auf meinen privaten Rechner getestet, der noch vollkommen
unbelastet war von irgendwelchen vorherigen Versuchen, da klappte es
auch nicht. merkwürdig ???

Autor: Steffen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Versuche mal zuerst den VCP-Treiber zu installieren. Den habe ich bei
mir jedenfalls als erstes drauf gepackt. Der D2XX-Treiber hat sich dann
problemlos installieren lassen.

Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
aber man sollte doch nur einen der beiden installiert haben, hätte ich
gedacht.

Soll ich wirklich bloß jeweils von beiden nur die *.exe ausführen. Weil
ich hab mittlerweile soviel gelesen.
Zum Beispiel:
Rechtsklick auf die *.inf Dateien und dann Install auswählen ...

Ich kenne mich gar nicht mehr aus und bin auch schon genervt, wenn du
mir noch eine kleine Anleitung für Dummies :-) geben könntest, wäre
toll . Danke schon mal

Autor: Steffen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Allzu oft muss ich mich damit auch nicht abquälen. Man sollte und kann
auch nur einen der beiden Treiber für ein Gerät verwenden. Auf dem PC
können beide Treiber installiert sein. Ein Gerät X braucht z.B. den
VCP-Treiber und das Gerät Y den D2XX-Treiber. Unterschieden werden die
Geräte bei gleicher VID und PID über die Seriennummer des Gerätes. Bei
älteren FTDI-Chips war diese meines Wissens nach immer gleich. Da
könnte es ohne externes EEPROM Probleme geben aber bei den neueren
denke ich ist dort eine einmalige Seriennummer vergeben.

BEim Anstecken des Gerätes an den USB sollte es automatisch als neue
Hardware erkannt werden. Bei der Installation wählst du dann manuell
den VCP-Treiber oder den D2XX-Treiber für dieses Gerät aus. Dafür gibt
es eine recht gute Anleitung mit Abbildungen auf der Homepage von
FTDI.

Im Gerätemanager der Systemsteuerung kannst du dann den Treiber auch
ändern (Eigenschaften -->Treiber aktualisieren).

Die *.exe ist die Deinstallationsroutine für die Treiber. Die darfst du
auf keinen Fall ausführen! Es sei denn, du willst die Treiber
entfernen.

Installiere erst einmal den VCP-Treiber und dann über den Gerätemanager
den D2XX-Treiber für das Gerät.

Ich hoffe, dass hilft dir etwas weiter. Der Experte in Bezug auf FTDI
bin ich auch nicht aber bisher habe ich es immer zum Laufen gebracht.

Autor: Wigenstaxi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo.

Ich habe Euren Schriftverkehr verfolgt und habe ein ähnliches Problem. 
Nur mir fehlt der Treiber (FT232BM) komplett. Ich habe ihn auf 
irgendeiner CD gehabt und finde Ihn nicht. Auf der FTDI Seite gibt es 
nur noch den FT232B und ich bin nicht so erfahren ob der auch geht. 
Meine Geschicht ist etwas ausführlicher, womit ich Euch nicht belasten 
möchte. Ich habe bei weitem nicht Eure Kenntnisse zu dieser Technik. Ich 
suche einfach nur den Treiber um meine CNC Fräse wieder zum laufen zu 
bekommen. Gibt es im allgemeinen Probleme mit dem  Chip und dem Treiber? 
Meine Fräse macht jetzt nur Dummheiten und ich vermute es liegt an dem 
Treiber oder am Chip.

Gruß WT

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.