mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ISP Adaptder funktioniert nicht mehr


Autor: Robert S. (razer) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo an alle

Seit gestern Abend funktioniert mein ISP Adapter nicht mehr. Win AVR
spuckt bei flashen immer eine Fehlermeldung aus:

> "make.exe" program
avrdude -p atmega8 -P lpt1 -c stk200 -U flash:rechner.hex

avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.


avrdude done. Thank you.

make.exe: *** [program] Error 1

> Process Exit Code: 2

Es scheint, alsoirgendwas mit dem Progger nicht stimmt. Ich hab aber
nichts geändert. Die Platine sitzt geschützt in einem Gehäuse.

Was ist da los??

Mit Bascom bekomm ich auch keine Verbindung

Durchgeklingelt hab ich bereits alles...

Kann ich irgendetwas messen?? Oszi hab ich leider keins

Ich hoffe jemand kann mir helfen

Danke im Voraus

Gruß Robert

Autor: Conlost (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

benutzt du die serielle oder parallele Schnittstelle noch für andere
Zwecke?
Kann sein, das da noch etwas anderes an der Schnitstelle hängt.

Es grüsst,
Arno

Autor: Robert S. (razer) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Arno

Der ISP Adapter hängt am LPT1. Da hängt nur der Progger. LPT1 wird
sonst von keinem Prgramm. Gestern hat alles noch sauber funktioniert.

Gruß Robert

Autor: Robert S. (razer) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo an alle

Ich hab hier einen Oszillator mit 8 Mhz gefunden. KAnn ich mit diesem
den Mega 8 testen??

Danke im Voraus

Gruß Robert

Autor: Conlost (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Robert,

hast du in der Zwischenzeit etwas an deinem Rechner geändert?
Eventuell mal mit einem Drucker testen ob der Parallelport
ansprechbar ist.
Der Stecker steckt hoffentlich noch richtig drin.   ;-)

Es grüsst,
Arno

Autor: Robert S. (razer) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Arno

Wie kann ich den LPT testen?? LPT drucker hab ich keinen (nur USB).
Kann irgendwie über Windows testen on die LPT Schnittstelle
funktioniert?

Gruß Robert

Autor: Conlost (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was wilst du denn mit dem Oszillator testen?
Falls du die Fuses falsch gesetzt hast, dann kannst du
den Oszillator an XTAL1 anschließen und dann die Fuses
richtig setzen.

Es grüsst,
Arno

Autor: Uwe Große-Wortmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ISPs reagieren teilweise allergisch auf Crossposter... alles unter 2
Stunden ist da sehr kritisch...

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo?! Willst du jetzt halbstündlich die Frage wiederholen?

Autor: Robert S. (razer) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorry, da is was passiert was ich nicht wollte. Der letzte Post von mir
war ungewollt.

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

stimmt, sowas kann leider beim Vor und Zurück im Browser etc. mal
passieren. Nevermind.

Windows hat afaik keinen eingebauten Selbsttest für die LPT. Aber die
Meldung besagt ja, dass es Probleme mit dem AVR, nicht mit dem Progger
gibt?! An den Fuses rumgefummelt?

Autor: Robert S. (razer) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Thomas

Nein an den Fuses hab ich gar nichts eingestellt.

Gruß Robert

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.