mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Phasenanschnitt


Autor: Florian Janker (jankerf)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Wir haben eine Print gebaut mit der wir über Solid State Relais dimmen
wollen, jedoch funktioniert unsere Software nicht wirklich mit dem
Print gemeinsam,
Wir bekommen über die IRQ0 den Nulldurchgang rein.
Wir wollen dann Phasen anschnitt so betreiben dass wir bei ND für eine
gewisse zeit (5ms, da Periodendauer 20ms)  einschalten und dann wieder
ausschalten und das immer wieder
die SSR sind an PORTA vom ATmega16

Das ist unser Prog im anhang, funkt leider nicht: (IN AVR STUDIO4) (CPU
CLK 3,68 MHz)

mfgg Florian

Autor: johnny.m (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das was Du da beschreibst klingt mir eher nach Phasenabschnitt und nicht
Phasenanschnitt. Es wäre überdies SEHR hilfreich, wenn Du mal
beschreiben könntest, WAS da nicht funktioniert.

Autor: Florian Janker (jankerf)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vorerst Danke!

Also das Relais schaltet ein (erkennbar an vorgeschaltene LED)und aus
(schwer ersichtlich da 50Hz).  jedoch die Lampe dahinter ist immer
Konstant hell obwohl eigentlich die Hälfte der oberen Sinus welle
fehlen müsste. Wir kommen nicht drauf an was es liegt denn theoretisch
müsste es ja funktionieren od.?

Autor: Florian Janker (jankerf)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
tschuldigung bei der obere und unter Sinuswelle müsste die Hälfte fehlen

Autor: Hubert.G (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schon eine zweite Lampe mit voller Ansteuerung zum vergleich
dazugeschaltet?
Falls du das Programm erweitern willst, in einer ISR wartet man nicht.
Verlege die Warteschleife nach aussen ins while(1).

Autor: Unbekannter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schaltplan?!?!

Autor: Unbekannter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Wir haben eine Print gebaut mit der wir über Solid State
> Relais dimmen wollen,

Ach, kann das Solid-State-Relais überhaupt dimmen? Was sagt das
Datenblatt zu dieser Idee?

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo


wenn ihr im Solid-State-Relais einen Triac habt dann bleibt der
gezündet bis zum Nulldurchgang. Deshalb brennt die Lampe wenn ihr im
Nulldurchgang zündet dauernd.

Autor: Vorn Nachn (eprofi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
SSRs haben oft Nulldurchgangsschalter (ZC, Zero-Crossing), da ist nichts
mit Dimmen, bestenfalls noch Pulspaketsteuerung (für Lampen kaum
geeignet).
Du brauchst einen MOC20xx ohne ZC und einen dicken Triac.
Suche mal im Forum unter  Dimmer  oder  Phasenanschnitt  .

Autor: Florian Janker (jankerf)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die Vorschläge!!!!

Werde die schaltung nochmals überprüfen und hoffe es funkt dann!

also Danke für eure Hilfe!!

mfg Flo

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.