mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ENC28J60 und AVR - Level Shift


Autor: Thomas S (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

eine Frage zur Kombination ENC28J60 und ATmega32:

braucht man die Pegelumsetzung auf dem SPI wirklich??? Meine Platine
habe ich brav nach ENC-Datenblatt mit einem 74HCT08 aufgebaut, der AVR
läuft mit 5V. Klappt auch. Nachdem ich aber sowieso nur die
MISO-Leitung verwende, habe ich nach ner Möglichkeit gesucht,
Platinen-Platz zu sparen, mit Transistoren gespielt usw.. Beim Lesen
des AVR-Datenblatts fiel mir aber jetzt auf, daß dort für Input High
Voltage steht Min. 0.6Vcc, das sind 3V. 3.3V ist also sowieso 10%
drüber. Ggf. könnte man den ENC auch noch mit 3.4V betreiben, um mehr
Reserve zu haben.

Jedenfalls habe ich den 74HCT08 einfach mal rausgenommen und die MISO
direkt verbunden, und siehe da: Seit zwei Stunden schon läuft das Ganze
wunderbar ohne irgendeinen erkennbaren Fehler.

Deshalb die Frage: Gibt es irgendeinen Grund, warum es fehlerträchtig,
gefährlich oder sonstwie unklug wäre, die beiden weiterhin direkt zu
verbinden?

Thomas

Autor: ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die EMV-Empfindlichkeit ist schlechter und die Stromaufnahme steigt wenn
ein Eingang nicht auf GND oder VCC liegt.

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Steht im Datenblatt zum ENC28J60 nicht drin, das die SPI-Pins 5V
tollerant sind?

Wenn ich mich nicht total irre und das so ist, sollte das mit dem
direkt anschließen kein Problem sein. Man muß halt nur die Versorgung
der beiden ICs getrennt ausführen.

Autor: Thomas S (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Um 5V-tolerant geht es hier nicht, das ist die andere Richtung, die hab
ich sowieso direkt angeschlossen. Die Frage ist, ob es zu Problemen
kommen kann, wenn der AVR-Eingang nur 3.3V als High bekommt.

@Ralf: Stromverbrauch wäre mir nicht so wichtig. EMV - meinst Du, daß
auf den 1-2 cm Leiterbahn derart starke Einstreuungen auftreten können,
daß es zu Fehlern kommen kann? Am SPI ist sonst nichts dran und ich
hatte nicht vor, das Ding in nem Umspannwerk zu betreiben :)

Thomas

Autor: Nik Bamert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit nem Avr eigentlich kein Problem, zumindest läufts bei mir, auch die
3.3Volt vom ENC richtung Avr :-)

Nik

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ups, da habe ich wohl nicht richtig gelesen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.