mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik PLL SAA1057 + FM Modul 1890


Autor: Sascha Bishop (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

ich bin gerade im Bau eines FM Radios mit folgenden Komponenten.
Schaltpläne

FM Modul 1890 (von Pollin)
SAA1057 PLL
PIC 16F876
Inkrementalgeber zur Eingabe
Und LCD zur Ausgabe

Habe alles wunderbar am laufen. Bis auf den besch.... PLL Baustein.
Die Senderansteuerung funktioniert (Word A) Auch die Initialisierung
(Word B) funktioniert. Mein Problem liegt am Tiefbassausgang der PLL.
Egal welche gängigen Werte ich benutze Schwingt sich die PLL immer auf
eine gewisse Spannung ein.

Meine Frage wäre hat jemand schon mal die SAA1057 PLL in funktion eines
Radiotuners benutz?

Ich wäre Euch für jeden Hinweis dankbar!

Gruß Sascha

Autor: Sascha Bishop (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Übrigens meine ich den Ausgang an Pin 5 und 6. Anbei mal das Datenblatt.

Autor: Bastler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi ich bau gerade ein ähnliches Projekt, mit dem gleichen Tunermodul und 
auch dem SAA1057, ich verwende jedoch als Mc nen Atmega.

Bei mir funktioniert die Pll auch nicht richtig, ich hab mittlerweile 
nach etlichen Versuchen den Verdacht, dass das Modul und der Saa nicht 
kompatibel zueinander sind.

Liegt bei dir auch immer so um die 0,4V Tuningspannung an, manchmal 
sinds auch 1,4V.

Autor: Tomtom (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Funktioniert der Pollin-Tuner mit einer variablen Spannung (Poti, 1,5 - 
7,5V) an Pin 12? Und was kommt dann am Pin OSC out raus?  Reduzier mal 
die Betriebsspannung vom 1890 auf 9 Volt und lass den Pull-Up an 
TuningVoltage weg. Sonst passt die Dimensionierung. Stimmt die 
Initialisierung? Was passiert an Pin 18 vom 1057, wenn Du im Word B 
T0..T3 setzt? Die Kombination 1890/SAA1057 läuft definitiv.
Tom

Autor: Tomtom (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Bastler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
den Pin 18 kann ich leider nicht testen, da mir ein Ozilloskop fehlt, 
ich hab die Schaltung nach der hier aufgebaut 
http://www.pira.cz/pll.htm. das Modul betreibe ich bereits mit 9V. Das 
Programm müsste eigentlich auch richtig sein.

Autor: Bastler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorry für den Doppelpost, die Abstimmung per Poti funktioniert 
einwandfrei.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.