mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Ext Interrupt AtMega128


Autor: Andreas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute ich habe folgendes Problem....

Ich versuche über einen ext. Interrupt die Zeit zwischen mehreren
Flanken zu messen...(ich weiss es gibt da eine capture funktion..ich
will es aber selbst machen) jedenfalls habe ich den Ext Int 2 über das
Register EICRA ISC0 auf fallende Flanke eingestellt. Danch wird der
Interrupt über das Register EIMSK bit INT2 freigeschaltet. Frage :
Warum bekomme ich dauernd einen interrupt wenn der Pegel auf Low liegt.
Ich habe schon im Datenblatt nachgeschaut und gelesen dass der INT Pin
als Output eigestellt werden muss... habe ich auch gemacht passiert
nichts.

Autor: johnny.m (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>...INT Pin als Output eigestellt werden muss...

Wo steht die Weisheit denn?

Und wenn Du den INT2 benutzt musst Du auch die ISC2...Bits einstellen
und nicht die ISC0...

Autor: Andreas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
When an INT7 – INT0 bit is written to one and the I-bit in the Status
Register (SREG) is
set (one), the corresponding external pin interrupt is enabled. The
Interrupt Sense Control
bits in the External Interrupt Control Registers – EICRA and EICRB –
defines
whether the external interrupt is activated on rising or falling edge
or level sensed.
------>Activity on any of these pins will trigger an interrupt req-uest
even if the pin is enabled as an output. <-----This provides a way of
generating a software interrupt.

Auszug aus dem Datenblatt.

Natürlich habe ich ISC2 "0" gesetzt und ISC2 "1" gelöscht

Autor: johnny.m (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>...even if the pin is enabled as an output.
Weißt Du, was 'even' heißt? Abgesehen davon hast Du oben geschrieben,
dass Du die ISC0x-Bits gesetzt hast. Die gehören aber nun mal zum
Externen Interrupt 0 und nicht zum INT2! Wenn die ISC2x-Bits 0 sind,
hast Du einen Level-Interrupt.

Autor: johnny.m (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach ja, wenn der Pin als Output mit High-Pegel programmiert ist und Du
ziehst ihn extern niederohmig auf Masse, gibts nen satten
Kurzschluss...

Autor: johnny.m (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey, vom doppelt posten wirds auch net besser...

Autor: Andreas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ups.. sorry für das neuladen

Autor: Andreas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ehm trotzdem geht nichts ... hab den
PD2 als Input, ISC20=1 und ISC21=0 und INT2 =1 d.h. Interrupt bei
fallender Flanke.... Mein Signal ist halt dauerhaft "0" bis die
ersten Rechtecke kommen(Was ich mit einen knopfdruck starte) trotzdem
kommt immer ein Interrupt

Autor: johnny.m (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Pullup eingeschaltet?

Autor: Andreas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja und geht trotzdem nicht kommt immer ein int

Autor: Andreas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hab jetzt mein signal invertiert damit es aktiv Hi ist.

jetzt kommt kein Int mehr ??!

Autor: Johannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

Ich habe im Moment auch Probleme mit dem INT2 auf PORTD. Falls du deinen 
UART1 aktiviert hast zeigt der Pin INT2 ebenfalls an, ob ein UART1 
Receive Complete ist. Das könnte ebenfalls zu Problemen führen..

Gruß Johannes

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.